Subject: Techdocs bug ... new page is instantly lost

From: Josh Berkus <[email-masked]>
Date: Tue, 19 Jun 2007 16:40:00 -0700

Techdocs home page
Create subpage
Give it name and short name
Add contents
Save
Go to wwwmaster
Approve
Go back to Techdocs

Can't find new page.  Where did it go?  How do I link to it? 

-- 
--Josh

Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Dave Page <[email-masked]>
Date: Wed, 20 Jun 2007 08:44:40 +0100

> Can't find new page.  Where did it go?  How do I link to it? 

Josh,

My guess is that it's on wwwmaster, but when you went back to techdocs
you were auto bounced to one of the static servers which wouldn't
necessarily get the new page for an hour or so - and even then it would
need to be linked first before the spider would see it.

So; Josh - make sure you check for the new page on wwwmaster, not www,
and use the Force when you link to it. You know it's there really :-)

Magnus - Should we have a auto-generated master index of pages someplace
to ensure everything gets spidered?

Regards, Dave

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 21 Jun 2007 11:58:55 +0200

> to ensure everything gets spidered?

The pages are all linked autoamtically from the menu on the parent page, so
there should be no need to create a separate index for *that* reason. If
there are other reasons, it could still be done of course :-P

//Magnus

---

From: Josh Berkus <[email-masked]>
Date: Tue, 26 Jun 2007 08:32:42 -0700

Magnus,

> there are other reasons, it could still be done of course :-P

Apparently not.  There are several existing pages which aren't linked.  My 
guess is that this index stopped building some time ago.

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 26 Jun 2007 18:27:51 +0200

> guess is that this index stopped building some time ago.

Can you give me a direct link for one of them so I can investigate? (or
the link that should work, if it doesn't)

//Magnus

---

From: Josh Berkus <[email-masked]>
Date: Tue, 26 Jun 2007 12:32:44 -0700

Magnus,

> the link that should work, if it doesn't)

That's the problem, I don't have a link.  The system doesn't return the ID of 
the newly approved page.  So how am I supposed to find it?

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 26 Jun 2007 21:41:26 +0200

> the newly approved page.  So how am I supposed to find it?

Ah, ok. Got a title of the page that got lost then?

//Magnus

---

From: Josh Berkus <[email-masked]>
Date: Wed, 27 Jun 2007 18:36:45 -0700

Magnus,

> Ah, ok. Got a title of the page that got lost then?

"Events"

I'm putting it on the developer wiki at this point, though.  So just delete 
it.

-- 
Josh Berkus
PostgreSQL @ Sun
San Francisco

---

From: Magnus Hagander <[email-masked]>
Date: Fri, 29 Jun 2007 16:44:46 +0200

> I'm putting it on the developer wiki at this point, though.  So just delete 

Are you referring to "Community Events", that's perfectly accessible at
http://www.postgresql.org/docs/techdocs.80 ?

//Magnus