Subject: Re: [pgsql-advocacy] We need an Advocacy wiki

From: "Dave Page" <[email-masked]>
Date: Sat, 4 Aug 2007 20:32:03 +0100

> ------- Original Message -------
> From: Neil Conway <[email-masked]>
> To: Dave Page <[email-masked]>
> Sent: 04/08/07, 19:59:29
> Subject: Re: [pgsql-advocacy] [pgsql-www] We need an Advocacy wiki
> 
> On Sat, 2007-04-08 at 19:30 +0100, Dave Page wrote:
> > Screenreaders cannot read the images.
> 
> Since the goal is to simplify signups in the common case, can't we just
> provide a means for people to email the admins and have an account
> created if they can't use the captcha?

We could do that, though there is a weaker argument that it would still be discriminatory because the disabled used cannot participate instantly, or without drawing attention to his or her disability.

One trend in UK anti-discrimination laws of late is that the question of whether or not discrimination has or has not occurred is almost entirely down to the victim - ie. if *they* feel they have been discriminated against, there is a case to be heard (though not necessarily to be won of course).

> > Many of the bigger sites (eg. Paypal) offer audio versions of the images
> 
> To play the devil's advocate, ISTM this still discriminates against the
> deaf-blind.

You have to draw the line somewhere about how far it is reasonable to take these things. Ever heard (better yet, seen the video) Metallica's 'One'? Would it be reasonable to make the site accessible for that poor guy? 

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Sun, 5 Aug 2007 09:29:46 +0100

> From: "Joshua D. Drake" <[email-masked]>
> Sent: 05/08/07, 00:58:19
> It isn't difficult, it is unexpected. You don't manage content via
> webmaster@, that is stupid. We are not talking about one off edits for a
> spelling mistake here. 

Right, now you twisting what we we're talking about. You asked how people get changes made if even you didn't know what to do.

I said they mainly email webmaster, which isn't an opinion about what should happen. It is fact, it does happen regularly.

>Now I would concur that -www would make
> reasonable sense, but my point, was that we might have a perception
> problem. 

*We* interact on -www when something is more than a simple action item, and I'd expect you to mail any requests there because you are well aware that that is where we discuss web stuff. Everything else can and does feed in via webmaster.

> I was trying to be helpful and I repeat:
> 
> Where is the, "How to contribute to the PostgreSQL.Org website HOWTO?".
> 
> If it doesn't exist, does it by chance make sense to have one? If not,
> why not? It isn't like this is the first time people have brought up the
> point that it isn't as easy as it could be to contribute to the website.

The technical howto is in the root of the source. I don't recall ever being asked for a non-technical howto.

If you feel we need a faq or doc item to tell ppl how to join -www and get started, please feel free to write a patch for the developer faq or raise the issue on -www if you feel it should go elsewhere on the website.

/D

---

From: "Dave Page" <[email-masked]>
Date: Sun, 5 Aug 2007 17:03:09 +0100

> Sent: 05/08/07, 16:35:58
> We could pray and hope but then reality would crush us ;)

Damn that reality, getting in the way again!

/D