Subject: www search behaviour

From: "Gevik Babakhani" <[email-masked]>
Date: Thu, 28 Feb 2008 01:47:43 +0100

I am trying to search for "to_char" in mailing archives but I get results
with "char". Is this correct?
Just try searching for "NON_EXEC_STATIC" and mixed results is shown.

Regards,
Gevik

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 28 Feb 2008 08:50:19 +0300 (MSK)

> Just try searching for "NON_EXEC_STATIC" and mixed results is shown.

We discussed this several times and know what to do. Seems, Magnus
is busy with other things

> Regards,
> Gevik
>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 5: don't forget to increase your free space map settings
>

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, Research Scientist, Head of AstroNet (www.astronet.ru),
Sternberg Astronomical Institute, Moscow University, Russia
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(495)939-16-83, +007(495)939-23-83

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 28 Feb 2008 09:25:25 +0100

> is busy with other things

Yeah, it's climbing up my TODO list...

//Magnus

---

From: "Gevik Babakhani" <[email-masked]>
Date: Thu, 28 Feb 2008 09:47:27 +0100

> Yeah, it's climbing up my TODO list...

Anything that I can do to help?

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 28 Feb 2008 11:54:34 +0300 (MSK)

> Anything that I can do to help?

Several variants:

1. Create custom parser for pgweb, which doesn't mean that '_' is a 
separator
2. Create synonym dictionary for pgweb, which lists all pg specific 
terms

1. is a most right way, 2. is a most easy way, just create word stats,
see all terms with '_' and create pgvars dictionary like
some_word some_word

Then created text search configuration , test it and give it to Magnus.
btw, Magnus, did you move to 8.3 ?

 	Regards,
 		Oleg

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 28 Feb 2008 09:57:34 +0100

> see all terms with '_' and create pgvars dictionary like

Didn't we also talk about option 3, a custom dictionary that strips the
underscores? Where could poteitnally use the regexp one as well?

If you do pt 2, I can put it in right away. It'll take a reindexing of the
whole db though. (Well, any of the options will)

> btw, Magnus, did you move to 8.3 ?

Yes, we're on 8.3. And it's great ;-)

//Magnus

---

From: Oleg Bartunov <[email-masked]>
Date: Thu, 28 Feb 2008 12:10:08 +0300 (MSK)

> underscores? Where could poteitnally use the regexp one as well?

I forget it :)

> Yes, we're on 8.3. And it's great ;-)

I'm busy, I and Teodor are going to Toulouse (France) btw. I think Gevik
could help you. Custom parser will be not difficult. About dictionary - 
http://vo.astronet.ru/arxiv/dict_regex.html, I'm not sure if it's ported
to 8.3. I'll ping author.

 	Regards,
 		Oleg

---

From: Richard Huxton <[email-masked]>
Date: Tue, 04 Mar 2008 11:06:32 +0000

> 1. Create custom parser for pgweb, which doesn't mean that '_' is a 

If it's of interest, I've got a custom parser here which is based on the 
default defined in wparser_def.c but includes an "identifier" type which 
allows underscores.

Bear in mind this is the first bit of C coding I've done in decades, but 
it's only tweaking the default parser and adapting it to a contrib/ 
format so I don't think I could have gone that far wrong.

-- 
   Richard Huxton
   Archonet Ltd

---

From: "Gevik Babakhani" <[email-masked]>
Date: Wed, 5 Mar 2008 08:48:34 +0100

> If it's of interest, I've got a custom parser here which is 
> based on the default defined in wparser_def.c but includes an 
> "identifier" type which allows underscores.

Would it be possible to share this code with us?

Regards,
Gevik.

---

From: Richard Huxton <[email-masked]>
Date: Wed, 05 Mar 2008 08:33:00 +0000

> Would it be possible to share this code with us?

Oh course - don't know if this list allows attachments, I'll send you a 
copy directly Gevik.

-- 
   Richard Huxton
   Archonet Ltd