Subject: Software catalog section improvements

From: "Greg Sabino Mullane" <[email-masked]>
Date: Mon, 16 Jun 2008 18:01:59 -0000

On the new Software Catalog er..."Catalogue" page, how does
one edit an existing entry? There is no contact email to
do so. While I know I can just bug Dave on this list, the
public should be told an email address.

I messed up entering "Spree", it should be under Applications
and has an open source, not a commercial license.

Also, it might be nice if the "Procedural Languages" section
mentioned that the builtin languages that are already available,
lest people stumble across this page and not be aware that
C, plpgsql, perl, python, and tcl are all available in core.

---

From: "Dave Page" <[email-masked]>
Date: Tue, 17 Jun 2008 08:56:38 +0100

On Mon, Jun 16, 2008 at 7:01 PM, Greg Sabino Mullane <[email-masked]> wrote:
>
> -----BEGIN PGP SIGNED MESSAGE-----
> Hash: RIPEMD160
>
>

Most people will simply email webmaster@ no? We don't list a contact
address on any other forms on the site that I can see.

> and has an open source, not a commercial license.

Fixed.

> C, plpgsql, perl, python, and tcl are all available in core.

There's no code for including additional text on each category at
present. We can either add that (noting that the admin interface for
categories is a highly advanced SQL based one) - patches welcome - or
add those languages to the list with a note saying they're in the core
product. Or consider it a non-issue.

Thoughts?

-- 
Dave Page
EnterpriseDB UK: http://www.enterprisedb.com

---

From: "Greg Sabino Mullane" <[email-masked]>
Date: Tue, 17 Jun 2008 23:29:46 -0000

> address on any other forms on the site that I can see.

I think there should be an email on all the form pages, or at the
last on a clearly marked contact page.

> Fixed.

Thanks!

> product. Or consider it a non-issue.

I'll take "Patches" for $100, Alex.

Index: portal/tools/add_products_blurb.sql
===================================================================
- --- portal/tools/add_products_blurb.sql       (revision 0)
+++ portal/tools/add_products_blurb.sql (revision 0)
@@ -0,0 +1,15 @@
+BEGIN;
+
+ALTER TABLE product_categories ADD blurb TEXT NOT NULL DEFAULT '';
+
+UPDATE product_categories SET blurb =
+$$Note: Postgres has four languages that are part of the core distribution:
+<a href="http://www.postgresql.org/docs/current/interactive/plpgsql.html">PL/pgSQL</a>,
+<a href="http://www.postgresql.org/docs/current/interactive/pltcl.html">PL/Tcl</a>,
+<a href="http://www.postgresql.org/docs/current/interactive/plperl.html">PL/Perl</a>,
+and
+<a href="http://www.postgresql.org/docs/current/interactive/plpython.html">PL/Python</a>.
+$$
+WHERE name = 'Procedural languages';
+
+COMMIT;
Index: portal/system/page/products.php
===================================================================
- --- portal/system/page/products.php   (revision 2127)
+++ portal/system/page/products.php     (working copy)
@@ -13,15 +13,17 @@
            throw new Exception(gettext('Category ID not specified'));
        }

- -       $rs = $this->pg_query_params('SELECT name AS category FROM product_categories WHERE id=$1', array(intval($_GET['id'])));
+       $rs = $this->pg_query_params('SELECT name AS cateogory, blurb FROM product_categories WHERE id=$1', array(intval($_GET['id'])));
        if (pg_num_rows($rs) == 0) {
            header('HTTP/1.0 404 Not found');
            throw new Exception (gettext('The specified category does not exist'));
        }

- -       $category = pg_fetch_result($rs, 0, 0);
+       $category = pg_fetch_result($rs, 0, 0);
+       $blurb = pg_fetch_result($rs, 0, 1);
        $this->tpl->setVariable('category_title', $category);
        $this->tpl->setVariable('category_header', $category);
+       $this->tpl->setVariable('category_blurb', $blurb);

        // Products
        $rs = $this->pg_query_params(
Index: portal/template/download/products.html
===================================================================
- --- portal/template/download/products.html    (revision 2127)
+++ portal/template/download/products.html      (working copy)
@@ -4,7 +4,7 @@

 <h1>Software Catalogue - {category_header}</h1>

- -<p>{product_count} product(s) were found in this category.</p>
+<p>{product_count} product(s) were found in this category. {category_blurb}</p>

 <!-- BEGIN product-loop -->

- --
Greg Sabino Mullane [email-masked]
PGP Key: 0x14964AC8 200806171927
http://biglumber.com/x/web?pk=2529DF6AB8F79407E94445B4BC9B906714964AC8

---

From: "Dave Page" <[email-masked]>
Date: Wed, 18 Jun 2008 10:07:54 +0100

> last on a clearly marked contact page.

Patches welcome :-) (well, it worked once, you can't blame a guy for
trying again!)

> I'll take "Patches" for $100, Alex.

Hah - bet you feel all dirty after playing in PHP!

Thanks, patch applied.