Subject: postini/mi8.com spamming the lists with regurgitated posts. Again.

From: Tom Lane <[email-masked]>
Date: Fri, 27 Jun 2008 23:56:58 -0400

Is there a way to not only purge the lists of these bozos, but prevent
future signups?  I've not only had enough of seeing them duplicating
posts onto the lists, I've had much more than enough of mail bounces
originating in their forging my address as envelope sender for such
regurgitations.  I suppose everyone else who posts to the lists gets
the same.  It's past time for a zero tolerance policy.

			regards, tom lane

------- Forwarded Message

Delivery-Date: Fri Jun 27 23:43:43 2008
To: [email-masked]
Subject: [COMMITTERS] pgsql: Fix standalone libpq build on win32.
Date: Fri, 27 Jun 2008 18:58:16 +0000 (UTC)
From: [email-masked] (Magnus Hagander)
Sender: [email-masked]
Reply-To: [email-masked]

Log Message:
-----------
Fix standalone libpq build on win32.

Hiroshi Saito

Tags:
----
REL8_3_STABLE

Modified Files:
--------------
    pgsql/src/interfaces/libpq:
        win32.mak (r1.50.2.1 -> r1.50.2.2)
        (http://anoncvs.postgresql.org/cvsweb.cgi/pgsql/src/interfaces/libpq/win32.mak?r1=1.50.2.1&r2=1.50.2.2)

-- 
Sent via pgsql-committers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers

-- 
Sent via pgsql-committers mailing list ([email-masked])
To make changes to your subscription:
http://www.postgresql.org/mailpref/pgsql-committers

------- End of Forwarded Message

---

From: "Marc G. Fournier" <[email-masked]>
Date: Sat, 28 Jun 2008 09:52:49 -0300

I just checked the lists, and find nothing for mi8/postini or obsmtp.com ... 
even checked globally (all lists), and nothing ...

And its all keyed on the From, which is Magnus ... I could ban him from the 
list? :)

This is where the duplicate checksum'ng is meant to come into play, but we have 
it disabled, for obvious reasons (key one: automated scripts that use the same 
commit message each time would then ben conssitently rejected) ...

- --On Friday, June 27, 2008 23:56:58 -0400 Tom Lane <[email-masked]> wrote:

> Return-Path: [email-masked]
> Received: from maia-1.hub.org (maia-1.hub.org [200.46.208.211])
> 	by sss.pgh.pa.us (8.14.2/8.14.2) with ESMTP id m5S3hhKi017005
> 	for <[email-masked]>; Fri, 27 Jun 2008 23:43:43 -0400 (EDT)
> Received: from postgresql.org (unknown [200.46.204.86])
> 	by maia-1.hub.org (Postfix) with ESMTP id 3AEB38F0D7A;
> 	Sat, 28 Jun 2008 00:43:34 -0300 (ADT)
> Received: from localhost (unknown [200.46.204.183])
> 	by postgresql.org (Postfix) with ESMTP id 5F0AD650EA4
> 	for <[email-masked]>; Fri, 27 Jun 2008
> 22:31:41 -0300 (ADT) Received: from postgresql.org ([200.46.204.86])
>  by localhost (mx1.hub.org [200.46.204.183]) (amavisd-maia, port 10024)
>  with ESMTP id 93909-02 for <[email-masked]>;
>  Fri, 27 Jun 2008 22:31:32 -0300 (ADT)
> X-Greylist: delayed 00:07:10.158774 by SQLgrey-1.7.6
> Received: from exprod6og102.obsmtp.com (exprod6og102.obsmtp.com [64.18.1.183])
> 	by postgresql.org (Postfix) with SMTP id AC82D650E7F
> 	for <[email-masked]>; Fri, 27 Jun 2008 22:31:37 -0300 (ADT)
> Received: from source ([63.240.6.3]) (using TLSv1) by
> exprod6ob102.postini.com ([64.18.5.12]) with SMTP; 	Fri, 27 Jun 2008 18:31:35
> PDT
> Received: from d01smtp07.Mi8.com ([172.16.1.114]) by Outbound02.Mi8.com with
> Microsoft SMTPSVC(6.0.3790.1830); 	 Fri, 27 Jun 2008 21:27:22 -0400
> Received: from D01SMTP04.Mi8.com ([172.16.1.243]) by d01smtp07.Mi8.com with
> Microsoft SMTPSVC(6.0.3790.1830); 	 Fri, 27 Jun 2008 21:27:23 -0400
> Received: from mail pickup service by D01SMTP04.Mi8.com with Microsoft
> SMTPSVC; 	 Fri, 27 Jun 2008 21:27:13 -0400
> Received: from psmtp.com ([64.18.1.142]) by D01SMTP04.Mi8.com with Microsoft
> SMTPSVC(6.0.3790.1830); 	 Fri, 27 Jun 2008 15:01:41 -0400
> Received: from source ([200.46.208.106]) by exprod6mx242.postini.com
> ([64.18.5.10]) with SMTP; 	Fri, 27 Jun 2008 14:58:36 EDT
> Received: from postgresql.org (unknown [200.46.204.86])
> 	by mx1.hub.org (Postfix) with ESMTP id A3DD8B08163;
> 	Fri, 27 Jun 2008 15:58:32 -0300 (ADT)
> Received: from localhost (unknown [200.46.204.183])
> 	by postgresql.org (Postfix) with ESMTP id 58F8E650EAA
> 	for <[email-masked]>; Fri, 27 Jun 2008
> 15:58:33 -0300 (ADT) Received: from postgresql.org ([200.46.204.86])
>  by localhost (mx1.hub.org [200.46.204.183]) (amavisd-maia, port 10024)
>  with ESMTP id 17942-01 for <[email-masked]>;
>  Fri, 27 Jun 2008 15:58:15 -0300 (ADT)
> Received: from cvs.postgresql.org (cvs.postgresql.org [217.196.146.206])
> 	by postgresql.org (Postfix) with ESMTP id 361BC650E91
> 	for <[email-masked]>; Fri, 27 Jun 2008 15:58:17 -0300 (ADT)
> Received: by cvs.postgresql.org (Postfix, from userid 1194)
> 	id 1AEBC754857; Fri, 27 Jun 2008 18:58:16 +0000 (UTC)
> MIME-Version: 1.0
> X-Mailer: activitymail 1.24, http://search.cpan.org/dist/activitymail/
> Content-Type: text/plain
> Message-Id: <[email-masked]>
> X-Virus-Scanned: Maia Mailguard 1.0.1
> X-Mailing-List: pgsql-committers
> Precedence: bulk
> X-pstn-neptune: 0/0/0.00/0
> X-pstn-levels:     (S:99.90000/99.90000 CV:99.0000 R:95.9108 P:95.9108
> M:97.0282 C:98.6951 ) X-OriginalArrivalTime: 27 Jun 2008 19:01:41.0786 (UTC)
> FILETIME=[3C3D47A0:01C8D888] X-Virus-Scanned: Maia Mailguard 1.0.1
> X-Mailing-List: pgsql-committers
> List-Archive: <http://archives.postgresql.org/pgsql-committers>
> List-Help: <mailto:[email-masked]?body=help>
> List-ID: <pgsql-committers.postgresql.org>
> List-Owner: <mailto:[email-masked]>
> List-Post: <mailto:[email-masked]>
> List-Subscribe: <mailto:[email-masked]?body=sub%20pgsql-committers>
> List-Unsubscribe:
> <mailto:[email-masked]?body=unsub%20pgsql-committers> Precedence:
> bulk
> Sent via pgsql-www mailing list ([email-masked])
> http://www.postgresql.org/mailpref/pgsql-www

- -- 
Marc G. Fournier        Hub.Org Hosting Solutions S.A. (http://www.hub.org)
Email . [email-masked]                              MSN . [email-masked]
Yahoo . yscrappy               Skype: hub.org        ICQ . 7615664

---

From: Magnus Hagander <[email-masked]>
Date: Sat, 28 Jun 2008 15:02:50 +0200

Can you perhaps track it down through the logfiles on the MX machine,
using the ESMTP id of the last hop out of postgresql.org/hub.org?

Since it appears to be a mail hosting company who *also* happens to use
postini/google for their antispam, it can be pretty much any domainname
at all, I think... And we can't very well null-route any address who
uses postini as their relayers, becuase loads of legit users do that...

//Magnus

Marc G. Fournier wrote:
> --On Friday, June 27, 2008 23:56:58 -0400 Tom Lane <[email-masked]> wrote:
>