Subject: Re: [webmaster] mirror of postgresql.org

From: Robert Treat <[email-masked]>
Date: 08 Oct 2003 08:46:58 -0400

Hey David, sorry for the slow reply, we've all been ridiculously busy
lately. If we haven't run you off, here's the info we need to set you up
as a mirror:

IP address of mirror server
Port number if non-standard
Hostnames/ip addresses of 1 or 2 machines that you will use to rsync the
site. For most sites this will be the same as the server.
 
In addition, ftp mirrors may have a path to the mirrored content.
 
In order for website mirrors to work, you must be able to setup a
virtual host on your server.
 
Please let us know what type of mirror (or both) you wish to host, and
what the appropriate details are.

thanks in advance,

Robert Treat

On Tue, 2003-09-30 at 00:40, David Wilcox, Ilisys Web Hosting wrote:
> Hi,
> I work for a web hosting company based in Perth, Western Australia.  We 
> have a server that is dedicated to hosting mirrors of opensource type 
> sites.  Currently we have mirrors of;
> www.cpan.org
> www.gnu.org
> www.jabber.org.au
> www.mysql.com
> www.opensource.org
> www.php.net
> www.python.org
> www.qmail.org
> www.tldp.org
> 
> We also have mirrors of the binaries from;
> Apache
> OpenOffice.org
> Proftpd
> PuTTY
> 
> I am intereseted in adding postgresql.org to our list of mirrors and would 
> greatly appreciate if you could supply more information or point me to 
> pages on postgresql.org that go into more detail on this.
> 
> 
> Regards,
> Dave Wilcox
> Technical Support Officer
> tel: +61 8 9289 9700
> fax +61 8 9289 9711
> 1-800-999-618
> 
> Ilisys Web Hosting
> http://www.ilisys.com.au/
-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "David Wilcox, Ilisys Web Hosting" <[email-masked]>
Date: Wed, 29 Oct 2003 16:19:49 +0800

Dear Robert,
Also sorry for the delay, I've been lumbered into a sales role for the last 
couple of weeks, yada, yada, yada, real busy too.
I've got the virtual host ready;

<VirtualHost 203.202.10.60>
         ServerAdmin [email-masked]
         DocumentRoot /home/postgresql
         ServerName postgresql.mirrors.ilisys.com.au
         ServerAlias www.postgresql.mirrors.ilisys.com.au
         ScriptAlias /cgi-bin/ /home/postgresql/cgi-bin/
         CustomLog /home/logs/postgresql.mirrors.ilisys.com.au-access_log 
ilisys-log
</VirtualHost>

This is the basic syntax (from a crontab) that I use for updates;
7 4 * * * rsync -avzC --timeout=600 --delete --delete-after 
rsync.php.net::phpweb /home/php > /dev/null 2>&1

What is the address I should use to rsync postgresql.org?

Anything else you need?

Regards,
David Wilcox

Regards,
Dave Wilcox

Ilisys Web Hosting