Subject: Sudden JVM crashes - a Postgres driver problem?

From: Robert Sösemann <[email-masked]>
Date: Thu, 13 Oct 2005 13:07:37 +0200

Hello,

we have a really tricky problem while running our web-application:

The JVM crashes from time to time for no apparent reason.
There seems to be no direct relation to any user-action, 
method-call or whatever.

We've checked the JVM crash dumps, but were not able to find something suspicious. The only ideas we've come up, were the 
usual suspects: JNI-calls and JDBC-Type2-drivers.

This is our current setup:
- JVM 1.4.2_09 on Linux SuSE 9.3
- mysql-database 4.1.14-max with 
- mysql-connector-java-3.0.14-production driver
- postgresql-database 8.0.3 with postgresql-8.0-312.jdbc3 driver

The only JNI-calls that I know of, is through some 3rd party UUID-library from "org.doomdark.jug". Maybe the forementioned 
jdbc-drivers contain JNI-calls, despite being Type4-drivers.

I've also checked a bunch of mailing-lists and it seems there are some outstanding bugs in hotspot, that may trigger the 
crash. Does anybody have more information or a workaround for this?

Who can help? Thanks in advance!

Robert
Leiter Softwareentwicklung
________________________________________

Gölz & Schwarz GmbH 
Waltherstr. 29, 80337 München, Germany 
phone: + 49 - (0)89 / 54 46 70 - 0 
fax: +49 - (0)89 / 54 46 70 - 10 
e-mail: [email-masked] 
web: http://www.goelz.com 
________________________________________
Sie suchen den aktiven Dialog mit Ihren Kunden? Sie möchten neue Wege gehen, um
Ihre Zielgruppen online zu motivieren und zu binden? Dann haben wir genau das Richtige
für Sie: Marketing Suite - die Komplett-Lösung für intelligentes Online Marketing!
Informationen zur Marketing Suite erhalten Sie unter http://www.goelz.com/marketingsuite.

---

From: "Magnus Hagander" <[email-masked]>
Date: Thu, 13 Oct 2005 13:14:21 +0200

Hello!

I think you'll want to redirect this to the JDBC list. This list is about discussing the postgresql website itself. See http://jdbc.postgresql.org/lists.html.

//Magnus

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Robert Sösemann
> Sent: Thursday, October 13, 2005 1:08 PM
> To: [email-masked]
> Subject: [pgsql-www] Sudden JVM crashes - a Postgres driver problem?
> 
> Hello,
> 
> 
> We've checked the JVM crash dumps, but were not able to find 
> something suspicious. The only ideas we've come up, were the 
> The only JNI-calls that I know of, is through some 3rd party 
> UUID-library from "org.doomdark.jug". Maybe the forementioned 
> I've also checked a bunch of mailing-lists and it seems there 
> are some outstanding bugs in hotspot, that may trigger the 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 2: Don't 'kill -9' the postmaster
>

---

From: Robert Sösemann <[email-masked]>
Date: Thu, 13 Oct 2005 13:16:47 +0200

Thanks, you are right. Didn't realize that there is a list of this name.
R.

-----Ursprüngliche Nachricht-----
Von: Magnus Hagander [mailto:[email-masked]] 
Gesendet: Donnerstag, 13. Oktober 2005 13:14
An: Robert Sösemann; [email-masked]
Betreff: RE: [pgsql-www] Sudden JVM crashes - a Postgres driver problem?

Hello!

//Magnus

> The JVM crashes from time to time for no apparent reason. There seems 
> to be no direct relation to any user-action, method-call or whatever.
> 
> Leiter Softwareentwicklung ________________________________________
> 
> Gölz & Schwarz GmbH