Subject: New News Entry

From: [email-masked] (World Wide Web Owner)
Date: Fri, 4 Jun 2004 09:58:51 -0300 (ADT)

A new entry has been added to the news database.

Database Admin: http://www.postgresql.org/admin/edit_news.php?196

Submitted by: [email-masked]
Headline: phpPgAdmin 3.4 Released
Summary:

A new major version of phpPgAdmin is now available. phpPgAdmin is a web-based administration tool for all 7.x versions of PostgreSQL.

Story:

A new major version of phpPgAdmin is now available. phpPgAdmin is a web-based administration tool for all 7.x versions of PostgreSQL.

New features include:

* Add CACHE and CYCLE parameters in sequence creation
* View, add, edit and delete comments on tables, views, schemas, aggregates, conversions, operators, functions, types, opclasses, sequences and columns (Dan Boren & ChrisKL)
* Add config file option for turning off the display of comments
* Allow creating array columns in tables
* Allow adding array columns to tables
* Allow creating domains with type length and arrays
* Show domain base type and comment in domains list
* Allow import of CSV, Tabbed and XML data.  \"Auto\" mode chooses import mode based on the file extension.
* Allow upload and execution of _basic_ SQL scripts
* More admin features available: vacuum, analyze, cluster all and reindex (with all options) (Bryan Encina)
* Fix SQL popup window to reload when the database is changed so that the correct page encoding is used.
* Create view wizard (Bryan Encina)
* Allow specification of MATCH, DEFERRABLE and INITIALLY DEFERRED on foreign keys.
* Automatically uncheck the NULL checkbox when data is typed in the value field while editing data.
* Show query runtime when executing arbitrary SQL
* Allow renaming functions when backend supports it
* Views are now more like tables.  They are listed in the browser, you can view the virtual columns of the view and its column defaults. Columns in view can also be renamed and have defaults set.
* Allow viewing, dropping and creation of rules on views.
* Support for 7.5-dev ALTER COLUMN TYPE, adding of SERIAL and BIGSERIAL columns, adding NOT NULL columns and adding columns with defaults.

Download it now:

http://phppgadmin.sourceforge.net/?page=download

---

From: "Dave Page" <[email-masked]>
Date: Fri, 4 Jun 2004 14:02:20 +0100

Thanks, approved.

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of World 
> Wide Web Owner
> Sent: 04 June 2004 06:07
> To: [email-masked]
> Subject: [pgsql-www] New News Entry
> 
> Database Admin: http://www.postgresql.org/admin/edit_news.php?195
> 
> Submitted by: [email-masked]
> Headline: SRA America Releases Win32 Version of PostgreSQL
> Summary:
> 
> SRA America has released an English version of its very 
> popular PowerGres port of PostgreSQL to Windows.
> 
> Story:
> 
> SRA America has released an English version of its very 
> popular PowerGres port of PostgreSQL to Windows.  The release 
> is available right now for download and can be used for free 
> for a 60-day trial period:
> 
>         http://www.sraapowergres.com
> 
> SRA America is also offering world-wide support, consulting, 
> and training for all versions of PostgreSQL.  Please contact 
> them for more details.
> 
> 
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 9: the planner will ignore your desire to choose an index 
> scan if your
>       joining column's datatypes do not match
> 
>

---

From: "Dave Page" <[email-masked]>
Date: Fri, 4 Jun 2004 14:02:38 +0100

Thanks, approved. 

> Sent: 04 June 2004 13:59
> A new major version of phpPgAdmin is now available. 
> phpPgAdmin is a web-based administration tool for all 7.x 
> versions of PostgreSQL.
> 
> Story:
> 
> A new major version of phpPgAdmin is now available. 
> phpPgAdmin is a web-based administration tool for all 7.x 
> versions of PostgreSQL.
> 
> New features include:
> 
> * View, add, edit and delete comments on tables, views, 
> schemas, aggregates, conversions, operators, functions, 
> types, opclasses, sequences and columns (Dan Boren & ChrisKL)
> * Allow import of CSV, Tabbed and XML data.  \"Auto\" mode 
> chooses import mode based on the file extension.
> * More admin features available: vacuum, analyze, cluster all 
> and reindex (with all options) (Bryan Encina)
> * Fix SQL popup window to reload when the database is changed 
> so that the correct page encoding is used.
> * Views are now more like tables.  They are listed in the 
> browser, you can view the virtual columns of the view and its 
> column defaults. Columns in view can also be renamed and have 
> defaults set.
> * Support for 7.5-dev ALTER COLUMN TYPE, adding of SERIAL and 
> BIGSERIAL columns, adding NOT NULL columns and adding columns 
> with defaults.
> 
> Download it now:
> 
> TIP 2: you can get off all lists at once with the unregister command
>     (send "unregister YourEmailAddressHere" to 
> [email-masked])
> 
>