Subject: Re: [translators] [Fwd: Re: PostgreSQL 8.1.0 Release is a Go ...]

From: "Dave Page" <[email-masked]>
Date: Tue, 8 Nov 2005 14:58:36 -0000

________________________________

	From: [email-masked]
[mailto:[email-masked]] On Behalf Of Samer Abukhait
	Sent: 08 November 2005 14:49
	To: [email-masked]; [email-masked]
	Subject: Re: [pgsql-www] [translators] [Fwd: Re: PostgreSQL
8.1.0 Release is a Go ...]

	Guys,
	the arabic page
http://www.postgresql.org/about/press/presskit81.html.ar
	need to be RTL'ed
	it is not readable in LTR direction.

Hmm, not sure how to fix that, knowing little about these issues myself.
The site certainly /thinks/ it's got to display it in rtl, and does
write the html tag accordingly:
 
<html xmlns="http://www.w3.org/1999/xhtml" lang="ar" xml:lang="ar"
dir="rtl">
 
Any ideas what else is required?
 
Regards,. Dave

---

From: Samer Abukhait <[email-masked]>
Date: Tue, 8 Nov 2005 19:38:27 +0200

There is a {text-align: left} inside the 'blue' theme that is imported in
the main page
it overwrites the page direction.
It can be found here http://www.postgresql.org/layout/css/blue/layout.css

there is a workarround to cascade a new value for this property in the
content div

having the release surrounded with

<div style="text-align: right; font-family: tahoma;">
..
</div>

will make it render fine.

(tahoma font is the best font for arabic letters)

Regards.

On 11/8/05, Dave Page < [email-masked]> wrote:
>
>
>  ------------------------------
> *From:* [email-masked] [mailto:
> [email-masked]] *On Behalf Of *Samer Abukhait
> *Sent:* 08 November 2005 14:49
> *To:* [email-masked]; [email-masked]
> *Subject:* Re: [pgsql-www] [translators] [Fwd: Re: PostgreSQL 8.1.0Release is a Go ...]
>
>  Guys,
> the arabic page http://www.postgresql.org/about/press/presskit81.html.ar
> need to be RTL'ed
> The site certainly /thinks/ it's got to display it in rtl, and does write
> the html tag accordingly:

---

From: Robert Treat <[email-masked]>
Date: Tue, 8 Nov 2005 13:25:39 -0500

Marhaba,

I've committed the fix you suggested below, you can check it out at 
http://xzilla.postgresql.org/about/press/presskit81.html.ar and it will be 
live on the main site within an hour.  Please give it the once over and lmk 
if anything else needs changing. 

One other thing we were wondering about is Tahoma font on non-widows 
platforms... will that work? AFAICT it looks ok on my linux box, but I can't 
read arabic so I'm probably not the best judge. 

Robert Treat

-- 
Robert Treat
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: Samer Abukhait <[email-masked]>
Date: Tue, 8 Nov 2005 23:27:03 +0200

Ahlan Robert,

a page with a certain font on an OS without that font (even on
windows) will be rendered by the next available default font
you could do something more safe by listing more fonts, something like:

font-family: tahoma, arial, helvetica, sans-serif;

Anyhow, It picks a good font on my linux.