Subject: Bitnami deprecation

From: Smith <[email-masked]>
Date: Mon, 11 Aug 2025 15:33:06 +0000

Not sure where to post this but the Postgres team should consider pulling the promotion for Bitnami on the downloads page.

See:

https://github.com/bitnami/charts/issues/35164

---

From: Adrian Klaver <[email-masked]>
Date: Mon, 11 Aug 2025 08:49:32 -0700

> https://github.com/bitnami/charts/issues/35164

Yeah, going here:

https://bitnami.com/tag/postgresql

gets a 404 page.

-- 
Adrian Klaver
[email-masked]

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 12 Aug 2025 12:34:36 +0200

> On 11 Aug 2025, at 17:49, Adrian Klaver <[email-masked]> wrote:

>> https://github.com/bitnami/charts/issues/35164

Reading that doesn't make it obvious that we should remove Bitnami from the
page, they are still offering (what they now call hardened images) postgresql:

https://hub.docker.com/r/bitnamisecure/postgresql

Looking at their catalog they are up to date with the most recent 16 minor
release but no 17 version AFAICT.

https://app-catalog.vmware.com/bitnami/apps/33ff5603-01b2-4310-a541-0d24b516cb56

Keeping it on the other hand opens the question of why we aren't linking to
other similar distributions and operators.

> https://bitnami.com/tag/postgresql

Right, that clearly needs to be fixed.

--
Daniel Gustafsson

---

From: Rachel Roch <[email-masked]>
Date: Wed, 13 Aug 2025 14:47:24 +0200 (CEST)

I think you missed this rather critical bit on the Github, Daniel ....

"Post-August 28th, 2025
- For development purposes, community-tier users are restricted to pulling only the most recent ‘latest’ tags of the limited community-tier subset of container images.
- Production users should subscribe to Bitnami Secure Images for full version support"

---

From: Christoph Berg <[email-masked]>
Date: Tue, 26 May 2026 18:07:29 +0200

Re: Rachel Roch
> - Production users should subscribe to Bitnami Secure Images for full version support"

I stumbled over the bitnami link on the downloads page while working
on something else at pgconf.dev.

Can we just remove it now? It is still dead, and the value it adds
over random other docker/whatever images is 0.

Christoph

---

From: Daniel Gustafsson <[email-masked]>
Date: Wed, 27 May 2026 00:10:38 +0200

> On 26 May 2026, at 18:07, Christoph Berg <[email-masked]> wrote:
> 
> Re: Rachel Roch
>> "Post-August 28th, 2025

I won't object to it.

--
Daniel Gustafsson

---

From: Christoph Berg <[email-masked]>
Date: Wed, 27 May 2026 11:15:07 +0200

Re: Daniel Gustafsson
> > over random other docker/whatever images is 0.

Done, thanks.

Christoph