Subject: Bizarre substitution in online devel docs

From: Tom Lane <[email-masked]>
Date: Sun, 19 Sep 2004 20:40:04 -0400

Take a look at

http://developer.postgresql.org/docs/postgres/plpgsql-porting.html#PLPGSQL-PORTING-EX2

The source text for this looks like

          || ' LIKE ''' || referrer_key.key_string
          || ''' THEN RETURN ''' || referrer_key.referrer_type
          || '''; END IF;'; 

but what I'm seeing on the web page is

          || ' LIKE ''' || referrer_key.key_string
          || ''' THEN RETURN ''' || "Not Your Business!"_type
          || '''; END IF;'; 

The same substitution for "referrer_key.referrer" occurs in two other
places further down the page, so it seems something is actively
filtering the page contents.

What's even more bizarre is that I see the same thing in Bruce's
build of the docs:

http://candle.pha.pa.us/main/writings/pgsql/sgml/plpgsql-porting.html#PLPGSQL-PORTING-EX2

but not in a locally built version.

The back-version on-line docs have the same thing, eg:
http://www.postgresql.org/docs/7.4/static/plpgsql-porting.html#PLPGSQL-PORTING-EX2

Any ideas what's doing that?  I'm pretty sure no such thing was
happening when I last edited this example, not many weeks ago.

			regards, tom lane

---

From: Tom Lane <[email-masked]>
Date: Sun, 19 Sep 2004 20:48:29 -0400

> http://developer.postgresql.org/docs/postgres/plpgsql-porting.html#PLPGSQL-PORTING-EX2

Scratch that, it seems to be some misconfiguration issue in the web proxy
I was using ...

			regards, tom lane