Subject: Wiki Editor request

From: Patrick BUNINO <[email-masked]>
Date: Wed, 01 Oct 2025 14:41:26 +0200

Hi .
I’ve just created an account as Patrick83300.

The Count_Estimate Wiki Page seems wrong and i’d like to change few things :
The example create table has 1000 rows and not 100 :) ,  
generate_series(1,1000) makes 1000 numbers, not 100 (at least in  
Postgres 9.5.3)

One should use a «explain select ... where t<999999999999» in order to  
get the actual number of rows in the "rows=" part of the plan.
explain select * from tbl where t<2222;
QUERY PLAN
....... rows=1000
Filter: (t < 2222)

If one use t<100 he gets rows=100 which is not an estimation of the  
TOTAL number of rows in the table.

Cordialement.
Patrick BUNINO

---

From: Joe Conway <[email-masked]>
Date: Fri, 3 Oct 2025 09:21:59 -0400

On 10/1/25 08:41, Patrick BUNINO wrote:
> Hi .
> I’ve just created an account
I have expedited your cooling off period. Please log in to the wiki once and 
then reply-all to this email. At that point we can grant editor privs.

-- 
Joe Conway
PostgreSQL Contributors Team
Amazon Web Services: https://aws.amazon.com