Subject: Advanced Search by modify time and sort by date not working

From: Michael Fuhr <[email-masked]>
Date: Tue, 5 Sep 2006 13:20:51 -0600

Searching the list archives for "compressed protocol" with the
simple search returns the following recent message, among others:

http://archives.postgresql.org/pgsql-general/2006-09/msg00095.php

Using Advanced Search with "For files modified" set to a value other
than "anytime" doesn't return this message.  Also, although an
"anytime" search does return this message, sorting by date puts it
and a few others from 2006 on the last page.  Other messages on the
third and fourth of the four pages are also out of order when sorted
by date.

-- 
Michael Fuhr

---

From: "John Hansen" <[email-masked]>
Date: Wed, 6 Sep 2006 07:04:05 +1000

Right,

I think I might have narrowed this bug down to the format of the last modified header retruned by the webserver.
As far as I can tell, the indexer doesn't like double spaces, as all of the cases I have seen so far, all of the search results that appear at the end where they should not, are from single digit dates.

I'll get this fixed as soon as possible.

... John 

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Michael Fuhr
> Sent: Wednesday, September 06, 2006 5:21 AM
> To: [email-masked]
> Subject: [pgsql-www] Advanced Search by modify time and sort 
> by date not working
> 
> Searching the list archives for "compressed protocol" with 
> the simple search returns the following recent message, among others:
> 
> Using Advanced Search with "For files modified" set to a 
> value other than "anytime" doesn't return this message.  
> Also, although an "anytime" search does return this message, 
> sorting by date puts it and a few others from 2006 on the 
> last page.  Other messages on the third and fourth of the 
> four pages are also out of order when sorted by date.
> 
> --
> Michael Fuhr
> 
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 5: don't forget to increase your free space map settings
>