Subject: Notice about EDB downloads

From: Magnus Hagander <[email-masked]>
Date: Thu, 4 Nov 2021 18:00:21 +0100

PFA a patch that adds a notice about the EDB downloads, clarifying that
they are hosted separately from the rest of our infrastructure, and giving
instructions for who to contact if there are issues with it.

Prompted by the fact that we get a lot of bug reports and other error
reports (some to the right and some to the wrong addresses for the rest of
our website) when there are issues, that have to be passed on which both
causes a bunch of manual work and a delay before the people who actually
can fix something get it.
<
-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>
diff --git a/templates/pages/download/macosx.html b/templates/pages/download/macosx.html
index e5bbbb85..5ea5ee81 100644
--- a/templates/pages/download/macosx.html
+++ b/templates/pages/download/macosx.html
@@ -13,6 +13,12 @@
 certified by EDB for all supported PostgreSQL versions.
 </p>
 
+<p>
+  <strong>Note!</strong> This installer is hosted by EDB and not on the PostgreSQL community servers.
+  If you have issues with the website it's hosted on, please contact
+  <a href="mailto:[email-masked]">[email-masked]</a>.
+</p>
+
 <p>
 This installer includes the PostgreSQL server, pgAdmin; a graphical tool for managing and developing
 your databases, and StackBuilder; a package manager that can be used to download and install
diff --git a/templates/pages/download/windows.html b/templates/pages/download/windows.html
index ed9c8f16..634133d9 100644
--- a/templates/pages/download/windows.html
+++ b/templates/pages/download/windows.html
@@ -11,6 +11,12 @@
  certified by EDB for all supported PostgreSQL versions.
 </p>
 
+<p>
+  <strong>Note!</strong> This installer is hosted by EDB and not on the PostgreSQL community servers.
+  If you have issues with the website it's hosted on, please contact
+  <a href="mailto:[email-masked]">[email-masked]</a>.
+</p>
+
 <p>This installer includes the PostgreSQL server, pgAdmin; a graphical tool for managing and developing
 your databases, and StackBuilder; a package manager that can be used to download and install
 additional PostgreSQL tools and drivers. Stackbuilder includes management,

---

From: Daniel Gustafsson <[email-masked]>
Date: Thu, 4 Nov 2021 20:54:33 +0100

> On 4 Nov 2021, at 18:00, Magnus Hagander <[email-masked]> wrote:

> PFA a patch that adds a notice about the EDB downloads, clarifying that they are hosted separately from the rest of our infrastructure, and giving instructions for who to contact if there are issues with it.
> 
> Prompted by the fact that we get a lot of bug reports and other error reports (some to the right and some to the wrong addresses for the rest of our website) when there are issues, that have to be passed on which both causes a bunch of manual work and a delay before the people who actually can fix something get it.

That seems generally fine, I'm not convinced it will help with all the reports
but it's about all we can do.

While in there, could you also add the 14 release to the version tables on
those pages?  The 14 installer is available for download but the page make it
seem like it's only 9.6-13 which isn't a good look.

--
Daniel Gustafsson		https://vmware.com/

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 4 Nov 2021 22:24:19 +0100

> but it's about all we can do.

Oh I doubt it will help with all of them. But maybe with some. And it does
provide some info to the users.

> seem like it's only 9.6-13 which isn't a good look.

We normally wait for the people who run that end to provide a patch for
that -- but that usually leaves us in just this situation, with things not
properly up to date

Perhaps we should see if EDB can provide a metadata file somewhere on the
site that we could scrape down regularly (say, daily) and have it automated?

---

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 5 Nov 2021 10:28:33 +0100

> On 4 Nov 2021, at 22:24, Magnus Hagander <[email-masked]> wrote:
> On Thu, Nov 4, 2021 at 8:54 PM Daniel Gustafsson <[email-masked] <mailto:[email-masked]>> wrote:

> We normally wait for the people who run that end to provide a patch for that -- but that usually leaves us in just this situation, with things not properly up to date
> 
> Perhaps we should see if EDB can provide a metadata file somewhere on the site that we could scrape down regularly (say, daily) and have it automated?

Since we regularly find ourselves with out of date information here we clearly
need to do something, right now we make it seem like 14 isn't available for
download a month out from the release.

Another option is to just remove the table alltogether and leave the platform
support information to the EDB landing page?  Since we don't offer direct
downloads via deeplinks, separating the platform support info and the actual
download is a bit strange anyways.

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Nov 2021 10:12:44 -0400

> download is a bit strange anyways.

Do we have that kind of chart for any other platform downloads?  What
value is the chart providing, considering it looks very similar to the
EDB download page.  Seems the chart is just a maintenance burden with
little value and should be removed, as suggested above.

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  If only the physical world exists, free will is an illusion.

---

From: Daniel Gustafsson <[email-masked]>
Date: Fri, 5 Nov 2021 16:16:06 +0100

> On 5 Nov 2021, at 15:12, Bruce Momjian <[email-masked]> wrote:
> 

I thint it formalizes the supported OS per release in a way which the EDB page
doesn't, but I don't think it's necessarily the best place to present this
information as anyone interested would have to flip flop back and forth between
the pages while downloading. Removing it might be the best course of action.

---

From: Dave Page <[email-masked]>
Date: Fri, 5 Nov 2021 15:22:15 +0000

On Fri, Nov 5, 2021 at 3:16 PM Daniel Gustafsson <[email-masked]> wrote:

> >>> We normally wait for the people who run that end to provide a patch
> for that -- but that usually leaves us in just this situation, with things
> not properly up to date
> >>>
> >>> Perhaps we should see if EDB can provide a metadata file somewhere on
> the site that we could scrape down regularly (say, daily) and have it
> automated?
> >>

I don't necessarily disagree with that, but I will point out that the
platform support page on the EDB website lists what EDB will support under
contract, which is not necessarily the same as the platform compatibility
list for the PostgreSQL installers (e.g. we'd fix a bug on them specific to
Windows desktop editions, but that's not necessarily something EDB would
support under contract).

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: Bruce Momjian <[email-masked]>
Date: Fri, 5 Nov 2021 11:32:09 -0400

> the pages while downloading. Removing it might be the best course of action.

Can we move some of that detail to the EDB page so we don't need to
maintain our own release list?  Also, since it looks like 32-bit is only
supported for PG 9.6 and 10, can we just mention that on our site and
then we don't have to change anything for new releases.  (We would need
updates when we end-of-live a release.)