Subject: Community events and badges

From: Bruce Momjian <[email-masked]>
Date: Mon, 11 Oct 2021 13:52:33 -0400

We currently have two Postgres events listed on our home page:

	https://www.postgresql.org/

The text is:

	Upcoming Events
	
	    2021-11-30 – 2021-12-01 · Postgres Build 2021: Virtual Event
	    (*) 2021-12-02 – 2021-12-03 · PGConf NYC 2021
	
	(*) PostgreSQL Community Event indicates that an event is recognised under
	the community event guidelines and is directly helping the PostgreSQL
	community.

There is a yellow community badge next to the second event, shown above
as "*".  However, when I click on the second event:

	https://www.postgresql.org/about/event/pgconf-nyc-2021-2412/

there is no yellow badge or description.  Is it intended to show the
community recognition badge on the on the event list and not on the
event page?

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  If only the physical world exists, free will is an illusion.

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 11 Oct 2021 20:14:15 +0200

> community recognition badge on the on the event list and not on the

That does seem a bit silly.

I suggest something like the attached.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>
diff --git a/templates/events/item.html b/templates/events/item.html
index 81eb42d0..00fa6535 100644
--- a/templates/events/item.html
+++ b/templates/events/item.html
@@ -6,6 +6,7 @@
 <div class="eventdate">Date: <strong>{{obj.displaydate|safe}}</strong></div>
 <div>Location: {{obj.locationstring}}</div>
 {%if obj.language%}<div>Language: {{obj.language}}</div>{%endif%}
+{%if obj.badged%}<img src="/media/img/PostgreSQL_Badge1.svg" class="community" alt="PostgreSQL Community Event">  This event is recognised under the <a href="/about/policies/conferences/">community event guidelines</a>.{%endif%}
 {{obj.details|markdown}}
 {%if obj.has_organisation%}
 <p>Posted by {{obj.org}}{%if obj.org.email%} ({{obj.org.email}}){%endif%}.</p>

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Mon, 11 Oct 2021 14:34:18 -0400

> On Oct 11, 2021, at 2:14 PM, Magnus Hagander <[email-masked]> wrote:
> 
> 
> 
> 

+1

Jonathan

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 11 Oct 2021 20:36:41 +0200

> I suggest something like the attached.
Thanks, pushed.

---

From: Bruce Momjian <[email-masked]>
Date: Mon, 11 Oct 2021 15:24:59 -0400

>             community recognition badge on the on the event list and not on the

Yes, looks good now.