Subject: pglister: don't say "subject is empty" for non-empty subjects

From: Álvaro Herrera <[email-masked]>
Date: Fri, 3 Jul 2026 15:30:10 +0200

Hi

We just got a complaint about a moderation message being unclear -- the
moderation interface says that the subject is empty when it isn't.  I
propose to reword the message.  Also, the constant name was already
wrong, but now it is even more obvious how wrong it is, so update it.

Proposed patch attached.

-- 
Álvaro Herrera               48°01'N 7°57'E  —  https://www.EnterpriseDB.com/
"La fuerza no está en los medios físicos
sino que reside en una voluntad indomable" (Gandhi)

---

From: Dave Page <[email-masked]>
Date: Fri, 3 Jul 2026 14:43:08 +0100

> wrong, but now it is even more obvious how wrong it is, so update it.

Looks good to me - thanks!

-- 
Dave Page
pgAdmin: https://www.pgadmin.org
PostgreSQL: https://www.postgresql.org
pgEdge: https://www.pgedge.com

---

From: Magnus Hagander <[email-masked]>
Date: Wed, 8 Jul 2026 11:45:10 +0200

> Looks good to me - thanks!

Looks reasonable. Pushed. Thanks!

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>