Subject: Add AIX on the PostgreSQL Download page

From: "REIX, Tony" <[email-masked]>
Date: Tue, 7 Sep 2021 08:06:35 +0000

Hi,

I am interested in knowing if AIX could be added to the PostgreSQL page https://www.postgresql.org/download/ , either as a link to a PostgreSQL web-site page where instructions can be given and updated about where to get RPMs for AIX and how to install them, plus news about new versions and releases, or a link to a page out of PostgreSQL web-site.

We (Bull/ATOS BullFreeware: http://www.bullfreeware.com,  and IBM AIX ToolBox: https://www.ibm.com/support/pages/aix-toolbox-linux-applications-overview) are providing OpenSource packages (inc. PostgreSQL) for AIX under RPM format since ages and we'd like to enable PostgreSQL for AIX to be more visible by PostgreSQL users.

Regards/Cordialement,

Tony Reix

[email-masked]

ATOS / Bull SAS
ATOS Expert
IBM-Bull Cooperation Project: Architect & OpenSource Technical Leader
1, rue de Provence - 38432 ECHIROLLES - FRANCE
www.atos.net<https://mail.ad.bull.net/owa/redir.aspx?C=PvphmPvCZkGrAgHVnWGsdMcDKgzl_dEIsM6rX0g4u4v8V81YffzBGkWrtQeAXNovd3ttkJL8JIc.&URL=http%3a%2f%2fwww.atos.net%2f>

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Tue, 7 Sep 2021 10:10:24 -0400

On 9/7/21 4:06 AM, REIX, Tony wrote:
> Hi,
> 
> I am interested in knowing if AIX could be added to the PostgreSQL page
> https://www.postgresql.org/download/ , either as a link to a PostgreSQL
> web-site page where instructions can be given and updated about where to
> get RPMs for AIX and how to install them, plus news about new versions
> and releases, or a link to a page out of PostgreSQL web-site.
> 
> We (Bull/ATOS BullFreeware: http://www.bullfreeware.com,  and IBM AIX
> ToolBox:
> https://www.ibm.com/support/pages/aix-toolbox-linux-applications-overview)
> are providing OpenSource packages (inc. PostgreSQL) for AIX under RPM
> format since ages and we'd like to enable PostgreSQL for AIX to be more
> visible by PostgreSQL users.

Looking at the available packages[1], it does not appear that all of the
community supported versions are updated (e.g. the last 9.6 updates were
in 2018). It also seems that package updates are random -- e.g. there
was a 13.1 release, and a 13.4 release, which misses several bug fix +
security releases, and they come out several weeks after the release.

I'd be more open to this if the packages themselves were hosted on
community infrastructure and were consistent with the rest of the
packaging projects. Right now I'm -1 on this; additionally, I'm
generally -1 to adding more additional offsite links to downloads.

Thanks,

Jonathan

[1]
http://www.bullfreeware.com/?searching=true&package=postgresql&from=&to=&libraries=false&exact=false&version=5

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 7 Sep 2021 16:26:37 +0200

> On 7 Sep 2021, at 16:10, Jonathan S. Katz <[email-masked]> wrote:
> 

Do we have a strict policy around this?  Some package managers are still at
13.3 ~ a month out and the Fink macOS package manager doesn’t have v13 at all
AFAICT?

> packaging projects.

That seems a high bar to cross given that we don’t host macOS, Windows and the
BSD’s today but link to those.

> Right now I'm -1 on this; additionally, I'm

Unrelated but semi-related, if we don’t want new links we should probably
remove the Solaris download link which doesn’t even link to downloadable
packages.

--
Daniel Gustafsson		https://vmware.com/

---

From: Dave Page <[email-masked]>
Date: Tue, 7 Sep 2021 15:57:01 +0100

> 13.3 ~ a month out and the Fink macOS package manager doesn’t have v13 at

The packages in the "primary" section are supposed to be released in sync
with our releases, and their packagers are expected to keep in the loop on
the -packagers list.

Ones that are released later should either be unlisted, or in the 3rd party
section.

> BSD’s today but link to those.

I agree.

> remove the Solaris download link which doesn’t even link to downloadable

+1

-- 
Dave Page
Blog: https://pgsnake.blogspot.com
Twitter: @pgsnake

EDB: https://www.enterprisedb.com

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Tue, 7 Sep 2021 11:07:10 -0400

On 9/7/21 10:57 AM, Dave Page wrote:
> 
> 
> On Tue, Sep 7, 2021 at 3:26 PM Daniel Gustafsson <[email-masked]
> <mailto:[email-masked]>> wrote:
> 
>     > On 7 Sep 2021, at 16:10, Jonathan S. Katz <[email-masked]
>     <mailto:[email-masked]>> wrote:

>     BSD’s today but link to those.

It doesn't mean we need to continue to exacerbate the situation by
linking to downloads that we have little control over.

For example, what happens when the external downloads are unavailable?
We had a recent incident where this exact scenario happened. There are
now some reporting mechanisms in place to handle that scenario, but
ultimately it comes back to "PostgreSQL is unavailable for download."

>     remove the Solaris download link which doesn’t even link to downloadable

IIRC we had left that up so we could sunset it and provide "forwarding
information." Given it's been ~1 year, we could likely remove it.

Jonathan

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 7 Sep 2021 17:26:22 +0200

> information." Given it's been ~1 year, we could likely remove it.

That sunsetting happened on May 17, 2021. That's definitely not a
year...  I think we should keep it for a while -- but we could remove
it from the index page.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/
 Work: https://www.redpill-linpro.com/

---

From: "REIX, Tony" <[email-masked]>
Date: Tue, 7 Sep 2021 15:31:05 +0000

Hi

Thanks for you comments.
About your requirements, yes we do not have all sub versions and we have not updated old versions recently.

However, we have a Jenkins environment available in our BullFreeware lab that we are using already for several other packages, smaller and simpler than PostgreSQL. This Jenkins environment automatically checks for new version or new sub-version, downloads them, does appropriate changes, runs build and tests, and then publishes on our Web-site.

So I think that it should not be very difficult for us to finalize the changes required to enable PostgreSQL versions (9, 10, 11, 12, 13 and soon 14, if I understand well) to be automatically built by our Jenkins as soon as they are made available by the PostgreSQL community.
For versions 11, 12, 13, and soon 14, we have improved our PostgreSQL RPM .spec file so that few more work is required.
For version 9 and 10, we'll have to back port some changes we did recently, but it's not rocket science. Just let me know if v9 and v10 are required to be maintained by us.

Regards/Cordialement,

Tony Reix

[email-masked]

ATOS / Bull SAS
ATOS Expert
IBM-Bull Cooperation Project: Architect & OpenSource Technical Leader
1, rue de Provence - 38432 ECHIROLLES - FRANCE
www.atos.net<https://mail.ad.bull.net/owa/redir.aspx?C=PvphmPvCZkGrAgHVnWGsdMcDKgzl_dEIsM6rX0g4u4v8V81YffzBGkWrtQeAXNovd3ttkJL8JIc.&URL=http%3a%2f%2fwww.atos.net%2f>
________________________________
De : Jonathan S. Katz <[email-masked]>
Envoyé : mardi 7 septembre 2021 17:07
À : Dave Page <[email-masked]>; Daniel Gustafsson <[email-masked]>
Cc : REIX, Tony <[email-masked]>; [email-masked] <[email-masked]>
Objet : Re: Add AIX on the PostgreSQL Download page

Jonathan

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 7 Sep 2021 18:21:33 +0200

> On 7 Sep 2021, at 17:07, Jonathan S. Katz <[email-masked]> wrote:
> 

That is an argument against any outbound links though.  Not having the
information in the first place doesn’t seem to make PostgreSQL more available
than the risk of an intermittent 404.

I don’t have strong feelings wrt AIX, nor insights into the current proposal,
but limiting the offering based on what has been effectively grandfathered in
based on fears about future shortcomings in network availability doesn’t seem
to improve user friendliness.  Having the packages on offer in the first place,
as discussed downthread, is another matter though and a very real one.

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Tue, 7 Sep 2021 13:52:09 -0400

> than the risk of an intermittent 404.

I'm not against having outbound links -- in fact I help moderate quite a
few of those that we host on .org, and I'm glad we do so.

Downloads are different -- they are often one's first impression of
PostgreSQL, and they are a critical piece of the user experience, i.e.
how one actually accesses PostgreSQL.

This is why I continuously recommend that we try to host them on our own
infrastructure, so that way we have maximum control over this experience.

> to improve user friendliness.

Network availability is only one aspect of this. There's the actual
package availability (as you pointed out with Fink -- and I'm pretty
sure Dave & I had extensively discussed this in the past).

>  Having the packages on offer in the first place,

Don't get me wrong, I'm glad that Tony + ATOS/Bull are offering to
support the AIX packages for PostgreSQL. I think it's very generous. I
know secondhand the pain it takes to maintain and build packages, and
I'm appreciative of anyone who wants to do so for PostgreSQL.

However, my point is that the packages should ultimately be hosted on
community infrastructure.

Thanks,

Jonathan

---

From: Christophe Pettus <[email-masked]>
Date: Tue, 7 Sep 2021 10:55:31 -0700

> On Sep 7, 2021, at 10:52, Jonathan S. Katz <[email-masked]> wrote:

I don't think it's viable to insist that all packages be downloaded from the pg.org infrastructure.  It's reasonable to say that we won't link directly to a download, but will link to a third-party website where the packages are made available.

---

From: Justin Clift <[email-masked]>
Date: Wed, 08 Sep 2021 04:47:56 +1000

On 2021-09-08 03:52, Jonathan S. Katz wrote:
<snip>
> support the AIX packages for PostgreSQL.

+1

> I think it's very generous. I

Are we willing to give Tony/ATOS/Bull write access to a Community infra
location to enable that?

* If so, then potential ideas for how can probably be discussed and
   maybe worked out.
* If not, seems like we'll be pointing to their servers. ;)

+ Justin

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 7 Sep 2021 21:35:24 +0200

> I don't think it's viable to insist that all packages be downloaded from the pg.org infrastructure.  It's reasonable to say that we won't link directly to a download, but will link to a third-party…

I agree that it's not viable to insist they're all downloaded from
"us", and there are sometimes good reasons for it. For example, the
*BSD ports system kind of relies on it being off their systems and not
off ours, but we still want to point to that.

I think it would make sense to more clearly indicate *when* the
download is off a third party site vs when it's from something the
community runs, as a general rule. That would also clear up some of
the confusion when people have issues. And that should be applied
across the board.

It would probably also make sense to have some leve of at leas ta
"soft SLA" defined as a requirement to get listed. Like putting out
patches within <x> time of a release for example -- I think that would
be a perfectly reasonable requirement to put out there. And no, we
can't follow up on every single one of them, but if we get repeated
reports of something not being properly maintained we can remove it
from our list.

But we also need to make sure we don't end up being a link factory for
companies or organisations who just want to get clicks, and do so by
hosting an installer. In fact, from that perspective it might b better
to actually  link to a direct binary if possible rather than a
website. But that's also going to be expensive on maintenance. But we
probably *should* put a hard rule in place wrt the amount of tracking
etc that can be done on the resulting page(s) being linked to.

---

From: Christophe Pettus <[email-masked]>
Date: Tue, 7 Sep 2021 13:06:14 -0700

> On Sep 7, 2021, at 12:35, Magnus Hagander <[email-masked]> wrote:
> 
> hosting an installer.

It's a bit of a balancing act, because one of the ways a commercial organization can justify the (non-trivial) cost of preparing packages or an installer is that it is a good marketing tool.  At the minimum, we should require that the installer be downlaodable without any registration or information collection.

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 7 Sep 2021 22:08:40 +0200

> It's a bit of a balancing act, because one of the ways a commercial organization can justify the (non-trivial) cost of preparing packages or an installer is that it is a good marketing tool.  At th…

Certainly, and I'm fine with that. I mean what we want to avoid is
having 5 different links for each platform going to differen companies
who're doing that as a way to drive traffic only. But yes as you say,
it's a balance.

---

From: Daniel Gustafsson <[email-masked]>
Date: Tue, 7 Sep 2021 22:46:20 +0200

> On 7 Sep 2021, at 22:08, Magnus Hagander <[email-masked]> wrote:

> who're doing that as a way to drive traffic only.

I don’t think there is a huge risk in any company making the investment into
packaging and/or writing and maintaining an up-to-date installer purely for
traffic, that would be very expensive traffic.  If they do make a high-quality
installer that people like and anyone can use for free without registration (I
would expect us to have such reqs in place for linking) only to get the
traffic, then that’s not necessarily bad for the community is it?

---

From: "REIX, Tony" <[email-masked]>
Date: Wed, 8 Sep 2021 12:38:26 +0000

Hello,

It looks that you are still discussing for finding the most appropriate solution,
 from: building and delivering within PostgreSQL community infrastructure
      to: simply providing a link to a place out of PostgreSQL community infratructure for downloading the executables.
Let me know when you have finalized your decision.

If your final decision is to simply provide a link to a place out of PostgreSQL community where companies using AIX can find and download RPMs for AIX, we could add a new page on BullFreeware where only PostgreSQL packages can be downloaded. That would need some development to be done on our side. Also, we plan to provide DNF in 2022, in order to make installing new software much simpler that downloading by hand as for now.
The ATOS/Bull BullFreeware web-site does obey the RGBD (« General Data Protection Regulation » : GDPR), and thus we do not record any detailed information about people connecting to our web-site, and there is no advertisements or links to the ATOS world or to the Escala products.

If your final decision is to build PostgreSQL binaries by your own and to make them available in your infrastructure, we may help you.
First, since ATOS sells IBM AIX machines (under Escala brand) since ages, we are working around AIX in cooperation with IBM (for 30 years in 2022). And, if you need more AIX/Power hardware, our IBM partner is studying the possibility to provide you with some Power HW.
Moreover, if you need some help for building PostgreSQL binary deliverables in your own environment, we may help you, whenever possible. There are several AIX VMs in your build farm, using GCC 8.3 or XLC. We use only GCC v8.4 for now, and we plan to move to GCC v10 next year since it includes many fixes and improvements we are working on. However, though building/installing/checking are required for delivering binaries, some other rules are required. Like: the /opt/freeware directory is the fundamental place where installing OpenSource packages on AIX. Plus respect some few fundamental rules specific to AIX (see after).

Just some information if you do not know the AIX world: the native format for delivering and managing packages on AIX is the LPP format, which is AIX-specific. About OpenSource products, we (ATOS/Bullfreeware and IBM/AIX-Toolbox) build them with the RPM tool and we deliver them as RPM files. Thus, like Fedora does, we manage src.rpm files (.spec file, .patch files) for building packages delivered as: postgresql-......aix7.1.ppc.rpm files. Our RPM .spec files are very close to the Fedora ones, but they include many AIX-specific stuff needed for providing a coherent set of libraries plus some stuff required by AIX (like: shared libraries are provided as lib*.a containing lib*.so files for both 32 and 64bit).
So, building PostgreSQL binaries by the PostgreSQL community infrastructure could be done in different ways, like using our .src.rpm code (which we plan to improve for version v14, and which requires some other OpenSource RPMs dependencies to be installed for building and then running, like Fedora does) or simply as a tar.gz .

Regards/Cordialement,

Tony Reix

[email-masked]

ATOS / Bull SAS
ATOS Expert

________________________________
De : Daniel Gustafsson <[email-masked]>
Envoyé : mardi 7 septembre 2021 22:46
À : Magnus Hagander <[email-masked]>
Cc : Christophe Pettus <[email-masked]>; Jonathan S. Katz <[email-masked]>; Dave Page <[email-masked]>; REIX, Tony <[email-masked]>; [email-masked] <[email-masked]>
Objet : Re: Add AIX on the PostgreSQL Download page

Caution! External email. Do not open attachments or click links, unless this email comes from a known sender and you know the content is safe.

--
Daniel Gustafsson               https://eur01.safelinks.protection.outlook.com/?url=https%3A%2F%2Fvmware.com%2F&amp;data=04%7C01%7Ctony.reix%40atos.net%7C9248b5c3eb794eaed4f108d972409bde%7C33440fc6b7c7412cbb730e70b0198d5a%7C0%7C0%7C637666444084949039%7CUnknown%7CTWFpbGZsb3d8eyJWIjoiMC4wLjAwMDAiLCJQIjoiV2luMzIiLCJBTiI6Ik1haWwiLCJXVCI6Mn0%3D%7C1000&amp;sdata=U8uEjRtl%2B5XFNNFlLKqGx6SdKQj%2B%2Fq%2FZXCGcROdTTmg%3D&amp;reserved=0

---

From: "REIX, Tony" <[email-masked]>
Date: Tue, 21 Sep 2021 08:04:15 +0000

Hello,

Any news about this subject?

Thx

Tony
________________________________
De : REIX, Tony <[email-masked]>
Envoyé : mercredi 8 septembre 2021 14:38
À : Daniel Gustafsson <[email-masked]>; Magnus Hagander <[email-masked]>
Cc : Christophe Pettus <[email-masked]>; Jonathan S. Katz <[email-masked]>; Dave Page <[email-masked]>; [email-masked] <[email-masked]>
Objet : RE: Add AIX on the PostgreSQL Download page

Hello,

Regards/Cordialement,

Tony Reix

[email-masked]

ATOS / Bull SAS
ATOS Expert

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Tue, 21 Sep 2021 10:49:15 -0400

Hi Tony,

> Any news about this subject?

Let's revisit after the PostgreSQL 14 release next week, as this is
unlikely to advance before then.

Thanks,

Jonathan

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 7 Oct 2021 14:24:06 -0400

> unlikely to advance before then.

Can we talk about this now that PG 14 has been released?

-- 
  Bruce Momjian  <[email-masked]>        https://momjian.us
  EDB                                      https://enterprisedb.com

  If only the physical world exists, free will is an illusion.

---

From: "Jonathan S. Katz" <[email-masked]>
Date: Thu, 7 Oct 2021 14:31:47 -0400

> Can we talk about this now that PG 14 has been released?

Sure.

I went to check the website[1] and see that since we last spoke, there
are now updated packages for PG 11, 12, and 13. I don't see new ones for
10 or 14, though understandably 14 is new. In this case I'll discount
9.6 given it has one more release.

My opinion is pretty much unchanged in terms of linking offsite; I'd
prefer that we host packages on community infrastructure.

However, I'll accommodate whatever the general consensus is, and if
that's linking offsite I'll gladly work on a patch for that when the
time is right.

Thanks,

Jonathan

[1]

---

From: Daniel Gustafsson <[email-masked]>
Date: Mon, 11 Oct 2021 15:39:36 +0200

> On 7 Oct 2021, at 20:31, Jonathan S. Katz <[email-masked]> wrote:

> prefer that we host packages on community infrastructure.

I still think it's a too large ask to enforce hosting by pginfra, considering
how many exceptions we'd have to punch in such a policy to accomodate for
various package managers.

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 11 Oct 2021 15:55:26 +0200

> various package managers.

Agreed. I would prefer it for those cases where it's just simple hosting
and not package manager integration though. Prefer, but not require.

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>