Subject: [PATCH] Fix inaccuracies in documentation

From: Nils <[email-masked]>
Date: Sun, 7 Nov 2021 17:13:56 +0000

---
 docs/batch.rst       | 10 +++++-----
 docs/dev_install.rst |  9 ++++-----
 2 files changed, 9 insertions(+), 10 deletions(-)

diff --git a/docs/batch.rst b/docs/batch.rst
index 990f518d..c309d1fe 100644
--- a/docs/batch.rst
+++ b/docs/batch.rst
@@ -12,11 +12,11 @@ All batch jobs are located in the directory tools/.
 
 docs/docload.py
 ---------------
-This script will load a new set of documentation. Simply specify the
-version to load and point out the tarball to load from. The script
-will automatically decompress the tarball as necessary, and also
-perform HTML tidying of the documentation (since the HTML generated by
-the PostgreSQL build system isn't particularly standards-conforming or
+This script will load a new set of documentation. Simply specify the version to
+load and the path to the tarball of the PostgreSQL source code to load from.
+The script will automatically decompress the tarball as necessary, and also
+perform HTML tidying of the documentation (since the HTML generated by the
+PostgreSQL build system isn't particularly standards-conforming or
 nice-looking).
 
 ftp/spider_ftp.py
diff --git a/docs/dev_install.rst b/docs/dev_install.rst
index b110efbb..9647e991 100644
--- a/docs/dev_install.rst
+++ b/docs/dev_install.rst
@@ -34,9 +34,8 @@ with. Here's a quick step-by-step on how to do that:
    There are some parts of the site that require further settings, but
    this should be enough to get the basics up and running.
 
-#. In the pgweb directory run the following command to create all
-   tables and indexes, as well as create a superuser for your local
-   installation::
+#. Run the following command to create all tables and indexes, as well as
+   create a superuser for your local installation::
 
        ./manage.py migrate
 
@@ -51,11 +50,11 @@ with. Here's a quick step-by-step on how to do that:
        psql -d pgweb -f sql/varnish_local.sql
 
 #. To load some initial data for some tables (far from all at this
-   point), in the pgweb directory, run the following command::
+   point), run the following command::
 
        pgweb/load_initial_data.sh
 
-#. You'll want to creaet a superuser so you can access the `/admin/`
+#. You'll want to create a superuser so you can access the `/admin/`
    interface::
 
        ./manage.py createsuperuser
-- 
2.31.1

---

From: Magnus Hagander <[email-masked]>
Date: Mon, 8 Nov 2021 10:32:54 +0100

Hi!

Can I ask you to re-send this as an attachment, so the MUAs don't eat the
formatting?

Thanks!

//Magnus

---

From: Nils Andre <[email-masked]>
Date: Tue, 9 Nov 2021 22:58:50 +0000

Patch attached.

Thanks,

Nils