Subject: annoying links

From: Oleg Bartunov <[email-masked]>
Date: Thu, 4 Apr 2019 15:59:02 +0300

It's quite annoying to click on the links like
https://www.postgresql.org/message-id/flat/9f88b5e0-6da2-5227-20d0-0d7012beaa1c(at)lab(dot)ntt(dot)co(dot)jp/
and found "NOT FOUND" page.

It happens on page
https://www.postgresql.org/message-id/[email-masked]

Oleg
-- 
Postgres Professional: http://www.postgrespro.com
The Russian Postgres Company

---

From: Magnus Hagander <[email-masked]>
Date: Sun, 7 Apr 2019 15:14:08 +0200

> https://www.postgresql.org/message-id/[email-masked]

Hmm. That is indeed quite annoying.

Do you know offhand if this is something that happend recently (in relation
to a change we made somewhere), or if it has been that way "all the time"?
I can't find anything obvious that changed it, but maybe something came
along with a django upgrade or something like that. Or if it's been around
since forever, that'd be good to know in the process of figuring out how to
fix it :)

-- 
 Magnus Hagander
 Me: https://www.hagander.net/ <http://www.hagander.net/>
 Work: https://www.redpill-linpro.com/ <http://www.redpill-linpro.com/>

---

From: Tom Lane <[email-masked]>
Date: Sun, 07 Apr 2019 10:34:08 -0400

> to a change we made somewhere), or if it has been that way "all the time"?

A lot of the archives' links have been like that for a long time.
Some don't get the let's-obscure-this-email-address treatment,
but I have no idea what the difference is.

			regards, tom lane

---

From: Magnus Hagander <[email-masked]>
Date: Sun, 7 Apr 2019 17:01:16 +0200

> but I have no idea what the difference is.

That's interesting. Do you have an example of one that doesn't get broken?

---

From: Tom Lane <[email-masked]>
Date: Sun, 07 Apr 2019 11:16:52 -0400

> That's interesting. Do you have an example of one that doesn't get broken?

Ones where @ has been converted to %40 seem to work fine,
as for example in

https://www.postgresql.org/message-id/20190331224233.GC891537%40rfd.leadboat.com

but I've also seen it work when that wasn't done, as for example
the second message-id link in

https://www.postgresql.org/message-id/271bc1a7-2b59-e3f3-56b7-c8bc5456424a%402ndquadrant.com

So no, I don't know why some of the ones where the final component
does look like it could be an email address get the obscuring
treatment.

			regards, tom lane