Subject: Re: community docs config issue

From: "Dave Page" <[email-masked]>
Date: Wed, 19 Apr 2006 17:12:04 +0100

> -----Original Message-----
> From: Larry Rosenman [mailto:[email-masked]] 
> Sent: 19 April 2006 16:52
> To: Dave Page; 'Magnus Hagander'; 'Robert Treat'
> Cc: [email-masked]
> Subject: RE: [pgsql-www] community docs config issue
> 
> 
> I think(!) I have a fix:
> 
> 1) make distclean for xdiff-pecl
> 2) ./configure
> 3) edit config.h and CHANGE #undef HAVE_XDL_ALLOCATOR_PRIV to
>    #define HAVE_XDL_ALLOCATOR_PRIV 1
> 4) recompile and install
> 
> this seems to fix it on my system.
> 
> The configure script apparently doesn't test for this 
> correctly, and we try to free when we are actually trying to malloc.

Oh, nice work Larry :-)

Fix confirmed on wwwmaster - module reinstalled, apache restarted.

The community docs diff function still doesn't work though - did you
disable it Magnus? I've confirmed the existance of xdiff in the server
through a phpinfo() call in a test page, as well as on the command line.

Regards, Dave

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 13:03:19 -0500

> through a phpinfo() call in a test page, as well as on the command

I'm also in the process of doing 2 other things:
1) adopt the libxdiff FreeBSD port (so I can fix the -fPIC issue on
   amd64 (or have it build a shared lib)
2) creating a textproc/pecl-xdiff port that uses the above, and does
   the fix we did here (appends the #define, but same effect).

LER

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 14:34:42 -0500

Larry Rosenman wrote:
>> disable it Magnus? I've confirmed the existance of xdiff in the
>> server through a phpinfo() call in a test page, as well as on the
>> command line. 
>> 
> 
The PRs are in the FreeBSD GNATS.

96062 is the libxdiff one
96065 is the pecl-xdiff one.

Once they get committed, I'd suggest using those, so we don't get burned by
forgetting...

LER

---

From: "Larry Rosenman" <[email-masked]>
Date: Thu, 20 Apr 2006 12:30:36 -0500

Larry Rosenman wrote:

> Once they get committed, I'd suggest using those, so we don't get
> burned by forgetting...
> 
> LER

Marc committed the 2 PR's for me.  

LER