Subject: Re: community docs config issue

From: "Dave Page" <[email-masked]>
Date: Wed, 19 Apr 2006 14:23:00 +0100

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Robert Treat
> Sent: 19 April 2006 14:03
> To: Magnus Hagander
> Cc: [email-masked]
> Subject: Re: [pgsql-www] community docs config issue
> 
> On Wednesday 19 April 2006 02:54, Magnus Hagander wrote:
> > > Tried to diff Guido's change for the community docs and got the 
> > > following in my pop-up:
> > >
> > > Title:
> > > Articles
> > > Annotation:
> > > Full text:
> > > xdiff not supported by this PHP
> > >
> > > this is on wwwmaster in the admin section.
> >
> > Yeah. xdiff coredumps on FreeBSD, seems not to be fully 
> supported there.
> > If you're up for fixing it, please do ;-) But that's the 
> xdiff C code, 
> > not PHP code.
> >
> 
> Wow, that is not good (tm).  ISTM xdiff is pretty critical to 
> this thing working... I'm really not in a position to fix it, 
> anyone else want to step up?  What is our other 
> alternative... swap wwmaster to one of the linux boxen? 

The problem is that wwwmaster is sufficiently complex that we
specifically want it in a freebsd VM so Marc can host it elsewhere in a
hurry if required.

Regards, Dave

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 08:41:39 -0500

Dave Page wrote:
>> Sent: 19 April 2006 14:03 To: Magnus Hagander
>>> Yeah. xdiff coredumps on FreeBSD, seems not to be fully supported
>>> there. If you're up for fixing it, please do ;-) But that's the
>>> xdiff C code, not PHP code. 
>>> 
>> 
> specifically want it in a freebsd VM so Marc can host it elsewhere in
> a hurry if required.
> 
> Regards, Dave
> 
> ---------------------------(end of
> broadcast)--------------------------- TIP 9: In versions below 8.0,
>        the planner will ignore your desire to choose an index scan if
>        your joining column's datatypes do not match

what does it core with? SIGSEGV?

Is wwwmaster a 64-bit box?

Where is xdiff source?  I have my own FreeBSD/amd64 6.1-RC box that I can
possibly fix it.

LER

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893