Subject: community docs config issue

From: Robert Treat <[email-masked]>
Date: Tue, 18 Apr 2006 20:46:50 -0400

Tried to diff Guido's change for the community docs and got the following in 
my pop-up:

Title:
Articles
Annotation:
Full text:
xdiff not supported by this PHP

this is on wwwmaster in the admin section.  
-- 
Robert Treat
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: "Magnus Hagander" <[email-masked]>
Date: Wed, 19 Apr 2006 16:11:30 +0200

> >>> Where is xdiff source?  I have my own FreeBSD/amd64 
> 6.1-RC box that 
> >>> I can possibly fix it.
> >> 
> >> http://pecl.php.net/package/xdiff
> >> 
> >> Note that we're not on amd64, just plain i386. It's also 
> not freebsd 
> >> 6.1, but I can't remember exactly which versino :-)
> > 
> > A simple test:
> > 
> > wwwmaster# more foo.php
> > <?php
> >   $a = "Hello";
> >   $b = "Goodbye";
> >   echo xdiff_string_diff($a, $b, 1);
> >> 
> > 
> > wwwmaster# php foo.php
> > Segmentation fault (core dumped)
> > 
> > :-(
> > 
> > Regards, Dave
> do we know what version of pecl-xdiff is installed?

xdiff-1.4.

> I don't see a FreeBSD port for it either :(

Nope.

> What PHP are we using on wwwmaster?

PHP 5.1.2 (cli) (built: Feb 22 2006 17:52:45)
Copyright (c) 1997-2006 The PHP Group
Zend Engine v2.1.0, Copyright (c) 1998-2006 Zend Technologies

//Magnus

---

From: "Magnus Hagander" <[email-masked]>
Date: Wed, 19 Apr 2006 18:17:39 +0200

> > I think(!) I have a fix:
> > 
> > 1) make distclean for xdiff-pecl
> > 2) ./configure
> > 3) edit config.h and CHANGE #undef HAVE_XDL_ALLOCATOR_PRIV to
> >    #define HAVE_XDL_ALLOCATOR_PRIV 1
> > 4) recompile and install
> > 
> > this seems to fix it on my system.
> > 
> > The configure script apparently doesn't test for this 
> correctly, and 
> > we try to free when we are actually trying to malloc.
> 
> Oh, nice work Larry :-)
> 
> Fix confirmed on wwwmaster - module reinstalled, apache restarted.
> 
> The community docs diff function still doesn't work though - 
> did you disable it Magnus? I've confirmed the existance of 
> xdiff in the server through a phpinfo() call in a test page, 
> as well as on the command line.

Yes. It's in comdoc-edit.php. Busy right now, can't fix, will in a
couple of others if nobody else has.

//Magnus

---

From: "Dave Page" <[email-masked]>
Date: Thu, 20 Apr 2006 21:42:11 +0100

> -----Original Message-----
> From: Larry Rosenman [mailto:[email-masked]] 
> Sent: 20 April 2006 20:44
> To: Dave Page; 'Marc G. Fournier'
> Cc: 'Magnus Hagander'; 'Robert Treat'; [email-masked]
> Subject: RE: [pgsql-www] community docs config issue
> 
> Dave Page wrote:
> >> -----Original Message-----
> >> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 20 April 
> >> 2006 20:33 To: Dave Page
> >> Cc: Larry Rosenman; Magnus Hagander; Robert Treat; 
> >> [email-masked]; Marc G. Fournier
> >> Subject: RE: [pgsql-www] community docs config issue
> >> 
> >>> Anyhoo, Marc; how do we get the new ports onto wwwmaster?
> >> 
> >> ports updates nightly at 5am ... just did a forced run now 
> though, so 
> >> you should be able to do the install from ports for both 
> of libxdiff 
> >> and pecl-xdiff now ...
> > 
> > Both installed, old source trees removed from 
> /usr/local/src. Thanks 
> > guys.
> > 
> > Regards, Dave.
> 
> don't forget to bounce apache so the new extension takes...

Whoops - thanks. Done now.

Regards, Dave.