Subject: Re: community docs config issue

From: "Dave Page" <[email-masked]>
Date: Wed, 19 Apr 2006 15:46:17 +0100

> -----Original Message-----
> From: Larry Rosenman [mailto:[email-masked]] 
> Sent: 19 April 2006 15:41
> To: Dave Page; 'Magnus Hagander'; 'Robert Treat'
> Cc: [email-masked]
> Subject: RE: [pgsql-www] community docs config issue
> 
> Dave Page wrote:
> >> -----Original Message-----
> >> From: Magnus Hagander [mailto:[email-masked]]
> >> Sent: 19 April 2006 15:12
> >> To: Larry Rosenman; Dave Page; Robert Treat
> >> Cc: [email-masked]
> >> Subject: RE: [pgsql-www] community docs config issue
> >> 
> >>> do we know what version of pecl-xdiff is installed?
> >> 
> >> xdiff-1.4.
> > 
> > And it's not in Pecl, despite what the PHP docs say - you 
> have to get 
> > the tarball and build it by hand,
> > 
> > Regards, Dave.
> 
> I filed a bug with the PECL folks (#7422), and offered to 
> give access to my box.

Thanks Larry - I see it is actually there now. For months it was
missing, despite being advertised as being there :-(

Regards, Dave.

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 10:52:25 -0500

Dave Page wrote:
>>> And it's not in Pecl, despite what the PHP docs say - you have to
>>> get the tarball and build it by hand,
>>> 
>>> Regards, Dave.
>> 

I think(!) I have a fix:

1) make distclean for xdiff-pecl
2) ./configure
3) edit config.h and CHANGE #undef HAVE_XDL_ALLOCATOR_PRIV to
   #define HAVE_XDL_ALLOCATOR_PRIV 1
4) recompile and install

this seems to fix it on my system.

The configure script apparently doesn't test for this correctly, and
we try to free when we are actually trying to malloc.

LER

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893