Subject: Re: community docs config issue

From: "Dave Page" <[email-masked]>
Date: Wed, 19 Apr 2006 15:33:25 +0100

> -----Original Message-----
> From: Magnus Hagander [mailto:[email-masked]] 
> Sent: 19 April 2006 15:12
> To: Larry Rosenman; Dave Page; Robert Treat
> Cc: [email-masked]
> Subject: RE: [pgsql-www] community docs config issue
> 
> > do we know what version of pecl-xdiff is installed?
> 
> xdiff-1.4.

And it's not in Pecl, despite what the PHP docs say - you have to get
the tarball and build it by hand,

Regards, Dave.

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 09:35:07 -0500

> the tarball and build it by hand,

I just tried it with the latest stuff on my amd64 it dies in a 
_efree() call from:
#4  0x00000008073d58a5 in load_into_mm_file (buffer=0x9cef98 "Hello",
size=5,
    dest=0x7fffffffce90) at /home/ler/xdiff-pecl/xdiff-1.4/xdiff.c:629
629             ptr = xdl_mmfile_writeallocate(dest, (long) size);
(gdb) print size
$2 = 5

I'm not a PECL programmer, so I'm at a loss. 

It appears (from function names ONLY) to possibly
be a mmap difference type thing :(

LER

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893