Subject: Re: community docs config issue

From: "Magnus Hagander" <[email-masked]>
Date: Wed, 19 Apr 2006 15:47:37 +0200

> >>>> Tried to diff Guido's change for the community docs and got the 
> >>>> following in my pop-up:
> >>>> 
> >>>> Title:
> >>>> Articles
> >>>> Annotation:
> >>>> Full text:
> >>>> xdiff not supported by this PHP
> >>>> 
> >>>> this is on wwwmaster in the admin section.
> >>> 
> >>> Yeah. xdiff coredumps on FreeBSD, seems not to be fully supported 
> >>> there. If you're up for fixing it, please do ;-) But that's the 
> >>> xdiff C code, not PHP code.
> >>> 
> >> 
> >> Wow, that is not good (tm).  ISTM xdiff is pretty critical to this 
> >> thing working... I'm really not in a position to fix it, 
> anyone else 
> >> want to step up?  What is our other alternative... swap 
> wwmaster to 
> >> one of the linux boxen?
> > 
> > The problem is that wwwmaster is sufficiently complex that we 
> > specifically want it in a freebsd VM so Marc can host it 
> elsewhere in 
> > a hurry if required.
> > 
> > Regards, Dave
> > 
> what does it core with? SIGSEGV?

Yes. It kills the apache process.

> Is wwwmaster a 64-bit box?

No. It's a 32-bit VM.

> Where is xdiff source?  I have my own FreeBSD/amd64 6.1-RC 
> box that I can possibly fix it.

http://pecl.php.net/package/xdiff

Note that we're not on amd64, just plain i386. It's also not freebsd
6.1, but I can't remember exactly which versino :-)

//Magnus

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 08:49:44 -0500

Magnus Hagander wrote:
>>>> thing working... I'm really not in a position to fix it, anyone
>>>> else want to step up?  What is our other alternative... swap
>>>> wwmaster to one of the linux boxen?
>>> 
>>> specifically want it in a freebsd VM so Marc can host it elsewhere
>>> in a hurry if required. 
>>> 
>>> Regards, Dave
>>> 

-- 
Larry Rosenman                     http://www.lerctr.org/~ler
Phone: +1 512-248-2683                 E-Mail: [email-masked]
US Mail: 430 Valona Loop, Round Rock, TX 78681-3893

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 19 Apr 2006 13:16:41 -0300 (ADT)

Can you tell me how I can test it once installed?  I've got some time 
today and can look into why its crashing apache ...

On Wed, 19 Apr 2006, Magnus Hagander wrote:

> ---------------------------(end of broadcast)---------------------------
> TIP 3: Have you checked our extensive FAQ?
>
>               http://www.postgresql.org/docs/faq
>

----
Marc G. Fournier           Hub.Org Networking Services (http://www.hub.org)
Email: [email-masked]           Yahoo!: yscrappy              ICQ: 7615664

---

From: "Larry Rosenman" <[email-masked]>
Date: Wed, 19 Apr 2006 11:17:49 -0500

> today and can look into why its crashing apache ...

Already fixed :) 

See my followup.

---

From: "Marc G. Fournier" <[email-masked]>
Date: Wed, 19 Apr 2006 13:23:57 -0300 (ADT)

>> today and can look into why its crashing apache ...

Yup, noticed :)  Thx

----