Subject: Re: Suggestion for improving Archives

From: "John Hansen" <[email-masked]>
Date: Sun, 5 Sep 2004 16:21:30 +1000

> While we are here, the "for files modified" bit of 
> the search.postgresql.org box does not seem to work: 
> searching for "nested transactions vadim" brings back 62 
> hits, regardless of whether I set it to within one day or 
> within 2 years. The top hit is from June 2000. There is also 
> no way to sort it by date, which can be extremely important. 
> The ads on every page are annoying as well.
>  

Seems to fork fine for me, no results in the last 3 months,5 in the last
6 and 12, 26 in the last 2 years. Sorting by date, rather than
relevance, could be added.

---

From: Oleg Bartunov <[email-masked]>
Date: Sun, 5 Sep 2004 11:49:06 +0400 (MSD)

> relevance, could be added.

Marc again dropped last time modification header, so it's impossible
to sort results by date (in general case ) without specific parser.
Also, he changed template for message. These changes cause recrawling
the whole archive each time and overloading archives.postgresql.org
More specific search engine could use another source of information which
messages to crawl, but one we use at pgsql.ru is a general search engine
and it can't get modification date without proper header.

I suggest:

1. Use 3-server architecture (image server, frontend, backend) which
   could be reduced to 2 servers (image+frontend, backend) -
   frontend could be plain apache+mod_accel and serve/cache all backends
   outputs, backend is a modperl or/and php enabled apache.

2. return last modification header - be friendly to crawlers and browsers
3. stop changing message template

	Oleg

>
>
> ---------------------------(end of broadcast)---------------------------
> TIP 6: Have you searched our list archives?
>
>                http://archives.postgresql.org
>

	Regards,
		Oleg
_____________________________________________________________
Oleg Bartunov, sci.researcher, hostmaster of AstroNet,
Sternberg Astronomical Institute, Moscow University (Russia)
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(095)939-16-83, +007(095)939-23-83