Subject: Initial work on interfaces.html

From: Gavin Sherry <[email-masked]>
Date: Sun, 14 Nov 2004 01:09:15 +1100 (EST)

As attached.

Gavin

Index: template/en/about/interfaces.html
===================================================================
RCS file: /usr/local/cvsroot/pgweb/portal/template/en/about/interfaces.html,v
retrieving revision 1.2
diff -r1.2 interfaces.html
11a12,77
> <h2>Programming language interfaces</h2>
> <p>Following is a list of some of the popular interfaces used to allow a variety of programming languages to connect to PostgreSQL.</p>
> 
> <li><b>Ada</b> - <a href="http://home.cogeco.ca/~ve3wwg/software.html#APQ">http://home.cogeco.ca/~ve3wwg/software.html#APQ</a></li>
> 
> <li><b>bash</b> - <a href="http://www.psn.co.jp/PostgreSQL/pgbash/index-e.html">http://www.psn.co.jp/PostgreSQL/pgbash/index-e.html</a></li>
> 
> <li><b>C</b> - The libpq interface is shipped with the source distribution. See the <a href="/download">downloads page</a> for more information.</li>
> 
> <li><b>C++</b> - <a href="http://gborg.postgresql.org/project/libpqxx/projdisplay.php">http://gborg.postgresql.org/project/libpqxx/projdisplay.php</a></li>
> 
> <li><b>Java</b> - A JDBC driver for PostgreSQL can be found at <a href="http://jdbc.postgresql.org">http://jdbc.postgresql.org</a></li>
> 
> <li><b>Perl</b> - An interface to PostgreSQL is supplied by the DBI module. This can be obtained from CPAN.</li>
> 
> <li><b>PHP</b> - <a href="http://www.php.net/manual/en/ref.pgsql.php">http://www.php.net/manual/en/ref.pgsql.php</a></li>
> 
> <li><b>Python</b> - <a href="http://www.druid.net/pygresql/">http://www.druid.net/pygresql/</a></li>
> 
> <li><b>Ruby</b> - <a href="http://www.postgresql.jp/interfaces/ruby/">http://www.postgresql.jp/interfaces/ruby/</a></li>
> 
> <li><b>TCL</b> - <a href="http://gborg.postgresql.org/project/pgtcl/projdisplay.php">http://gborg.postgresql.org/project/pgtcl/projdisplay.php</a></li>
> 
> <li><b>.NET</b></li> - <a href="http://gborg.postgresql.org/project/npgsql/projdisplay.php">http://gborg.postgresql.org/project/npgsql/projdisplay.php</a></li>
>                                                                                 <br />
>                                                                                 
> <li><b>ODBC</b> - <a href="http://gborg.postgresql.org/project/psqlodbc/projdisplay.php">http://gborg.postgresql.org/project/psqlodbc/projdisplay.php</a></li>
> 
> <li><b>JDBC</b> - <a href="http://jdbc.postgresql.org">http://jdbc.postgresql.org</a></li>
> 
> <h2>Development Tools</h2>
> 
> XXX: to be completed
> <li>ECPG</li>
> <li>Aubit</li>
> <li>pgst</li>
> <li>...</li>
> 
> 
> <p>
> PostgreSQL 4GL for web database applications can be found at 
> <a href="http://www.man.ac.uk/~whaley/ag/appgen.html">http://www.man.ac.uk/~whaley/ag/appgen.html</a>
> </p>
> 
> <p>
> <a href="http://www.zeoslib.net/">ZeosDBO</a> (Zeos Database Objects, version 6.0)<br /><br />
> Did you ever dream about a single collection of native components that acts the
> same way, regardless whether you use database system A or database system B, 
> regardless whether your development platform is Microsoft Windows or Linux? Here 
> you are! ZeosDBO is a library for cross platform development under Delphi, Kylix 
> and C++ Builder, that gives you the power of high-performance native database 
> access and simple deployment.
> <br /><br />
> ZeosLib controls are optimized and fully integrated with the specific compiler 
> environments. Since the components compile directly into your applications there&apos;s 
> nothing extra to distribute and install. The only additional piece of software you 
> may have to install on the client side is the database system&apos;s API - usually only 
> one or two DLL files that must be copied. That&apos;s it! Best of all, ZeosLib&apos;s complete 
> source code is included so you can see exactly how it works.
> <br /><br />
> Currently you can use our tools with the following database systems:</p>
> <ul><li>Firebird, InterBase, MySQL, Microsoft SQL, PostgreSQL</li>
> <li>IBM DB2 and Oracle (will be released soon)</li></ul>
> 
> All of the software may be used free of charge even for commercial applications.
> 
15d80
< 
17,18c82,89
< An updated version of
< <a href="http://www.samse.fr/GPL/ora2pg/ora2pg-1.8.tar.gz">ora2pg</a>.</p>
---
> <a href="http://www.chez.com/emarsden/downloads/pg.el">pg.el</a>
> lets you access the PostgreSQL object-relational DBMS
> from Emacs, using its socket-level frontend/backend protocol. The
> module is capable of automatic type coercions from a range of SQL
> types to the equivalent Emacs Lisp type. This is a low level API,
> and won&apos;t be useful to end users. Should work with GNU Emacs 19.34
> and up, and XEmacs 20 and up. Performance is very poor when not
> byte-compiled.</p>
21,25c92,96
< <a href="http://web.tiscali.it/wiseminosse/index.html#danalysis.html">DistAnalysis</a>
< is a module that interacts with a PostgreSQL database calculating 
< a parameter distribution or a
< functional relation. All analyses can include grouping conditions. 
< The module also offers the possibility to graph the curves with a PHP module.</p>
---
> <a href="http://melati.org">Melati</a> is a tool for building 
> Java-programmed websites backed by a database (currently only Postgresql 7).
> Melati can be downloaded from SourceForge
> <a href="http://www.sourceforge.net/projects/melati">http://www.sourceforge.net/projects/melati</a>
> or <a href="http://melati.org">http://melati.org</a></p>
58,106d128
< <p>
< <a href="http://sourceforge.net/projects/pgmail/">pgMail</a> is a small 
< TCL based script that you can store within any PostgreSQL database.
< Once it is stored there, you can create any number of specialized procedures to send email
< from directly within PostgreSQL. i.e. emailing a customer when product ships</p>
< <p>
< <a href="http://www.chez.com/emarsden/downloads/pg.el">pg.el</a>
< lets you access the PostgreSQL object-relational DBMS
< from Emacs, using its socket-level frontend/backend protocol. The
< module is capable of automatic type coercions from a range of SQL
< types to the equivalent Emacs Lisp type. This is a low level API,
< and won&apos;t be useful to end users. Should work with GNU Emacs 19.34
< and up, and XEmacs 20 and up. Performance is very poor when not
< byte-compiled.</p>
< <p>
< <a href="http://www.sevainc.com/Access">Tool to convert 
< from Access97 to PosgtreSQL</a> This web site also describes several issues
< encountered while upsizing an Access database to PostgreSQL and what was done 
< to work around them.  PostgreSQL 7.1 is required for this to work.</p>
< <p>
< <a href="http://isg.ee.ethz.ch/tools/gedafe">Gedafe</a>
< (Generic Database Front-End) is an application independent
< end-user web front-end for databases. Application independant means,
< that the front-end doesn&apos;t have any information about the
< structure and contents of the database.</p>
< <p>
< <a href="http://melati.org">Melati</a> is a tool for building 
< Java-programmed websites backed by a database (currently only Postgresql 7).
< Melati can be downloaded from SourceForge
< <a href="http://www.sourceforge.net/projects/melati">http://www.sourceforge.net/projects/melati</a>
< or <a href="http://melati.org">http://melati.org</a></p>
< <p>
< UncommonSQL, available at <a href="http://alpha.onshore.com/lisp-software">
< http://alpha.onshore.com/lisp-software</a>, is
< both a functional and object-oriented interface to relational
< databases for Common Lisp.  It includes support for PostgreSQL, as
< well as Oracle.  It presently works in CMUCL, but should be portable
< to other runtimes.</p>
< <p>
< <a href="http://d.sefcik.cc/pgsql-coldfusion.html">Making ColdFusion work 
< with PostgreSQL</a> How to make ColdFusion work with PostgreSQL (On Solaris).</p>
< <p>
< <a href="http://nsmsweb3.oucs.ox.ac.uk/pg/Pgsetup.html">PostgreSQL Upsizing</a>
<  convert, develop, and use a PostgreSQL database from an existing Microsoft 
< Access 97 database.</p>
< <p>
< <a href="http://www.psn.co.jp/PostgreSQL/pgbash/index-e.html">Pgbash</a>
< is a useful tool which can execute all of the SQL functions directly from
< bash shell.</p>
108,114c130
< <p>
< <a href="http://www.ruby-lang.org/en/">Ruby</a> is a script language
< like Perl and Python and is distributed under GPL or Artistic like less 
< restrictive license.  There is an 
< <a href="http://www.ruby-lang.org/en/raa-list.rhtml?name=postgres">interface
< to PostgreSQL available at http://www.ruby-lang.org/en/raa-list.rhtml?name=postgres</a>.
< </p>
---
> <h2>Administration tools</h2>
135,223d150
< <p>
< The VisualWorks EXDI is a core API of the <a
< href="http://www.cincom.com/smalltalk/vwdownload.asp">VisualWorks
< Smalltalk</a> development environment.  It provides a standard set of
< interfaces to SQL-compliant databases.  The  <a
< href="http://brain.cs.uiuc.edu/VisualWorks/PostgreSQL+EXDI">PosgreSQL
< Smalltalk driver + EXDI interface libaries</a> provide an EXDI implementation
< for VisualWorks programmers wishing to access PostgreSQL databases.
< </p>
< <p>
< <a href="http://www.zeoslib.net/">ZeosDBO</a> (Zeos Database Objects, version 6.0)<br /><br />
< Did you ever dream about a single collection of native components that acts the
< same way, regardless whether you use database system A or database system B, 
< regardless whether your development platform is Microsoft Windows or Linux? Here 
< you are! ZeosDBO is a library for cross platform development under Delphi, Kylix 
< and C++ Builder, that gives you the power of high-performance native database 
< access and simple deployment.
< <br /><br />
< ZeosLib controls are optimized and fully integrated with the specific compiler 
< environments. Since the components compile directly into your applications there&apos;s 
< nothing extra to distribute and install. The only additional piece of software you 
< may have to install on the client side is the database system&apos;s API - usually only 
< one or two DLL files that must be copied. That&apos;s it! Best of all, ZeosLib&apos;s complete 
< source code is included so you can see exactly how it works.
< <br /><br />
< Currently you can use our tools with the following database systems:</p>
< <ul><li>Firebird, InterBase, MySQL, Microsoft SQL, PostgreSQL</li>
< <li>IBM DB2 and Oracle (will be released soon)</li></ul>
< 
< All of the software may be used free of charge even for commercial applications.
< 
< 
< <p>
< PostgreSQL has a TCL/TK library in distribution providing for a GUI 
< frontend tool.  TCL/TK is a Rapid Application Development tool. Develop
< once and run it everywhere on NT, Win 95, Linux, and most Unixes! 
< TCL/TK can be found at 
< <a href="http://sunscript.sun.com/">http://sunscript.sun.com/</a>
< or <a href="ftp://ftp.sunlabs.com/pub/tcl/">ftp://ftp.sunlabs.com/pub/tcl/</a>
< </p>
< 
< <p>
< The PostgreSQL ODBC Driver
< <a href="http://gborg.postgresql.org/project/psqlodbc">psqlODBC</a> From A-Z, PostgreSQL ODBC
< </p>
< 
< 
< <p>
< UDBC is a static version of ODBC independent of
< driver managers and DLL support, used to embed database
< connectivity support directly into applications.
< <a href="http://www.openlinksw.com">http://www.openlinksw.com</a>
< </p>
< 
< 
< <p>
< Java connectivity to PostgreSQL. Since version 6.2,
< the drivers are included in the source distribution.
< <br /><a href="ftp://ftp.ai.mit.edu/people/rst/rst-jdbc.tar.gz">ftp://ftp.ai.mit.edu/people/rst/rst-jdbc.tar.gz</a>
< <br /><a href="http://www.retep.org.uk/postgres">http://www.retep.org.uk/postgres</a>
< </p>
< 
< 
< <p>
< Java Rapid Application Tool for PostgreSQL 
< <a href="http://www.man.ac.uk/~whaley/kj/kanch.html">http://www.man.ac.uk/~whaley/kj/kanch.html</a>
< </p>
< 
< 
< <p>
< Java Classes for PostgreSQL can be found at 
< <a href="http://www.blackdown.org">http://www.blackdown.org</a>
< </p>
< 
< 
< <p>
< Edmund Mergl created the Perl interface included
< in the distribution of PostgreSQL. Check in
< src/pgsql_perl5 directory.
< <br />Email: <a href="mailto:[email-masked]">[email-masked]</a>
< <br />Perl Home page : <a
< href="http://www.perl.com/perl/index.html">http://www.perl.com/perl/index.html</a></p>
< <p>If you want to use the Database Independent (DBI) interface for
< Perl, you can use the PostgreSQL database driver (also created by
< Edmund Mergl) DBD::Pg.  It can be found at the CPAN archives:
< <a href="http://www.perl.com/CPAN-local/modules/by-module/DBD/">
< http://www.perl.com/CPAN-local/modules/by-module/DBD/</a>
< </p>
< 
233,245c160
< <p>
< Postgres API for the Pike Programming Language.
< Francesco Chemolli authored an API to be used for
< Pike. The API is distributed along with the Pike
< programming language. As a backgrounder, Pike is a free
< interpreted, object-oriented, loosely-typed, net-aware
< programming language, derived from LPC, and written by
< Frederik Hubinette.
< <br />Email: <a
< href="mailto:[email-masked]">[email-masked]</a>
< <br /><a href="http://pike.idonex.se">http://pike.idonex.se</a></p>
< 
< 
---
> <h2>Report writing</h2>
248,254c163,167
< Windows Interactive Query Tool for PostgreSQL (WISQL) - Identical to 
< Microsoft SQL server WISQL!
< <a href="http://www.ucolick.org/~de/tcl_syb/wisql.html">
< http://www.ucolick.org/~de/tcl_syb/wisql.html</a>
< <br />Email: <a href="mailto:[email-masked]">[email-masked]</a>
< </p>
< 
---
> <a href="http://isg.ee.ethz.ch/tools/gedafe">Gedafe</a>
> (Generic Database Front-End) is an application independent
> end-user web front-end for databases. Application independant means,
> that the front-end doesn&apos;t have any information about the
> structure and contents of the database.</p>
255a169
> <h2>Add ons</h2>
257,261c171,174
< The Interactive Query Tool - ISQL (Character command line
< terminals) is included in the distribution, called PSQL. Very
< similar to Sybase ISQL, Oracle SQLplus but more feature packed. 
< </p>
< 
---
> <a href="http://sourceforge.net/projects/pgmail/">pgMail</a> is a small 
> TCL based script that you can store within any PostgreSQL database.
> Once it is stored there, you can create any number of specialized procedures to send email
> from directly within PostgreSQL. i.e. emailing a customer when product ships</p>
263,266d175
< <p>
< PostgreSQL 4GL for web database applications can be found at 
< <a href="http://www.man.ac.uk/~whaley/ag/appgen.html">http://www.man.ac.uk/~whaley/ag/appgen.html</a>
< </p>
269,272d177
< <p>
< Web Database Design/Implementation tool for PostgreSQL can be found at 
< <a href="http://www.oswego.edu/Earp">http://www.oswego.edu/Earp</a>
< </p>
275,277d179
< <p>
< WWW Web interface for PostgresSQL - See PHP3 below.
< </p>
280,284d181
< <p>
< PHP3 Server-side html-embedded scripting language
< for PostgreSQL (WWW Interface Tool)  <a href="http://www.php.net">
< http://www.php.net</a>
< </p>
287,290d183
< <p>
< PyGres95 is a python interface for the PostgreSQL. It is available from 
< <a href="ftp://ftp.via.ecp.fr/pub/python/contrib/Database/PyGres95-1.0b.tar.gz">ftp://ftp.via.ecp.fr/pub/python/contrib/Database/PyGres95-1.0b.tar.gz</a>
< </p>
294,298d186
< <p>
< The &quot;C&quot; language Interface for PostgreSQL is 
< included in distribution &apos;libpq&apos;. Similar to Oracle OCI,
< Sybase DB-lib, Informix CLI libraries. 
< </p>
299a188
> techdocs material
302,306c191,194
< The &quot;C++&quot; language Interface for PostgreSQL is
< included in distribution &apos;libpq++&apos;. 
< </p>
< 
< 
---
> <a href="http://www.sevainc.com/Access">Tool to convert 
> from Access97 to PosgtreSQL</a> This web site also describes several issues
> encountered while upsizing an Access database to PostgreSQL and what was done 
> to work around them.  PostgreSQL 7.1 is required for this to work.</p>
308,311c196,201
< PostgreSQL ESQL/C (Embedded C Pre-compiler) like Oracle&apos;s Pro*C, 
< Informix ESQL/C is now called &quot;ecpg&quot; and is included in 
< the PostgreSQL source distribution.
< </p>
---
> <a href="http://d.sefcik.cc/pgsql-coldfusion.html">Making ColdFusion work 
> with PostgreSQL</a> How to make ColdFusion work with PostgreSQL (On Solaris).</p>
> <p>
> <a href="http://nsmsweb3.oucs.ox.ac.uk/pg/Pgsetup.html">PostgreSQL Upsizing</a>
>  convert, develop, and use a PostgreSQL database from an existing Microsoft 
> Access 97 database.</p>

---

From: "Dave Page" <[email-masked]>
Date: Sat, 13 Nov 2004 22:10:20 -0000

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Gavin Sherry
> Sent: 13 November 2004 14:09
> To: [email-masked]
> Subject: [pgsql-www] Initial work on interfaces.html
> 
> As attached.
> 
> Gavin
> 

Thanks Gavin, patch applied.

Regards, Dave