Subject: Re: Mirror.php

From: "Dave Page" <[email-masked]>
Date: Sat, 4 Dec 2004 20:18:16 -0000

> -----Original Message-----
> From: Alexey Borzov [mailto:[email-masked]] 
> Sent: 04 December 2004 18:35
> To: Dave Page
> Cc: [email-masked]
> Subject: Re: [pgsql-www] Mirror.php
> 
> ::scratches head::
> Well, the PEAR code boils down to the example above if you 
> strip all the pretty stuff out. Please try running the 
> following script, maybe it will give some insight:
> 
> <?php
> error_reporting(E_ALL);
> var_dump(gethostbyname('wwwmaster.postgresql.org'));
> 
> require_once 'HTTP/Request.php';
> PEAR::setErrorHandling(PEAR_ERROR_CALLBACK, 'var_dump'); $req 
> =& new HTTP_Request('http://wwwmaster.postgresql.org/');
> $req->sendRequest();
> ?>
> 

root@developer:/usr/local/www/wwwmaster.postgresql.org/www/tools# php -d
include_path=/usr/local/www/portal.postgresql.org/pear/lib test3.php
string(13) "194.217.48.42"
root@developer:/usr/local/www/wwwmaster.postgresql.org/www/tools#

Regards, Dave.

---

From: Alexey Borzov <[email-masked]>
Date: Sun, 05 Dec 2004 01:21:08 +0300

Hi,

> root@developer:/usr/local/www/wwwmaster.postgresql.org/www/tools#

If that particular script produces no errors, I can't imagine anything that 
prevents mirror.php from running... Please try running that again, maybe the 
problem just magically went away.