Subject: Re: New site - minor problem

From: "Dave Page" <[email-masked]>
Date: Mon, 6 Dec 2004 22:01:52 -0000

> -----Original Message-----
> From: John Hansen [mailto:[email-masked]] 
> Sent: 06 December 2004 21:55
> To: Dave Page
> Cc: Joshua D. Drake; Gavin M. Roy; [email-masked]
> Subject: RE: [pgsql-www] New site - minor problem
> 
> Maxminds API's are not nescessarily database dependant. I 
> even think they have an apache module. If not, writing one 
> would be trivial.
> 
> However all these solutions would require mirrors to install 
> the modules on their servers no? or are we generating the 
> mirror selection pages statically, customised to the mirror 
> region? if so, what exactly would the ip2country modules be used for?

No, that's the point. All the mirrors would be selected on the master
server, giving a single point of failure. I'm far from convinced that
it's worth it. The *only* benefit to users is that the flags for their
country would be shown seperately on the mirror selection pages, saving
them may 2 seconds to spot their flag in the main grid.

Regards, Dave.

---

From: John Hansen <[email-masked]>
Date: Tue, 07 Dec 2004 09:09:24 +1100

> them may 2 seconds to spot their flag in the main grid.

In that case I vote to send that idea to the trash can..... :)

Unless mirrors are prepared to perform the ip2ccode lokups...
Single point of failure kinda defeats the purpose I reckon.

... John

---

From: "Gavin M. Roy" <[email-masked]>
Date: Mon, 06 Dec 2004 14:14:39 -0800

As I understand it, the new site will examine the person's ip address
and redirect them to the proper mirror for their country, if available.
The module I am offering will allow this to happen faster with less
overhead than current open source implementations.

Gavin

On Mon, 2004-12-06 at 22:01 +0000, Dave Page wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 7: don't forget to increase your free space map settings