Subject: Re: New site - minor problem

From: "Dave Page" <[email-masked]>
Date: Mon, 6 Dec 2004 21:40:12 -0000

> -----Original Message-----
> From: John Hansen [mailto:[email-masked]] 
> Sent: 06 December 2004 21:31
> To: Joshua D. Drake
> Cc: Dave Page; Gavin M. Roy; [email-masked]
> Subject: Re: [pgsql-www] New site - minor problem
> 
> > I would say, if there is not a reasonably open source 
> alternative then 
> > go for it... I have not problem with us using a closed 
> source module 
> > if it is the best for the job.
> 
> What's wrong with using maxmind's ip2country database?
> 
> Having read the thread, I'm still unclear as to what the 
> problem really is.

The problem is that we go to great lengths to mirror the site and
minimise the points of failure, and then add code in that forces all
selection of those mirrors downloads of our software through 1 database
dependent script that provides very little benefit to the end user. 

My earlier concern was that it would have too great of an effect on our
leased line, but having looked at the server logs and done a little
math, I realise now I was worrying about nothing.

Regards, Dave.

---

From: John Hansen <[email-masked]>
Date: Tue, 07 Dec 2004 08:54:30 +1100

> dependent script that provides very little benefit to the end user. 

Maxminds API's are not nescessarily database dependant. I even think
they have an apache module. If not, writing one would be trivial.

However all these solutions would require mirrors to install the modules
on their servers no? or are we generating the mirror selection pages
statically, customised to the mirror region? if so, what exactly would
the ip2country modules be used for?

Sorry if I sound a bit lost... :)

... John