Subject: Re: New site - minor problem

From: "Dave Page" <[email-masked]>
Date: Mon, 6 Dec 2004 11:05:16 -0000

> -----Original Message-----
> From: [email-masked] 
> [mailto:[email-masked]] On Behalf Of Dave Page
> Sent: 06 December 2004 11:02
> To: [email-masked]
> Subject: [pgsql-www] New site - minor problem
> 
> I suspected this would be a problem:
> 
> The new website uses ip2country to figure out where to send users.
> However, the site is spidered and static pages generated for 
> mirroring in .uk
> 
> I would rather remove the ip2country than have every hit 
> directed to my server. Any major objections?

Should add to that - all this will do is change the format of the mirror
selection pages by not listing local servers at the top.

/D

---

From: "Dave Page" <[email-masked]>
Date: Mon, 6 Dec 2004 20:16:55 -0000

> From: Marc G. Fournier [mailto:[email-masked]] 
> Sent: 06 December 2004 19:19
> To: Dave Page
> Cc: Alexey Borzov; [email-masked]
> Subject: Re: [pgsql-www] New site - minor problem
> 
> I thought form submissions went to scripts.postgresql.org anyway .. ?
> 

They do at the moment, but they'll need to come to the master site as
that's where the database is.

BTW, we'll also need to figure out how to get the DNS zonefile from the
master to you. How about I provide a section of the zonefile for you to
rsync an import as required?

Regards, Dave

---

From: "Dave Page" <[email-masked]>
Date: Mon, 6 Dec 2004 22:15:44 -0000

> From: John Hansen [mailto:[email-masked]] 
> Sent: 06 December 2004 22:09
> To: Dave Page
> Cc: Joshua D. Drake; Gavin M. Roy; [email-masked]
> Subject: RE: [pgsql-www] New site - minor problem
> 
> > No, that's the point. All the mirrors would be selected on 
> the master 
> > server, giving a single point of failure. I'm far from 
> convinced that 
> > it's worth it. The *only* benefit to users is that the 
> flags for their 
> > country would be shown seperately on the mirror selection pages, 
> > saving them may 2 seconds to spot their flag in the main grid.
> 
> In that case I vote to send that idea to the trash can..... :)
> 
> Unless mirrors are prepared to perform the ip2ccode lokups...

No, we keep them pure HTML for simplicity.

> Single point of failure kinda defeats the purpose I reckon.

Yup, my feelings precisely.

/D