Subject: Re: Feeds Integration

From: Chris Ryan <[email-masked]>
Date: Fri, 20 Feb 2004 07:48:44 -0800 (PST)

--- David Costa <[email-masked]> wrote:
> Hello!
 -- snip --
> Then just run the file and if it works let me know.
 -- snip --

    It worked great. You can find the output that was generated at
http://gborg.postgresql.org/news.rss. I don't have any RSS tools to
view this with so someone else may want to look at this and verify it's
generating correctly. Other than that it looks good to me.

    Once a few people have looked at it and we all like the way it's
working I can setup the cron to generate the file on a regular basis.

    Good Job Dave.

Chris Ryan

__________________________________
Do you Yahoo!?
Yahoo! Mail SpamGuard - Read only the mail you want.
http://antispam.yahoo.com/tools

---

From: Devrim GUNDUZ <[email-masked]>
Date: Fri, 20 Feb 2004 18:03:45 +0200 (EET)

Hi,

> generating correctly. Other than that it looks good to me.

I've tested it with Evolution now. It looks really perfect.

Thanks guys.

Regards,
- -- 
Devrim GUNDUZ	       
[email-masked]				[email-masked] 
			http://www.TDMSoft.com
			http://www.gunduz.org

---

From: David Costa <[email-masked]>
Date: Fri, 20 Feb 2004 17:05:23 +0100

> working I can setup the cron to generate the file on a regular basis.
Okay a live parsed feed is at http://php.gurugeek.org/parser.php
as you can see there are some little problems
The date is not produced by the feed <date>submit_date</date> (see 
source on http://gborg.postgresql.org/news.rss)
The author is not grabbed by this specific parser but is something we 
can solve.

This parser is somehow strict, I have another one if you want me to try 
with that one, I can have a page up soon or I can email you the source 
of a "non that strict"
parser ? ;)

---

From: David Costa <[email-masked]>
Date: Fri, 20 Feb 2004 17:09:07 +0100

> I've tested it with Evolution now. It looks really perfect.

Hi Devrim :D
umh, does it looks like this http://php.gurugeek.org/parser.php or you 
can also see the author ?
thanks again for your feedback :D

David Costa

> -----BEGIN PGP SIGNATURE-----
> Version: GnuPG v1.2.1 (GNU/Linux)
>
> iD8DBQFANi/ktl86P3SPfQ4RAtAiAJ9V4l/8ugow1tYLV1DeGIkihdRDQQCaA3AE
> okK64IyRlisYvH863sRQpEU=
> =00s7
> -----END PGP SIGNATURE-----
>
>
> ---------------------------(end of 
> broadcast)---------------------------
> TIP 5: Have you checked our extensive FAQ?
>
>                http://www.postgresql.org/docs/faqs/FAQ.html

---

From: Devrim GUNDUZ <[email-masked]>
Date: Fri, 20 Feb 2004 18:17:11 +0200 (EET)

Hi,

> can also see the author ?

Here is a screenshot from Evolution:

http://www.gunduz.org/gborg-rss.png

Regards,
- -- 
Devrim GUNDUZ

---

From: Chris Ryan <[email-masked]>
Date: Fri, 20 Feb 2004 08:20:43 -0800 (PST)

I've corrected the date and posted the updated news.rss.

Chris Ryan

---

From: David Costa <[email-masked]>
Date: Fri, 20 Feb 2004 17:29:33 +0100

>     I've corrected the date and posted the updated news.rss.

Hello Chris,
thanks for your prompt fix.

looks fine to me. Now there is a caveat ;)

Rss 1.0 which I used on this script allows only title, link description 
therefore some parsers might arbitrarily ignore any other tags or 
complain.
Rss 2.0 has author and data capability but is sort of silly because 
pretends a formation like [email-masked] which for spam purposes 
is rarely used.

Let's see if someone else has a feedback  I will test it with some 
other parsers too just in case.
So far so good.
thanks to Devrim for trying this out.

Regards
David Costa

---

From: David Costa <[email-masked]>
Date: Wed, 25 Feb 2004 16:42:51 +0100

Chris,
can you please put up a beta/alpha for the main news feeds
and events?
all you need to change is the db query and the name of the php objects 
used in the loop.

For my news alpha I am using a regex on the postgresql homepage and is 
not really a good idea©

Cheers
David

---

From: Chris Ryan <[email-masked]>
Date: Wed, 25 Feb 2004 18:47:46 -0800 (PST)

David,

    It's been a long day and I'm somewhat confused with what you want
me to do. Could you clarify? Thanks.

Chris Ryan

__________________________________
Do you Yahoo!?
Get better spam protection with Yahoo! Mail.
http://antispam.yahoo.com/tools

---

From: Chris Ryan <[email-masked]>
Date: Thu, 26 Feb 2004 10:28:36 -0800 (PST)

Dave P., Marc,

    I took what David gave me for the rss feed on gborg and made some
quick changes in the sql to fit with the events and news tables from
the main sites database. I gleaned the information from the pgweb cvs
so it should be good to go but may need some tweaking since I didn't
test the sql against the db.

    Find attached a file that has the two seperate scripts I modified
and a third script that needs to be placed appropriately. David had
sent me the instructions the first time but I seem to have deleted them
so he should be able to provide the needed instructions on setup. In
short it was placing the 3rd file in <PEAR>/XML/. and making sure
certain pear packages were installed XML_RPC and XML_Util.

Chris Ryan

---

From: Robert Treat <[email-masked]>
Date: 27 Feb 2004 08:14:47 -0500

Is it just me or did no one else get the attachment?

Robert Treat

On Thu, 2004-02-26 at 13:28, Chris Ryan wrote:
> ---------------------------(end of broadcast)---------------------------
> TIP 1: subscribe and unsubscribe commands go to [email-masked]

-- 
Build A Brighter Lamp :: Linux Apache {middleware} PostgreSQL

---

From: Chris Ryan <[email-masked]>
Date: Fri, 27 Feb 2004 05:31:30 -0800 (PST)

In retrospect it was probably me. Attached this time... i swear... i
hope :)

Chris Ryan

--- Robert Treat <[email-masked]> wrote:
> > > For my news alpha I am using a regex on the postgresql homepage
> and
> > > is 
> > > not really a good idea©
> > > 
> > > Cheers
> > > David
> > > 
> > > > view this with so someone else may want to look at this and
> verify
> > > it's