Subject: No search results for "now"

From: "Marti Raudsepp" <[email-masked]>
Date: Wed, 7 May 2008 11:52:04 +0300

Hi,

Someone pointed out in #postgresql that a search for "now" apparently
gives no results, even though PostgreSQL has a now() function:
http://search.postgresql.org/search?u=%2Fdocs%2F8.3%2Fstatic%2F&q=now

Probably needs to be fixed.

Marti

---

From: Bruce Momjian <[email-masked]>
Date: Thu, 26 Jun 2008 18:35:29 -0400 (EDT)

> Probably needs to be fixed.

I can confirm this bug.  Anyone know the cause?

-- 
  Bruce Momjian  <[email-masked]>        http://momjian.us
  EnterpriseDB                             http://enterprisedb.com

  + If your life is a hard drive, Christ can be your backup. +

---

From: Richard Huxton <[email-masked]>
Date: Fri, 27 Jun 2008 08:15:10 +0100

> I can confirm this bug.  Anyone know the cause?

Well, "now" is a stopword in the standard english configuration. Also 
"and", "or", "if", "then" but not "C".

-- 
   Richard Huxton
   Archonet Ltd

---

From: Oleg Bartunov <[email-masked]>
Date: Fri, 27 Jun 2008 18:22:53 +0400 (MSD)

On Fri, 27 Jun 2008, Richard Huxton wrote:

> Well, "now" is a stopword in the standard english configuration. Also "and", 
> "or", "if", "then" but not "C".

There was also problem with parser, reported several times.
Looks like it's a time to redo text search configuration at postgresql.org.

 	Regards,
 		Oleg
_____________________________________________________________
Oleg Bartunov, Research Scientist, Head of AstroNet (www.astronet.ru),
Sternberg Astronomical Institute, Moscow University, Russia
Internet: [email-masked], http://www.sai.msu.su/~megera/
phone: +007(495)939-16-83, +007(495)939-23-83