Subject: From website: all US download links fail for 8.4b1

From: "Gavin M. Roy" <[email-masked]>
Date: Mon, 20 Apr 2009 13:23:21 -0400

I get sent to
http://www.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2which
gives me a Not Found error.

---

From: Dave Page <[email-masked]>
Date: Tue, 21 Apr 2009 08:30:28 +0100

On Mon, Apr 20, 2009 at 6:23 PM, Gavin M. Roy <[email-masked]> wrote:
> I get sent
> to http://www.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2
> which gives me a Not Found error.

Where did you find that URL? Any /redir/ URL should be on wwwmaster
not www (as they seem to be when I check the website).

-- 
Dave Page
EnterpriseDB UK:   http://www.enterprisedb.com

---

From: "Gavin M. Roy" <[email-masked]>
Date: Tue, 21 Apr 2009 13:45:19 -0400

Clicking through from the beta links:

Homepage - Participate in the Beta >
You can find the source code for the latest beta release in our FTP
area (http://www.postgresql.org/developer/beta) >
takes me to http://wwwmaster.postgresql.org/download/mirrors-ftp/source/v8.4beta/postgresql-8.4beta1.tar.bz2
> which automatically redirects me to
http://www.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2

It's still happening right now.  What's odd is the url with the
refresh is wwwmaster.postgresql.org, maybe it's a weidness with
safari?  It works fine in Firefox.  Perhaps it would be better to
change:

<meta http-equiv="refresh"
content="5;/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2"
/>

to

<meta http-equiv="refresh"
content="5;http://wwwmaster.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2"
/>

---

From: Dave Page <[email-masked]>
Date: Tue, 21 Apr 2009 20:06:24 +0100

> content="5;http://wwwmaster.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2"

Hmm, yes I see it now. Magnus; I assume this broke when you re-wrote
the redirector? Can you fix please?

---

From: Magnus Hagander <[email-masked]>
Date: Tue, 21 Apr 2009 21:07:48 +0200

> content="5;http://wwwmaster.postgresql.org/redir/198/h/source/v8.4beta/postgresql-8.4beta1.tar.bz2"

Indeed. And the code attempted to do htat. Except it accessed
master_server instead of masterserver in the settings array.

Fix applied, and update queued. Should be updated in <10 minutes, can
you please try again then? :-)

//Magnus