Subject: [Patch] pglister: gitlab-ci: bump OS and tool for checking syntax

From: Célestin Matte <[email-masked]>
Date: Thu, 7 Aug 2025 11:15:53 +0200

CI is still on buster

-- 
Célestin Matte
From 5f733591e0349e8f1b77e2a172a87c23323a814a Mon Sep 17 00:00:00 2001
From: =?UTF-8?q?C=C3=A9lestin=20Matte?= <[email-masked]>
Date: Mon, 14 Aug 2023 12:06:57 +0200
Subject: [PATCH] gitlab-ci: bump OS and tool for checking syntax

---
 .gitlab-ci.yml | 6 +++---
 1 file changed, 3 insertions(+), 3 deletions(-)

diff --git a/.gitlab-ci.yml b/.gitlab-ci.yml
index 7f31de4..6992859 100644
--- a/.gitlab-ci.yml
+++ b/.gitlab-ci.yml
@@ -3,9 +3,9 @@ stages:
 
 validate syntax:
   stage: test
-  image: "debian:buster"
+  image: "debian:bookworm"
   before_script:
-    - apt-get update -qq && apt-get install -y -qq pep8
+    - apt-get update -qq && apt-get install -y -qq pycodestyle
   script:
     - (for X in $(find . -name "*.py") ; do cat $X | python3 -c "import sys, os; compile(sys.stdin.read(), sys.argv[1], 'exec')" $X ||exit 1 ; done)
-    - pep8 -v .
+    - pycodestyle -v .
-- 
2.50.1

---

From: Magnus Hagander <[email-masked]>
Date: Thu, 7 Aug 2025 16:33:27 +0200

Hah, yeah that's pretty old. Applied.

//Magnus