agora inbox for pljava-dev@postgresql.org
help / color / mirror / Atom feed[Pljava-dev] Posmaster start and stop automatically
2+ messages / 0 participants
[nested] [flat]
* [Pljava-dev] Posmaster start and stop automatically
@ 2004-09-13 19:50
0 siblings, 1 reply; 2+ messages in thread
From: @ 2004-09-13 19:50 UTC (permalink / raw)
Hi Thomas,
Excuse-me Thomas, when i refer classpath isn't a postgresql pljava.classpath, but classpath Windows XP.
Well, I will explain my situation
> This leads me to believe that the PATH you claim you
> have is not the PATH that is visible to the backend process, i.e. it's
> not the path in effect when the postmaster is started. The backend
> process somehow finds an older JRE (1.3 perhaps?) and attempts to load it.
Exactly. I don't know because postmaster is seeing my JRE 1.3, but I uninstall it and now its OK.
I delete deploy.jar from my classpath. Here is my situation now :
CLASSPATH=.;e:\ora9iDS\jlib\bigraphbean.jar;e:\ora9iDS\jlib\LW_PfjBean.jar;e:\or
a9iDS\jlib\bigraphbean-nls.zip;e:\ora9iDS\jdbc\lib\classes12.jar;e:\orad2k6i\for
ms60\java\oracle\opb\javaImporter;e:\orad2k6i\tools\common60\java\importer.jar;E
:\PostgreSQL80_Beta2\data\deploy.jar;E:\PostgreSQL80_Beta2\data\postgresql.jar
JAVA_HOME=E:\j2sdk1.4.1_01
Path=E:\j2sdk1.4.1_01\jre\bin;E:\j2sdk1.4.1_01\jre\bin\client;e:\orant\bin;e:\or
a9iDS\bin;e:\orad2k6i\bin;e:\des_817\bin;e:\ora9i\bin;e:\j2sdk1.4.1_01;e:\ora9iD
S\jdk\jre\bin;e:\ora9iDS\jdk\jre\bin\classic;e:\ora9iDS\jlib;C:\Program Files\Or
acle\jre\1.3.1\bin;e:\ora9i\Apache\Perl\5.00503\bin\mswin32-x86;C:\Program Files
\Oracle\jre\1.1.8\bin;C:\WINDOWS\system32;C:\WINDOWS;C:\WINDOWS\System32\Wbem;e:
\orant\REPADM61\jre1_4\bin;e:\orant\REPADM61\jre1_4\bin\client;e:\orad2k6i\jdk\b
in;e:\j2sdk1.4.1_01\bin;E:\j2sdk1.4.1_01\jre\lib\i386;E:\j2sdk1.4.1_01\jre\lib\i386\client;
In the postgresql.conf, I use
dynamic_library_path = 'E:\\PostgreSQL80_Beta2\\data'
custom_variable_classes = pljava
#pljava.classpath = 'E:\\PostgreSQL80_Beta2\\data\\pljava.jar'
Note that pljava.classpath is commented, when i discomment this line, an error bellow ocurr and postmaster doesn't
start.
"The PostgreSQL Database Server 8.0-beta2-dev3 service on local computer started and then stopped. Some
services stop automatically if they have no work to do, for example, the Performance Logs and Alerts Services".
When I comment this line, the postmaster start and sql.installjar don't see classes built in pljava.jar
ERROR: Unable to load class org/postgresql/pljava/internal/Backend using CLASSPATH '.;e:\ora9iDS\jlib\bigraphbean.jar;e:\ora9iDS\jlib\LW_PfjBean.jar;e:\ora9iDS\jlib\bigraphbean-nls.zip;e:\ora9iDS\jdbc\lib\classes12.jar;e:\orad2k6i\forms60\java\oracle\opb\javaImporter;e:\orad2k6i\tools\common60\java\importer.jar;E:\PostgreSQL80_Beta2\data\deploy.jar;E:\PostgreSQL80_Beta2\data\postgresql.jar'
Regards,
Rodrigo Foscarini
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20040913/c5c49448/attachment.html;
-------------- next part --------------
A non-text attachment was scrubbed...
Name: PCarta SYSPOINT 2.jpg
Type: image/jpeg
Size: 24188 bytes
Desc: not available
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20040913/c5c49448/attachment.jpg;
^ permalink raw reply [nested|flat] 2+ messages in thread
* [Pljava-dev] Posmaster start and stop automatically
@ 2004-09-13 20:50
parent:
0 siblings, 0 replies; 2+ messages in thread
From: @ 2004-09-13 20:50 UTC (permalink / raw)
Rodrigo,
> Excuse-me Thomas, when i refer classpath isn't a postgresql
pljava.classpath, but classpath Windows XP.
>
I understand that. What I'm trying to say is that the postmaster process
(your service) doesn't need the Windows XP classpath. The classpath for
the service should be set using the postgresql.conf and it should only
appoint the pljava.jar.
> In the postgresql.conf, I use
>
> dynamic_library_path = 'E:\\PostgreSQL80_Beta2\\data'
> custom_variable_classes = pljava
> #pljava.classpath = 'E:\\PostgreSQL80_Beta2\\data\\pljava.jar'
>
>
> Note that pljava.classpath is commented, when i discomment this
line, an error bellow ocurr and postmaster doesn't
> start.
>
> "The PostgreSQL Database Server 8.0-beta2-dev3 service on local
computer started and then stopped. Some
> services stop automatically if they have no work to do, for example,
the Performance Logs and Alerts Services".
>
Are you 100% sure this happens when you uncomment that exact line? The
reason I ask is that the line is just read and stored in a placeholder
variable and not in any way used when the postmaster starts! Unless you
have a syntax error or have misspelled "pljava" or "pljava.classpath",
there's no way this can cause the postmaster to fail. The example above
looks very OK though. Do you have a stray character at the end of the
line or something?
The PL/Java module is not loaded until you actually call the first Java
function (install_jar in this case) and that's when the pljava.classpath
is examined for the first time. An error at that time will not cause the
service to fail, it will just be reported in your current session and
rollback the transaction.
Just to prove my point; I copied the lines above into my own
postgresql.conf and started my postmaster without any problems, with or
without the comment. PL/Java won't work with for me using your setting
of course, but there's no problem starting the postmaster.
Regards,
Thomas Hallgren
^ permalink raw reply [nested|flat] 2+ messages in thread
end of thread, other threads:[~2004-09-13 20:50 UTC | newest]
Thread overview: 2+ messages (download: mbox mbox.gz follow: Atom feed)
-- links below jump to the message on this page --
2004-09-13 19:50 [Pljava-dev] Posmaster start and stop automatically
2004-09-13 20:50 `
This inbox is served by agora; see mirroring instructions
for how to clone and mirror all data and code used for this inbox