From: gulden at portugalmail.pt (Gulden) Date: Fri, 1 Apr 2005 20:14:43 +0100 Subject: [Pljava-dev] java.sql.SQLException: ERROR: could not loadlibrary"/usr/local In-Reply-To: <424D98BF.7070302@mailblocks.com> Message-ID: <200504011913.j31JDZnn013513@localhost.localdomain> I'll try to install a new version of java -----Original Message----- From: Thomas Hallgren [mailto:thhal at mailblocks.com] Sent: sexta-feira, 1 de Abril de 2005 18:54 To: Gulden Cc: pljava-dev at gborg.postgresql.org Subject: Re: [Pljava-dev] java.sql.SQLException: ERROR: could not loadlibrary"/usr/local Gulden wrote: >I've added this entry on classpath: > >/usr/java/j2sdk1.4.1_02/jre/lib/i386 > >Without success!! > > The call to dlopen fails with "No such file or directory" when attempting to load the libjvm.so. This indicates that the loader either fails to locate the libjvm.so or something that it in turn requires. Barring a corrupt Java installation, the error you encounter can only come from an insufficient LD_LIBRARY_PATH or from setting the LD_LIBRARY_PATH so that the backend process doesn't see it. From your previous postings, I deduct that the correct LD_LIBRARY_PATH should be something like: /usr/java/j2sdk1.4.1_02/jre/lib/i386/client:/usr/java/j2sdk1.4.1_02/jre/lib/ i386 perhaps with the addition of :/usr/java/j2sdk1.4.1_02/jre/lib/i386/native_threads although the lack of the latter would normally yield another error relating to HPI. So, please verify that your LD_LIBRARY_PATH indeed is correct, that the backend (postmaster) really is started using this path, and that your Java installation is correct. The Java you're using is quite old so a reinstallation might be a good idea anyway. The latest 1.4 is 1.4.2_07 if I remember correctly. Regards, Thomas Hallgren