From: zoong at zoong.com (Zoong PHAM) Date: Fri, 27 May 2005 00:18:01 +1000 Subject: [Pljava-dev] libpljava.so: failed to map segment from shared object: Permission denied In-Reply-To: References: <20050522021120.GC14268@www.zoong.com> <20050526134310.GG14268@www.zoong.com> <4295D458.1070509@mailblocks.com> Message-ID: <20050526141801.GH14268@www.zoong.com> On Thursday, 26 May 2005 at 15:51:20 +0200, Thomas Hallgren wrote: > I haven't seen this before. Try removing the pljava stuff from /usr/lib > (it shouldn't reside there anyway). Your environment setting of But run "make install" in the root source of pljava install the library pljava stuff into /usr/lib. > LD_LIBRARY_PATH and the postgresql.conf setting dynamic_library_path > should be sufficient to find the shared objects where you have installed > them. Anyway, I tried to remove the library stuff and the error message is different now. Here are the details: # ls -l /usr/lib/*libpljava* -rw-r--r-- 1 root root 2097994 May 26 23:53 /usr/lib/libpljava.a lrwxrwxrwx 1 root root 16 May 26 23:53 /usr/lib/libpljava.so -> libpljava.so.1.1 lrwxrwxrwx 1 root root 16 May 26 23:53 /usr/lib/libpljava.so.1 -> libpljava.so.1.1 -rwxr-xr-x 1 root root 1159391 May 26 23:53 /usr/lib/libpljava.so.1.1 # rm /usr/lib/*libpljava* # # echo $LD_LIBRARY_PATH /home/zoong/JDK/pljava-1.1.0/build:/home/zoong/JDK/pljava-1.1.0/build/objs:/usr/lib:/usr/lib/pgsql:/opt/SUNWappserver/lib:/usr/include/pgsql/server/lib:/usr/local/lib:/lib:/opt/SUNWappserver/jdk/jre/lib/i386:/opt/SUNWappserver/jdk/jre/lib/i386/client:/opt/SUNWappserver/jdk/jre/lib/i386/native_threads # # /opt/SUNWappserver/jdk/bin/java -cp /home/zoong/JDK/pljava-1.1.0/build/deploy.jar:/usr/share/java/postgresql-8.0-311.jdbc3.jar org.postgresql.pljava.deploy.Deployer -reinstall -user compiere -database cmpcs java.sql.SQLException: ERROR: could not access file "libpljava": No such file or directory at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1471) at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1256) at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:175) at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:389) at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:314) at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:306) at org.postgresql.pljava.deploy.Deployer.initJavaHandlers(Deployer.java:419) at org.postgresql.pljava.deploy.Deployer.main(Deployer.java:275) # Before running the above commands, I started PostgreSQL as this: # su - postgres -bash-3.00$ echo $LD_LIBRARY_PATH /home/zoong/JDK/pljava-1.1.0/build:/home/zoong/JDK/pljava-1.1.0/build/objs:/usr/lib:/usr/lib/pgsql:/opt/SUNWappserver/lib:/usr/include/pgsql/server/lib:/usr/local/lib:/lib:/opt/SUNWappserver/jdk/jre/lib/i386:/opt/SUNWappserver/jdk/jre/lib/i386/client:/opt/SUNWappserver/jdk/jre/lib/i386/native_threads -bash-3.00$ pg_ctl stop waiting for postmaster to shut down.... done postmaster stopped -bash-3.00$ ps auxww | grep sql -bash-3.00$ pg_ctl start -D /var/lib/pgsql/data -l logfile -o "-i" postmaster starting -bash-3.00$ ps auxww | grep sql postgres 13905 3.5 0.5 19148 2920 ? S 00:09 0:00 /usr/bin/postmaster -D /var/lib/pgsql/data -i postgres 13912 0.0 0.1 5604 648 pts/5 R+ 00:09 0:00 grep sql -bash-3.00$