From: dgaethofs at yahoo.com (Danny Gaethofs) Date: Thu, 16 Jun 2005 07:04:03 -0700 (PDT) Subject: [Pljava-dev] PL/JAVA on Windows In-Reply-To: Message-ID: <20050616140403.13906.qmail@web54708.mail.yahoo.com> Dear Thomas, Definitely these lines of code are causing the problem. Last day when I was working on getting pljava installed I did not stop the server when making the changes to the postgresql.conf file. Later the evening when I rebooted my machine I got the same error which I could not explain. So I completely reinstalled postgresql and the problem was over. Today I restarted the installation of pljava and there it was again the strange error. When I stop the server, change my postgresql.conf and remove these lines of code, start the server, start pgadminiii, I can access my database. When I stop the server, put lines of code in the postgresql.conf, start the server, it is no longer possible to open the connection in pgadminiii. With the error message mentioned. After your reply I did shut down the server and added the lines of code. Then I rebooted my machine, and did the same test. It is giving me the same results. So please help me out identifying what the problem is. Regards, Danny --- Thomas Hallgren wrote: > Danny, > I'm sorry, but there's just no way there can be a > correlation between > the error you get and the lines you claim you > remove. There must be > something else that you overlook. My guess is that > the port is busy due > to TCP/IP lingering a while after the old server > closed down. > > And yes, lots of people use PL/Java succesfully on > Windows XP. > > Regards, > Thomas Hallgren > > Danny Gaethofs wrote: > > >Dear Thomas, > > > >After stopping the postgresql server and restarting > >it, I am no longer able to open the server > connection > >in pgadminiii. The message I get is: > >could not connect to server: Connection refused > >(0x0000274D/10061) > >Is the server running on host "127.0.0.1" and > >accepting TCP/IP connections on port 5432? > > > >When I remove these lines from my postgresql.conf > it > >works again. > > > >--------------------------------------------------------------------------- > ># PLJAVA - 13-05-06 > >#--------------------------------------------------------------------------- > ># define "pljava" as a custom variable class. This > is > >a comma separated > ># list of names. > ># > >custom_variable_classes = 'pljava' > > > ># define the class path that the JVM will use when > >loading the > ># initial library. Only meaningful for non GJC > >installations > ># > >#old pljava.classpath = > >'/home/Tada/pljava/build/pljava.jar' > >pljava.classpath = > >'C:\ProgramFiles\PostgreSQL\8.0\pljava\pljava.jar' > > > ># Set the size of the prepared statement MRU cache > ># > >pljava.statement_cache_size = 10 > > > ># If true, lingering savepoints will be released on > >function exit. If false, > ># the will be rolled back > ># > >pljava.release_lingering_savepoints = true > > > ># Define startup options for the Java VM. > ># > >pljava.vmoptions = '-Xmx64M' > > > ># Setting debug to true will cause the postgres > >process to go > ># into a sleep(1) loop on its first call to java. > This > >is > ># only useful if you want to debug the PL/Java > >internal C code. > ># > >pljava.debug = false > > > > > >I thought installing pljava would be easy? > >Has anyone succeeded doing it on windows xp? > > > >regards, > >Danny > > > >--- Thomas Hallgren wrote: > > > > > > > >>Danny Gaethofs wrote: > >> > >> > >> > >>>After defining the CLASSPATH as an user > environment > >>>variable that contains: > >>> > >>> > >>C:\ProgramFiles\PostgreSQL\8.0\jdbc\postgresql-8.0-310.jdbc2.jar;C:\ProgramFiles\PostgreSQL\8.0\pljava\deploy.jar > >> > >> > >>>The deployer now works. When I create a database > >>> > >>> > >>and > >> > >> > >>>issue the command: > >>>C:\>java org.postgresql.pljava.deploy.Deployer > >>>-install -user compiere -password > >>>compiere -database cmpcs > >>> > >>>I get the message > >>>java.sql.SQLException: ERROR: could not access > file > >>>"libpljava": No such file or > >>>directory > >>> > >>>But strange is that when I look at the database I > >>> > >>> > >>find > >> > >> > >>>the schema sqlj is created. > >>> > >>>Is this what should happen? If yes why am i > getting > >>>this error message about not finding libjava? > >>> > >>>And what should I do to solve it. > >>> > >>> > >>> > >>> > >>The schema is created before the functions in that > >>schema are created > >>and called. The error you see is when a java > >>function is called and > >>tries to instantiate the pljava binary module. > Your > >>postgresql.conf file > >>contains the following line: > >> > >>dynamic_library_path = > >>'$libdir:C:\\ProgramFiles\\PostgreSQL\\8.0\\pljava' > >> > >>Change the first colon to a semicolon. Windows use > >>semicolon as the path separator (it has too since > >>colon is part of the drive designator). > >> > >>Now run the deployer again with option -uninstall. > >>You will see an error (since the language is not > >>installed) but you can ignore it. Then try to > >>install again. > >> > >>Regards, > >>Thomas Hallgren > >> > >> > >> > >> > >> > >> > > > > > > > > > >__________________________________ > >Discover Yahoo! > >Use Yahoo! to plan a weekend, have fun online and > more. Check it out! > >http://discover.yahoo.com/ > > > > > > > __________________________________________________ Do You Yahoo!? Tired of spam? Yahoo! Mail has the best spam protection around http://mail.yahoo.com