From: thomas at tada.se (Thomas Hallgren) Date: Sat, 29 Oct 2005 14:27:35 +0200 Subject: R: Re: [Pljava-dev] crash due to huge load? In-Reply-To: <43621BAB00003456@mail-7.mail.tiscali.sys> References: <43621BAB00003456@mail-7.mail.tiscali.sys> Message-ID: <43636AB7.7080409@tada.se> Roberto, Thank you for the logs. Now it starts to get interesting. You get several normal process terminations from instances that use PL/Java (I see a couple of _destroyJavaVM which indicates of a normal shutdown) yet the postmaster consider them crashed processes. I'm not sure why that happens. You say it only happens under heavy load. Perhaps it's the Java VM shutdown in itself that crashes somehow. I'll have to investigate that further. A couple of questions. 1. Are you now using the latest CVS? I.e. if I provide patches, will you be able to try them out? 2. What kind of system are you on? 3. Would it be possible for you to include a pid or session id included in the backend trace (use a log_line_prefix with %p in it)? You use several instances here and it's hard to tell which trace that origins from which session. Regards, Thomas Hallgren rcolmegna at tiscali.it wrote: > As you requested I sent you other logs. > > Note that errors appear only under huge load. > > TIA > Roberto Colmegna > > ---- Messaggio originale ---- > Data: Sat Oct 29 10:59:47 CEST 2005 > Da: Thomas Hallgren > A: rcolmegna at tiscali.it > Cc: pljava-dev at gborg.postgresql.org > Ccn: > Ogg.: Re: R: Re: [Pljava-dev] crash due to huge load? > > Roberto, > Some of you problems stems from the following lines: > > ERROR: XX000: java.lang.NoClassDefFoundError: > org/postgresql/core/StartupPacket > ERROR: XX000: java.lang.NoClassDefFoundError: > it/robcol/distribdb/util/SQLIntrospector > > You need to find the cause of these errors. You also get a warning from > PL/Java: > > WARNING: 01000: 29 Oct 05 09:35:14 > org.postgresql.pljava.jdbc.Invocation Closing 1 "forgotten" statement > > this indicates that you have prepared statements that you don't close. > > Please set the log_min_messages in your postgresql.conf to DEBUG1. That > will reveal some more info. > > Regards, > Thomas Hallgren > > > > __________________________________________________________________ > TISCALI ADSL > Solo con Tiscali Adsl navighi senza limiti e telefoni senza canone > Telecom a partire da 19,95 Euro/mese. > Attivala subito, I PRIMI DUE MESI SONO GRATIS! CLICCA QUI: > http://abbonati.tiscali.it/adsl/sa/1e25flat_tc/ > > > >