Subject: [Pljava-dev] Help SetUserIdAndContext

From: kpesmart at hotmail.com (Parisso Escamilla)
Date: Thu, 12 Jun 2008 10:57:39 -0500

Hi to all, i?ve been trying to install PlJava but i can?t, every time i received the same error when i try to run install.sql.

My system is CentOS 5.1.
JDK 1.5.0.15
Postgres 8.1.11-1
Pl/Java 1.4 this version dont?have problem with assert_enabled errors, i downloaded from ejurka ftp.

All envrionment variables are correct, in PATH, etc.

LD_LIBRARY_PATH=/usr/java/jdk1.5.0_15/jre/lib/i386:/usr/java/jdk1.5.0_15/jre/lib/i386/client:/usr/java/jdk1.5.0_15/jre/lib/i386/native_threads:/usr/local/pgsql/lib
CREATE SCHEMA

GRANT

psql:install.sql:6: ERROR: could not load library "/usr/local/pgsql/lib/pljava.so": /usr/local/pgsql/lib/pljava.so: undefined symbol: SetUserIdAndContext

psql:install.sql:8: ERROR: function sqlj.java_call_handler() does not exist

psql:install.sql:12: ERROR: could not load library "/usr/local/pgsql/lib/pljava.so": /usr/local/pgsql/lib/pljava.so: undefined symbol: SetUserIdAndContext

psql:install.sql:14: ERROR: function sqlj.javau_call_handler() does not exist

psql:install.sql:23: NOTICE: CREATE TABLE will create implicit sequence "jar_repository_jarid_seq" for serial column "jar_repository.jarid"

psql:install.sql:23: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "jar_repository_pkey" for table "jar_repository"

psql:install.sql:23: NOTICE: CREATE TABLE / UNIQUE will create implicit index "jar_repository_jarname_key" for table "jar_repository"

CREATE TABLE

GRANT

psql:install.sql:32: NOTICE: CREATE TABLE will create implicit sequence "jar_entry_entryid_seq" for serial column "jar_entry.entryid"

psql:install.sql:32: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "jaar_entry_jarid_key" for table "jar_entry"

CREATE TABLE

GRANT

ALTER TABLE

psql:install.sql:43: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "classpath_entry_pkey" for table "classpath_entry"

CREATE TABLE

GRANT

psql:install.sql:50: NOTICE: CREATE TABLE will create implicit sequence "typemap_entry_mapid_seq" for serial column "typemap_entry.mapid"

psql:install.sql:50: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "typemap_entry_pkey" for table "typemap_entry"

CREATE TABLE

GRANT

psql:install.sql:55: ERROR: language "java" does not exist

psql:install.sql:59: ERROR: language "java" does not exist

psql:install.sql:63: ERROR: language "java" does not exist

psql:install.sql:67: ERROR: language "java" does not exist

psql:install.sql:71: ERROR: language "java" does not exist

psql:install.sql:75: ERROR: language "java" does not exist

psql:install.sql:79: ERROR: language "java" does not exist

psql:install.sql:83: ERROR: language "java" does not exist

psql:install.sql:87: ERROR: language "java" does not exist

I don?t know what i did wrong, every is checked and i think is correct. Help me!!!

Thank you!!!!

Parisso Escamilla
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080612/281a6ba0/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Thu, 12 Jun 2008 09:06:00 -0700

Parisso Escamilla wrote:
> Hi to all, i?ve been trying to install PlJava but i can?t, every time i 
> received the same error when i try to run install.sql.
>  
> My system is CentOS 5.1.
> JDK 1.5.0.15
> Postgres 8.1.11-1
> psql:install.sql:6: ERROR: could not load library 
> "/usr/local/pgsql/lib/pljava.so": /usr/local/pgsql/lib/pljava.so: 
> undefined symbol: SetUserIdAndContext
> 

Are you sure you're trying to install this into 8.1.11?  You may have 
the RPM for 8.1.11 installed, but it looks like you're installing it 
into /usr/local/pgsql which may be a different version.

Kris Jurka

---

From: books at ejurka.com (Kris Jurka)
Date: Thu, 12 Jun 2008 09:31:35 -0700

Parisso Escamilla wrote:
> 
> I compiled postgresql-base.8.1.9.tar.gz in /usr/local/src and the 
> installation put it into /usr/local/psql.
> I followed all the instructions in INSTALL archive in postgres files.
> 
> The system result is psql version 8.1.9 postgres-server 8.1.11
> 
> I did something wrong??? or is better to run RPM archive.

The binary pljava 1.4 builds for 8.1 will only work with 8.1.11 or 
higher.  This is why you can't install them on your 8.1.9 server.  The 
source will build against either server version, but you the compiled 
results can only be used for servers that provide the same API as it was 
compiled against.  If your OS provides 8.1.11, I don't see why you would 
go to the trouble of installing a separate copy of an older version.

Kris Jurka