Subject: [Pljava-dev] How to compile pljava in Solaris 10 5/08?

From: terencenwk at hotmail.com (Terence Ng)
Date: Sun, 8 Jun 2008 11:10:51 +0800

_________________________________________________________________
Connect to the next generation of MSN Messenger?
http://imagine-msn.com/messenger/launch80/default.aspx?locale=en-us&source=wlmailtagline
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080608/e1312de0/attachment.html>

---

From: jurka at ejurka.com (Kris Jurka)
Date: Sat, 07 Jun 2008 22:21:11 -0600

Terence Ng wrote:
>  
> I have difficulty in compiling pljava 1.4.0 in Solaris 10 5/08.
> I am using Postgresql 8.2, JDK1.5..0, GCC and Binutils packages in Solaris.
> 
> There is an error during compiling: 
>  
> /bin/sh: /ws/on10-tools/SUNWspro/SS11/bin/cc: not found 

Pljava is trying to use the same compiler and options to build pljava as 
the postgresql server was compiled with.  Apparently your postgresql 
package was built with Solaris' compiler, so it's trying to use that 
instead of gcc which you have installed.

You can override this by setting the CUSTOM_CC environment variable to 
point to gcc, but you'll still have the old CFLAGS and other things 
which are not so easy to override.  The easiest thing would be to 
install the sun compiler, next easiest would be to build your own 
postgresql version with gcc, and finally you could adjust assorted parts 
of the pljava build system to build with gcc instead of sun's compiler.

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Sun, 8 Jun 2008 22:50:34 +0800

Hi Kris,
 
I have installed Solaris Studio 12 the C compiler and build tool.  After running:
# cd /var/tmp/pljava/pljava-1.4.0
# /opt/SUNWspro/bin/dmakedmake: Warning: Can't find `make.rules': No such file or directorydmake: Fatal error in reader: Makefile, line 30: Unexpected end of line seen
 
What should I do?  Should I also install the C++ compiler?
 
Regards,
Terence 

> Date: Sat, 7 Jun 2008 22:21:11 -0600> From: jurka at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: [Pljava-dev] How to compile pljava in Solaris 10 5/08?> > Terence Ng wrote:> > > > I have difficulty in compiling pljava 1.4.0 in Solaris 10 5/08.> > I am using Postgresql 8.2, JDK1.5..0, GCC and Binutils packages in Solaris.> > > > There is an error during compiling: > > > > /bin/sh: /ws/on10-tools/SUNWspro/SS11/bin/cc: not found > > Pljava is trying to use the same compiler and options to build pljava as > the postgresql server was compiled with. Apparently your postgresql > package was built with Solaris' compiler, so it's trying to use that > instead of gcc which you have installed.> > You can override this by setting the CUSTOM_CC environment variable to > point to gcc, but you'll still have the old CFLAGS and other things > which are not so easy to override. The easiest thing would be to > install the sun compiler, next easiest would be 
 to build your own > postgresql version with gcc, and finally you could adjust assorted parts > of the pljava build system to build with gcc instead of sun's compiler.> > Kris Jurka
_________________________________________________________________
Discover the new Windows Vista
http://search.msn.com/results.aspx?q=windows+vista&mkt=en-US&form=QBRE
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080608/d90ff0ed/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Sun, 08 Jun 2008 12:02:38 -0600

Terence Ng wrote:
> # /opt/SUNWspro/bin/dmake
> dmake: Warning: Can't find `make.rules': No such file or directory
> dmake: Fatal error in reader: Makefile, line 30: Unexpected end of line seen
>  

You still need to use GNU make to build pljava, not dmake.  Also since
you've installed sun studio 12 (and into a different location) instead
of the used sun studio 11, you'll need to either set CUSTOM_CC to point
to your cc binary, or make some symlinks.

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Tue, 10 Jun 2008 23:58:07 +0800

Hi,
 
I still cannot compile pljava, the output is:
 
         22:18:56 svc:/application/database/postgresql:version_82#I did install the postgresql devel and header package and jdbc package.  What did I miss?
 
Regards,
Terence

> Date: Sun, 8 Jun 2008 12:02:38 -0600> From: books at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: [Pljava-dev] How to compile pljava in Solaris 10 5/08?> > > > Terence Ng wrote:> > > > I have installed Solaris Studio 12 the C compiler and build tool. After > > running:> > # cd /var/tmp/pljava/pljava-1.4.0> > # /opt/SUNWspro/bin/dmake> > dmake: Warning: Can't find `make.rules': No such file or directory> > dmake: Fatal error in reader: Makefile, line 30: Unexpected end of line seen> > > > You still need to use GNU make to build pljava, not dmake. Also since> you've installed sun studio 12 (and into a different location) instead> of the used sun studio 11, you'll need to either set CUSTOM_CC to point> to your cc binary, or make some symlinks.> > Kris Jurka
_________________________________________________________________
News, entertainment and everything you care about at Live.com. Get it now!
http://www.live.com/getstarted.aspx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080610/6b60a003/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Wed, 11 Jun 2008 09:18:49 -0700

Terence Ng wrote:
>  
> # echo $CUSTOM_CC
> /opt/SUNWspro/bin/cc
> # gmake
> "/usr/postgres/8.2/include/server/pg_config_os.h", line 17: cannot find 
> include file: <sys/isa_defs.h>
> "/usr/postgres/8.2/include/server/pg_trace.h", line 17: cannot find 
> include file: <sys/sdt.h>
> "/usr/postgres/8.2/include/server/c.h", line 68: cannot find include 
> file: <stdio.h>

I don't know why it can't find stock system headers, that's pretty odd.
 I might try setting the CUSTOM_COPT environment variable to
"-I/usr/include".

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Thu, 12 Jun 2008 23:47:59 +0800

Kris,
 
Thanks.  I can build pljava now.  It is because the following packages are missing:
 
sdt.h -> dtrace (SUNWdtrp, SUNWdtrc)
stdio.h -> SunOS C/C++ header files (SUNWhea)
math.h -> Math and Microtasking Library (SUNWlibmr, SUNWlibm
 
Regards,
Terence

> Date: Wed, 11 Jun 2008 09:18:49 -0700> From: books at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: [Pljava-dev] How to compile pljava in Solaris 10 5/08?> > Terence Ng wrote:> > > > # echo $CUSTOM_CC> > /opt/SUNWspro/bin/cc> > # gmake> > "/usr/postgres/8.2/include/server/pg_config_os.h", line 17: cannot find > > include file: <sys/isa_defs.h>> > "/usr/postgres/8.2/include/server/pg_trace.h", line 17: cannot find > > include file: <sys/sdt.h>> > "/usr/postgres/8.2/include/server/c.h", line 68: cannot find include > > file: <stdio.h>> > I don't know why it can't find stock system headers, that's pretty odd.> I might try setting the CUSTOM_COPT environment variable to> "-I/usr/include".> > Kris Jurka
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080612/604e97df/attachment.html>

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Mon, 21 Jul 2008 16:53:48 +0800

Hi Kris,
 
I suppose I have installed pljava adequately.  But I discover that something wrong and want to re-install it again...but fail to install.  I do not know where should I start.  Please give me some suggestions.
 
How do I know the installation is okay?
 
# JAVA_HOME=/usr/jdk/instances/jdk1.5.0# export JAVA_HOME# java -cp /usr/postgres/8.2/lib/deploy.jar:/usr/postgres/8.2/jdbc/postgresql.jar org.postgresql.pljava.deploy.Deployer -install -user adempiere -database adempiere -password adempiereorg.postgresql.util.PSQLException: ERROR: schema "sqlj" already exists        at org.postgresql.core.v3.QueryExecutorImpl.receiveErrorResponse(QueryExecutorImpl.java:1548)        at org.postgresql.core.v3.QueryExecutorImpl.processResults(QueryExecutorImpl.java:1316)        at org.postgresql.core.v3.QueryExecutorImpl.execute(QueryExecutorImpl.java:191)        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:452)        at org.postgresql.jdbc2.AbstractJdbc2Statement.executeWithFlags(AbstractJdbc2Statement.java:337)        at org.postgresql.jdbc2.AbstractJdbc2Statement.execute(AbstractJdbc2Statement.java:329)        at org.postgresql.pljava.deploy.Deployer.createSQLJSchema(Deployer.java:351)        at org.pos
 tgresql.pljava.deploy.Deployer.main(Deployer.java:268)
# psql -d adempiere -U adempierePassword for user adempiere:Welcome to psql 8.2.6, the PostgreSQL interactive terminal.
Type:  \copyright for distribution terms       \h for help with SQL commands       \? for help with psql commands       \g or terminate with semicolon to execute query       \q to quit
adempiere=# SELECT sqlj.install_jar('file:///opt/Adempiere/lib/sqlj.jar','sqlj',true);ERROR:  function sqlj.install_jar("unknown", "unknown", boolean) does not existLINE 1: SELECT sqlj.install_jar('file:///opt/Adempiere/lib/sqlj.jar'...               ^HINT:  No function matches the given name and argument types. You may need to add explicit type casts.adempiere=# \qcould not save history to file "//.psql_history": Permission denied
# psql -d adempiere -U adempiere -f /usr/postgres/8.2/share/install.sqlPassword for user adempiere:psql:/usr/postgres/8.2/share/install.sql:1: ERROR:  schema "sqlj" already existsGRANTpsql:/usr/postgres/8.2/share/install.sql:6: ERROR:  could not load library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: open failed: No such file or directorypsql:/usr/postgres/8.2/share/install.sql:8: ERROR:  function sqlj.java_call_handler() does not existpsql:/usr/postgres/8.2/share/install.sql:12: ERROR:  could not load library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: open failed: No such file or directorypsql:/usr/postgres/8.2/share/install.sql:14: ERROR:  function sqlj.javau_call_handler() does not existpsql:/usr/postgres/8.2/share/install.sql:23: NOTICE:  CREATE TABLE will create implicit sequence "jar_repository_jarid_seq1" for serial column "jar_repository.jarid"psql:/usr/postgres/8.2/share/install.sql:23: ERROR:  relation "jar_r
 epository" already existsGRANTpsql:/usr/postgres/8.2/share/install.sql:32: NOTICE:  CREATE TABLE will create implicit sequence "jar_entry_entryid_seq1" for serial column "jar_entry.entryid"psql:/usr/postgres/8.2/share/install.sql:32: ERROR:  relation "jar_entry" already existsGRANTALTER TABLEpsql:/usr/postgres/8.2/share/install.sql:43: ERROR:  relation "classpath_entry" already existsGRANTpsql:/usr/postgres/8.2/share/install.sql:50: NOTICE:  CREATE TABLE will create implicit sequence "typemap_entry_mapid_seq1" for serial column "typemap_entry.mapid"psql:/usr/postgres/8.2/share/install.sql:50: ERROR:  relation "typemap_entry" already existsGRANTpsql:/usr/postgres/8.2/share/install.sql:55: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:59: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:63: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:67: ERROR:  language "java" does not existpsql:
 /usr/postgres/8.2/share/install.sql:71: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:75: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:79: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:83: ERROR:  language "java" does not existpsql:/usr/postgres/8.2/share/install.sql:87: ERROR:  language "java" does not exist# 
Regards,
Terence
_________________________________________________________________
Explore the seven wonders of the world
http://search.msn.com/results.aspx?q=7+wonders+world&mkt=en-US&form=QBRE
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080721/29e7f857/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 21 Jul 2008 03:10:10 -0600

Terence Ng wrote:
>  
> I suppose I have installed pljava adequately.  But I discover that 
> something wrong and want to re-install it again...but fail to install..  
> I do not know where should I start.  Please give me some suggestions.
>  

I don't believe your install worked correctly.  To clear out the old
installation there should be an uninstall.sql alongside the install.sql
file.  So I'd give that a shot.

> psql:/usr/postgres/8.2/share/install.sql:6: ERROR:  could not load 
> library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: 
> libjvm.so: open failed: No such file or directory

This is your real problem here.  I'm guessing you haven't set
LD_LIBRARY_PATH appropriately prior to starting the server.

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Mon, 21 Jul 2008 23:23:39 +0800

Hi Kris,
 
After I set LD_LIBRARY_PATH and run uninstall.sql, there still has an error saying "java" does not exit.  Why?
 
Do I have to set /etc/ld.so.conf.d/postgresql.conf (as in SLES10) when I am using SOLARIS 10?
 
# echo $JAVA_HOME/usr/jdk/instances/jdk1.5.0# echo $LD_LIBRARY_PATH/usr/postgres/8.2/lib:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/native_threads:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/server# echo $JAVA_HOME/usr/jdk/instances/jdk1.5.0# svcadm restart postgresql:version_82# psql -d adempiere -U adempiere -f /var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sqlPassword for user adempiere:psql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:1: ERROR:  language "java" does not existpsql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:2: ERROR:  language "javau" does not existpsql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:3: ERROR:  schema "sqlj" does not exist#Regards, Terence

> Date: Mon, 21 Jul 2008 03:10:10 -0600> From: books at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: [Pljava-dev] java.lang.NoClassDefFoundError> > > > Terence Ng wrote:> > > > I suppose I have installed pljava adequately. But I discover that > > something wrong and want to re-install it again...but fail to install.. > > I do not know where should I start. Please give me some suggestions.> > > > I don't believe your install worked correctly. To clear out the old> installation there should be an uninstall.sql alongside the install.sql> file. So I'd give that a shot.> > > psql:/usr/postgres/8.2/share/install.sql:6: ERROR: could not load > > library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: > > libjvm.so: open failed: No such file or directory> > This is your real problem here. I'm guessing you haven't set> LD_LIBRARY_PATH appropriately prior to starting the server.> > Kris Jurka
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080721/2417ed8e/attachment.html>

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Sun, 27 Jul 2008 00:57:30 +0800

Hi TrifonAfter I set LD_LIBRARY_PATH and run uninstall.sql to clear previous installation, there still has an error saying "java" does not exit.  Why?  What did I miss? I have explicitly set LD_LIBRARY_PATH and set in /usr/ld/ld.config by using crle -u -i ...
I have set the dynamic_library_path='$libdir:/usr/postgres/8.2/lib' in postgresql.conf 
 
# echo $LD_LIBRARY_PATH/usr/postgres/8.2/lib:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/native_threads:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/server# echo $JAVA_HOME/usr/jdk/instances/jdk1.5.0
# java -versionjava version "1.5.0_15"Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)Java HotSpot(TM) Client VM (build 1.5.0_15-b04, mixed mode, sharing)# svcadm restart postgresql:version_82# psql -d adempiere -U adempiere -f /var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sqlPassword for user adempiere:psql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:1: ERROR:  language "java" does not existpsql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:2: ERROR:  language "javau" does not existpsql:/var/tmp/pljava/pljava-1.4.0/src/sql/uninstall.sql:3: ERROR:  schema "sqlj" does not exist#Regards, Terence
_________________________________________________________________
Connect to the next generation of MSN Messenger?
http://imagine-msn.com/messenger/launch80/default.aspx?locale=en-us&source=wlmailtagline
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080727/3a6c7af8/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Tue, 29 Jul 2008 11:15:19 -0600

Terence Ng wrote:
> 
> After I set LD_LIBRARY_PATH and run uninstall.sql to clear previous 
> installation, there still has an error saying "java" does not exit.  
> Why?  What did I miss?

If your previous installation didn't get completely installed than the 
uninstall will fail to uninstall some parts of it.  That's expected. 
Also if you run the uninstall script multiple times it should only do 
something interesting on the first run.  I believe you've sufficiently 
uninstalled it to begin the installation again.

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Wed, 30 Jul 2008 22:35:00 +0800

I don't know why it cannot find libjvm.so and java. What should I do?# echo $LD_LIBRARY_PATH/usr/jdk/instances/jdk1.5.0/jre/lib/i386:/usr/jdk/instances /jdk1.5.0/jre/lib/i386/client:/usr/jdk/instances/jdk1.5.0/jre/lib/i386/native_threads# echo $LD_LIBRARY_PATH_64/usr/jdk/instances/jdk1.5.0/jre/lib/amd64:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/server:/usr/jdk/instances/jdk1.5.0/jre/lib/amd64/native_threads# echo $JAVA_HOME/usr/jdk/instances/jdk1.5.0# java -versionjava version "1.5.0_15"Java(TM) 2 Runtime Environment, Standard Edition (build 1.5.0_15-b04)Java HotSpot(TM) Client VM (build 1.5.0_15-b04, mixed mode, sharing)# psql -d adempiere -U adempiere -f install.sqlPassword for user adempiere:CREATE SCHEMAGRANTpsql:install.sql:6: ERROR: could not load library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: open failed: No such file or directorypsql:install.sql:8: ERROR: function sqlj.java_call_handler() does not existpsql:install.sql:12: ERROR: could not load library "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: open failed: No such file or directorypsql:install.sql:14: ERROR: function sqlj.javau_call_handler() does not existpsql:install.sql:23: NOTICE: CREATE TABLE will create implicit sequence "jar_repository_jarid_seq" for serial column "jar_repository.jarid"psql:install.sql:23: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "jar_repository_pkey" for table "jar_repository"psql:install.sql:23: NOTICE: CREATE TABLE / UNIQUE will create implicit index "jar_repository_jarname_key" for table "jar_repository"CREATE TABLEGRANTpsql:install.sql:32: NOTICE: CREATE TABLE will create implicit sequence "jar_entry_entryid_seq" for serial column "jar_entry.entryid"psql:install.sql:32: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "jar_entry_pkey" for table "jar_entry"psql:install.sql:32: NOTICE: CREATE TABLE / UNIQUE will create implicit index "jar_entry_jarid_key" for table "jar_entry"CREATE TABLEGRANTALTER TABLEpsql:install.sql:43: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "classpath_entry_pkey" for table "classpath_entry"CREATE TABLEGRANTpsql:install.sql:50: NOTICE: CREATE TABLE will create implicit sequence "typemap_entry_mapid_seq" for serial column "typemap_entry.mapid"psql:install.sql:50: NOTICE: CREATE TABLE / PRIMARY KEY will create implicit index "typemap_entry_pkey" for table "typemap_entry"CREATE TABLEGRANTpsql:install.sql:55: ERROR: language "java" does not existpsql:install.sql:59: ERROR: language "java" does not existpsql:install.sql:63: ERROR: language "java" does not existpsql:install.sql:67: ERROR: language "java" does not existpsql:install.sql:71: ERROR: language "java" does not existpsql:install.sql:75: ERROR: language "java" does not existpsql:install.sql:79: ERROR: language "java" does not existpsql:install.sql:83: ERROR: language "java" does not existpsql:install.sql:87: ERROR: language "java" does not exist# Terence Ng

> Date: Tue, 29 Jul 2008 11:15:19 -0600> From: books at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: language "java" does not exist> > Terence Ng wrote:> > > > After I set LD_LIBRARY_PATH and run uninstall.sql to clear previous > > installation, there still has an error saying "java" does not exit. > > Why? What did I miss?> > If your previous installation didn't get completely installed than the > uninstall will fail to uninstall some parts of it. That's expected. > Also if you run the uninstall script multiple times it should only do > something interesting on the first run. I believe you've sufficiently > uninstalled it to begin the installation again.> > Kris Jurka
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080730/a2df9d67/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Wed, 30 Jul 2008 09:00:29 -0600

Terence Ng wrote:
> I don't know why it cannot find libjvm.so and java. What should I do?
> 
> # echo $LD_LIBRARY_PATH
> /usr/jdk/instances/jdk1.5.0/jre/lib/i386:/usr/jdk/instances 
> /jdk1.5.0/jre/lib/i386/client:/usr/jdk/instances/jdk1.5.0/jre/lib/i386/native_threads

> psql:install.sql:6: ERROR: could not load library 
> "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: 
> open failed: No such file or directory

Setting LD_LIBRARY_PATH in your current environment doesn't help.  You 
need it set in the server's environment.

Kris Jurka

---

From: terencenwk at hotmail.com (Terence Ng)
Date: Thu, 31 Jul 2008 00:32:41 +0800

I am sorry.  I do not have any idea to set the server's environment.  Could you give me some hints, so that I can as least look for the instructions.
 
Thanks in advance,
Terence

> Date: Wed, 30 Jul 2008 09:00:29 -0600> From: books at ejurka.com> To: terencenwk at hotmail.com> CC: pljava-dev at pgfoundry.org> Subject: Re: language "java" does not exist> > Terence Ng wrote:> > I don't know why it cannot find libjvm.so and java. What should I do?> > > > # echo $LD_LIBRARY_PATH> > /usr/jdk/instances/jdk1.5.0/jre/lib/i386:/usr/jdk/instances > > /jdk1.5.0/jre/lib/i386/client:/usr/jdk/instances/jdk1.5.0/jre/lib/i386/native_threads> > > psql:install.sql:6: ERROR: could not load library > > "/usr/postgres/8.2/lib/pljava.so": ld.so.1: postgres: fatal: libjvm.so: > > open failed: No such file or directory> > Setting LD_LIBRARY_PATH in your current environment doesn't help. You > need it set in the server's environment.> > Kris Jurka
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080731/075bc417/attachment.html>