Subject: [Pljava-dev] How to compile 1.4.0 pljava.so from source?

From: daniel at notima.se (Daniel Tamm)
Date: Wed, 13 Aug 2008 21:13:39 +0200

Hi

I've downloaded the source for pljava-1.4.0

Running

make USE_GCJ=1

gives me a pljava_jar.o file in the build/objs directory and it's not a 
dynamic library.

I need a pljava.so file instead (like in the binary distributions). Is 
that easily achieved by changing some flags when running make?

-- 
Daniel Tamm

---

From: daniel at notima.se (Daniel Tamm)
Date: Thu, 14 Aug 2008 15:57:38 +0200

I solved the problem. The package postgresql-devel containing pg_config 
was not installed on the server. When I installed it and recompiled I 
got the pljava.so that I needed.