Subject: [Pljava-dev] error JNI_CreateJavaVM

From: mminout at admin.ulb.ac.be (MINOUT Mohammed)
Date: Fri, 12 Sep 2008 08:44:20 +0200

Hi,

 Can you help me.

 I compiled pljava 1.4. i have this error :

 ERROR: could not load library "/usr/share/plj

 ava/pljava.so": /usr/share/pljava/pljava.so: undefined symbol:
JNI_CreateJavaVM

 i tested all case for LD_LIBRARY_PATH but i have the error.

 My machine:

 AMD

 Java 1.4.2

 Thanks

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080912/a350cd08/attachment.html>

---

From: thomas at tada.se (Thomas Hallgren)
Date: Fri, 12 Sep 2008 09:32:38 +0200

The most common error is setting the LD_LIBRARY_PATH for the client 
instead of the server. Are you sure the PostgreSQL server runs with the 
LD_LIBRARY_PATH set correctly?

Regards,
Thomas Hallgren

MINOUT Mohammed wrote:
> ------------------------------------------------------------------------
>
> _______________________________________________
> Pljava-dev mailing list
> Pljava-dev at pgfoundry.org
> http://pgfoundry.org/mailman/listinfo/pljava-dev