Subject: [Pljava-dev] problem with date and timezone

From: Eric.Boyer at insa-toulouse.fr (Eric BOYER)
Date: Mon, 24 Nov 2008 17:06:51 +0100

Hello,

When I set a date in a row, this row is OK but the trigger seems not to 
be in the same timezone because I have one day less (in reality one hour).

I use Debian :
aladin at srv-aladin:/usr/local/aladin$ more /etc/timezone
Europe/Paris

My JVM tell me : System.out.println(TimeZone.getDefault());
sun.util.calendar.ZoneInfo[id="GMT+01:00",offset=3600000,dstSavings=0,useDaylight=false,transitions=0,lastRule=null]

And the trigger :
sun.util.calendar.ZoneInfo[id="GMT+01:00",offset=3600000,dstSavings=0,useDaylight=false,transitions=0,lastRule=null]

So that's the same ...

On another server, all is OK but with the same localtime !!! :
boyere at footcrix:~/INSA/documents/foot$ more /etc/timezone
Europe/Paris

My JVM and Triiger client tell me : 
System.out.println(TimeZone.getDefault());
sun.util.calendar.ZoneInfo[id="Europe/Paris",offset=3600000,dstSavings=3600000,useDaylight=true,transitions=184,lastRule=java.util.SimpleTimeZone[id=Europe/Paris,offset=3600000,dstSavings=3600000,useDaylight=true,startYear=0,startMode=2,startMonth=2,startDay=-1,startDayOfWeek=1,startTime=3600000,startTimeMode=2,endMode=2,endMonth=9,endDay=-1,endDayOfWeek=1,endTime=3600000,endTimeMode=2]]

So what could be is wrong in my first server ?

I use postgresql 8.1 and the same pljava version (I think 1.3 ...).

thanks for your Help,

Eric

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 24 Nov 2008 08:33:36 -0800

Eric BOYER wrote:
> aladin at srv-aladin:
> boyere at footcrix:

These two JVM timezones are not the same.  useDaylight is different between.

Kris Jurka

---

From: Eric.Boyer at insa-toulouse.fr (Eric BOYER)
Date: Mon, 24 Nov 2008 17:41:48 +0100

OK so,
How get the same JVM timezone ?

Thanks

Kris Jurka a ?crit :
> _______________________________________________
> Pljava-dev mailing list
> Pljava-dev at pgfoundry.org
> http://pgfoundry.org/mailman/listinfo/pljava-dev
>
>   

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20081124/7334ba70/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 24 Nov 2008 21:16:39 -0500 (EST)

> How get the same JVM timezone ?

That depends on both your OS and JVM.  You could try setting the TZ 
environment variable.  It also seems a little odd that /etc/localtime is a 
text file on your systems.  Normally those are symlinks to binary zoneinfo 
files which aren't human readable.

Kris Jurka

---

From: Eric.Boyer at insa-toulouse.fr (Eric BOYER)
Date: Tue, 25 Nov 2008 15:23:13 +0100

my localtime is data but timezone is ascii

footcrix:/home/boyere# file /etc/localtime
/etc/localtime: timezone data
footcrix:/home/boyere# file /etc/timezone
/etc/timezone: ASCII text, with no line terminators

my server is a debian and jvm is 1.4.2

What could be diff?rent on my two servers, because I have twice :
# more /etc/timezone
Europe/Paris

Thanks for your Help

Kris Jurka a ?crit :
> environment variable.  It also seems a little odd that /etc/localtime 
> is a text file on your systems.  Normally those are symlinks to binary 
> zoneinfo files which aren't human readable.
>
> Kris Jurka
>