Subject: [Pljava-dev] pljava and jvm loading.

From: pierce at hogranch.com (John R Pierce)
Date: Sat, 24 Apr 2010 14:31:52 -0700

if I have a postgresql 8.4.3 cluster with several databases, and one of 
them has PL/Java installed using Sun JDK 1.5.0, when does the JVM get 
loaded?

    A) when a connection is made to the database that has pljava
    B) when any connection is made to any DB in the cluster
    C) when a pljava function is first invoked
    D) other?

(I note this is the -dev list... and my questions are more of the -user 
variety, but I don't know of any other lists... if there's a more 
appropriate forum for these questions, feel free to direct me...)

---

From: thomas at tada.se (Thomas Hallgren)
Date: Sun, 25 Apr 2010 00:34:11 +0200

Hi John,
The answer is to your question is C.

We only have a -dev list so user questions are just as welcome.

Regards,
Thomas Hallgren

On 04/24/2010 11:31 PM, John R Pierce wrote:
> if I have a postgresql 8.4.3 cluster with several databases, and one 
> of them has PL/Java installed using Sun JDK 1.5.0, when does the JVM 
> get loaded?
>
> (I note this is the -dev list... and my questions are more of the 
> -user variety, but I don't know of any other lists... if there's a 
> more appropriate forum for these questions, feel free to direct me...)
>
>
> _______________________________________________
> Pljava-dev mailing list
> Pljava-dev at pgfoundry.org
> http://pgfoundry.org/mailman/listinfo/pljava-dev