Subject: [Pljava-dev] Simple patch for java 1.6 compatibility

From: pmichalek at click.cz (Petr Michálek)
Date: Mon, 17 May 2010 18:57:48 +0200

Hello,

I'm sending patch that adds support for java 1.6.

New JDBC4(java 1.6) API simple throws exception NotSupoprtedOperation.

(patch -R -p2 <./pljava.diff)

Regards

Petr Michalek
-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pljava_1_4_0__java_1_6.diff
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100517/1c9aa843/attachment.ksh>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 17 May 2010 10:37:47 -0700

> New JDBC4(java 1.6) API simple throws exception NotSupoprtedOperation.

This diff is unreadable.  It seems like a diff between 1.4.0 and current 
CVS with a ton of changes from tabs to spaces.  We need a diff from 
current CVS that doesn't have irrelevant whitespace changes.

It's also not clear that such a patch is a great idea unless it retains 
the ability to still build with a 1.5 JDK as that still seems to be in use.

Kris Jurka

---

From: Jon.Roberts at asurion.com (Roberts, Jon)
Date: Mon, 17 May 2010 12:44:30 -0500

My development environment uses Java 1.6 and my production is still on 1.5.  When I create new class files, I compile with "-target 1.5" and everything works in both environments.  

Am I lucky that this works at all or is the way to use Java 1.6 with PL/Java?

Jon

-----Original Message-----
From: pljava-dev-bounces at pgfoundry.org [mailto:pljava-dev-bounces at pgfoundry.org] On Behalf Of Kris Jurka
Sent: Monday, May 17, 2010 12:38 PM
To: Petr Mich?lek
Cc: pljava-dev at pgfoundry.org
Subject: Re: [Pljava-dev] Simple patch for java 1.6 compatibility

Kris Jurka
_______________________________________________
Pljava-dev mailing list
Pljava-dev at pgfoundry.org
http://pgfoundry.org/mailman/listinfo/pljava-dev

---

From: thomas at tada.se (Thomas Hallgren)
Date: Mon, 17 May 2010 19:58:33 +0200

On 05/17/2010 07:37 PM, Kris Jurka wrote:
>
> It's also not clear that such a patch is a great idea unless it 
> retains the ability to still build with a 1.5 JDK as that still seems 
> to be in use.
>

J2SE 5.0 reached its End of Service Life on November 3, 2009. Not sure I 
see any compelling reasons to continue the support for it if Sun no 
longer does:

http://java.sun.com/javase/downloads/index_jdk5.jsp

What would stop anyone from upgrading to 1.6?

Regards,
Thomas Hallgren

---

From: pmichalek at click.cz (Petr Michálek)
Date: Mon, 17 May 2010 22:00:17 +0200

I'm sorry, whitespaces was added by Eclipse code formatter.
Cleaned diff against current CVS is attached.

Petr Michalek

-------------- next part --------------
An embedded and charset-unspecified text was scrubbed...
Name: pljava_cvs_20100517__java_1_6.diff
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100517/c6d3c46b/attachment.ksh>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 17 May 2010 17:39:45 -0700

> Cleaned diff against current CVS is attached.

This is slightly better, but still contains many, many whitespace 
changes.  Please review the patch prior to sending it again.

Kris Jurka