Subject: [Pljava-dev] Survey of pl/java usage

From: piotr.wasik at gmail.com (Piotr Wasik)
Date: Mon, 9 Jun 2014 15:32:58 +0100

Hi,

I would like to ask around the following questions, if you use pl/java:

1. dev or production? now or in the past?
2. is it heavy load? complex deployment like multiserver, replications or
cluster? web style, fast, sub-second queries or complex processing with
long queries?
3. what version of operating system, postgres and java do you use? pure
java or another language targetting jvm?
4. did you compile it yourself or used pre-packaged system?
5. a lot of unexpected pain? any showstoppers?

thanks in advance! I hope the survey will let us all find out about current
state of the project, so much needed in my opinion.... if you have jvm, you
have java and a good collection of other languages targetting jvm; we would
have jruby, jython, javascript, scheme, common lisp, clojure and scala "for
free".

Piotr
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20140609/8b12e5c5/attachment.html>

---

From: tim.clarke at manifest.co.uk (Tim Clarke)
Date: Mon, 09 Jun 2014 15:36:54 +0100

On 09/06/14 15:32, Piotr Wasik wrote:
> 2. is it heavy load? complex deployment like multiserver, replications
> or cluster? web style, fast, sub-second queries or complex processing
> with long queries?
> 3. what version of operating system, postgres and java do you use?
> pure java or another language targetting jvm?
> thanks in advance! I hope the survey will let us all find out about
> current state of the project, so much needed in my opinion.... if you
> have jvm, you have java and a good collection of other languages
> targetting jvm; we would have jruby, jython, javascript, scheme,
> common lisp, clojure and scala "for free".
>
> Piotr

Development and production continuously for at least the last 8 years I
think? Its not a complex deployment not particularly heavy workload just
repeated complex code run required that we found Java good at doing.
Currently Postgres 8.2 (we know its old - upgrade project is underway to
9.x) and heaven knows what version of pljava - I think I compiled it
myself. Some grief and misunderstanding getting it to work - it still
doesn't pass proper error returns back up the stack to our MS Access
front end for it.

-- 
Tim Clarke
IT Director
Manifest
9 Freebournes Court
Newland Street
Witham, Essex
CM8 2BL
England
 
Phone: +44 1376 503500
Direct: +44 1376 504510
Fax: +44 1376 503550
Email: tim.clarke at manifest.co.uk <mailto:tim.clarke at manifest.co.uk>
Web: http://www.manifest.co.uk
Skype: callto:tim.clarke

Manifest is the trading name of: Manifest Information Services Ltd: Registered in England Number 3401145 & The Manifest Voting Agency Ltd:
Registered in England Number 2920820. Registered Office at above address. VAT Registration Number: GB 700 1880 77
Copyright: This e-mail may contain confidential or legally privileged information.
If you are not the named addressee you must not use or disclose such information, instead please report it to: admin at manifest.co.uk 
Please see http://www.manifest.co.uk/legal/legal_notices.htm for further information.

---

From: michalek.petr at gmail.com (Petr Michálek)
Date: Mon, 9 Jun 2014 17:07:03 +0200

Hi,

> 1. dev or production? now or in the past?
Development and production since version of postgresql 8.0

> cluster? web style, fast, sub-second queries or complex processing with
I'm using it on two production servers on quite large DB. No problem under
heavy load.

> java or another language targetting jvm?
Linux, Postgresql 9.3, Java 7 (with little modifed java code because of
newer JDBC in Java 7; I will send on request)

> 4. did you compile it yourself or used pre-packaged system?
Compiled - It's easy ;-)

> 5. a lot of unexpected pain? any showstoppers?
I don't know of any.

I must say, that I have good experiences with authors, which always helped
me.

Petr
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20140609/78e0d711/attachment-0001.html>