Subject: [Pljava-dev] Compiling pljava with Microsoft Visual C

From: pega_olsok at yahoo.com (k o)
Date: Sun, 29 Jun 2014 14:45:50 -0700

I've forked the pljava git code and adapted it to build with Microsoft Visual C (leaving other platforms intact). It builds cleanly with Visual Studio 2010, 2012 and 2013 with Postgresql 8.4 through 9.3. Compiles cleanly with Postgresql 9.4 beta but has link issues with that version.

Any interest in having me submit a pull request to perhaps get this reviewed and incorporated into the main repository?

Ken
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20140629/95d54918/attachment.html>

---

From: thomas at tada.se (Thomas Hallgren)
Date: Mon, 30 Jun 2014 08:26:31 +0200

On 2014-06-29 23:45, k o wrote:
> I've forked the pljava git code and adapted it to build with Microsoft 
> Visual C (leaving other platforms intact). It builds cleanly with 
> Visual Studio 2010, 2012 and 2013 with Postgresql 8.4 through 9.3. 
> Compiles cleanly with Postgresql 9.4 beta but has link issues with 
> that version.
>
Awesome!

> Any interest in having me submit a pull request to perhaps get this 
> reviewed and incorporated into the main repository?
>
Yes, please do that.

- thomas

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20140630/5d16611a/attachment.html>