Subject: [Pljava-dev] PL/java kills unicode chars?

From: chap at anastigmatix.net (Chapman Flack)
Date: Sat, 19 Sep 2015 23:41:04 -0400

Srivatsan Ramanujam wrote:
> I believe PL/java is killing unicode characters (it is probably converting
> text to a byte stream and reading them as single byte characters - perhaps
> Latin-1 and not as UTF-8). ...

Well, this one has been open for a while. It's also in the github tracker,
https://github.com/tada/pljava/issues/21 which I've just updated with
confirming test code.

I think vatsan's comment (on the github issue) about
http://bugs.sun.com/view_bug.do?bug_id=5030776 is probably spot on.
We seem to handle the whole basic multilingual plane correctly
(nearly 64k codepoints), it's just all the planes above that getting
messed up.

Should be a straightforward fix, once I've found how many places those
not-really-UTF JNI functions are really used in the code.

-Chap

---

From: Chapman Flack <[email-masked]>
Date: Sun, 04 Oct 2015 19:54:24 -0400

> (nearly 64k codepoints), it's just all the planes above that getting

Pull request fixing this has been made at github.

-Chap

---

From: Chapman Flack <[email-masked]>
Date: Sat, 10 Oct 2015 17:38:24 -0400

> > I believe PL/java is killing unicode characters (it is probably
> > converting text to a byte stream and reading them as single byte
> > characters - perhaps Latin-1 and not as UTF-8). ...
>
> Well, this one has been open for a while...
>

Now fixed in the master branch.

-Chap
_______________________________________________
Pljava-dev mailing list
[email-masked]
http://lists.pgfoundry.org/mailman/listinfo/pljava-dev