Subject: [Pljava-dev] PL/Java 1.5.0-BETA2 announced (release candidate)

From: Chapman Flack <[email-masked]>
Date: Mon, 22 Feb 2016 20:38:45 -0500

PL/Java brings functions, triggers, and types in Java. 1.5.0, now in second
beta/release candidate, supports latest PostgreSQL and Java versions with a
range of improvements and fixes.

Project site:  http://tada.github.io/pljava/
Release notes: http://tada.github.io/pljava/releasenotes.html

Although PL/Java has historically used numbered betas and not "RC"
releases, this may be considered a 1.5.0 release candidate.

Changes since 1.5.0-BETA1:

* Microsoft Windows builds are now supported using both the Visual Studio
  and the MinGW-w64 toolchains.
* Fixed: two build/install issues on Mac OS X El Capitan (issues 94, 96)
* Fixed: parameter declaration generated for trigger function (issue 92)
* Fixed: source location missing for some annotation errors (issue 95)
* Fixed: pljava-api jar missing from installation jar

Please see the release notes for more details and the cumulative list of
changes.

Many thanks to all the individuals and organizations listed in the release
notes under Credits.
_______________________________________________
Pljava-dev mailing list
[email-masked]
http://lists.pgfoundry.org/mailman/listinfo/pljava-dev

---

From: Peter Brewer <[email-masked]>
Date: Fri, 26 Feb 2016 11:08:20 -0700

First of all... I can't tell you how glad I am to see the work on the 
new release! Thanks to everyone who is making this happen.

I am, however, having a few issues with building. My version info is:

OS : Ubuntu 14.04.4
Maven : 3.0.5
Java : OpenJDK 1.7.0_95 (i386)
PG: 9.3.11
gcc : 4.8.4

As you can see from the attached mvn log, things go pear shaped building 
the PL/Java backend native code.

Any ideas?

Peter

-- 
*********************************
Dr Peter Brewer
Research Associate
Rm 405, Bryant Bannister Building
Laboratory of Tree-Ring Research
1215 E Lowell St
Tucson AZ 85721
USA
Phone: +1 520 621 0753
Fax  : +1 520 621 8229
Email: [email-masked]
Web  : http://ltrr.arizona.edu
*********************************

---

From: Chapman Flack <[email-masked]>
Date: Fri, 26 Feb 2016 13:51:32 -0500

On 02/26/2016 01:08 PM, Peter Brewer wrote:
> First of all... I can't tell you how glad I am to see the work

Thank you!

> Athings go pear shaped building

Yes. :)

Most of what you are seeing there are [-Wsign-conversion]
warnings, and those are a miserable nuisance. It is not
really possible to tweak PL/Java's code to make them go
away, without actually changing .h files that come from
PostgreSQL itself, and when you try to read your log, all
those nuisance warnings get in the way of seeing the one
actual error that determined the shape of the fruit.

That one's on line 791:
[ERROR] /usr/include/postgresql/9.3/server/libpq/libpq-be.h:36:27: fatal
error: gssapi/gssapi.h: No such file or directory

It seems that your PostgreSQL package was build with gssapi
support, but the PL/Java build did not find the gssapi.h file
on your system. The solution may be as simple as finding a
package named gssapi-devel or some such, from your Ubuntu
package manager and installing it.

As far as the nuisance sign-conversion warnings, I recommend
using -Pwnosign on the mvn command line, to turn them off.
It is just easier to spot real problems that way.

After locating gssapi.h, would you be willing to do your
testing on 1.5.0-BETA2 rather than 1.6.0-SNAPSHOT?  It's
extra valuable to have testing focused on the imminent 1.5.0
release; 1.6.0-SNAPSHOT will be where somewhat more vaporous
future work will be happening.

Regards,
-Chap

---

From: Peter Brewer <[email-masked]>
Date: Fri, 26 Feb 2016 13:46:50 -0700

> error: gssapi/gssapi.h: No such file or directory
Looks like installing libkrb5-dev fixed this for me.  Thanks.

> future work will be happening.
Sure.  I've switched to 1.5.0-b2 but have a few more errors.  Logs attached.

Many thanks

Peter