Subject: [Pljava-dev] Build Fails on Windows 7

From: "Igal @ Lucee.org" <[email-masked]>
Date: Tue, 16 Feb 2016 23:08:11 -0800

Hi,

I'm trying to build PL/Java but am getting errors.

I am attaching here the verbose output of "mvn -e -X clean install", but 
it looks like the error section is as follows:

[ERROR] Failed to execute goal com.github.maven-nar:nar-maven-plugin:3.2.3:nar-validate (default-nar-validate) on project pljava-so: Cannot deduce version number from: -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal com.github.maven-nar:nar-maven-plugin:3.2.3:nar-validate (default-nar-validate) on project pljava-so: Cannot deduce version number from:
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
	at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
	at org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
	at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
	at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
	at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
	at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
	at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
	at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
	at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
	at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
	at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
	at java.lang.reflect.Method.invoke(Method.java:497)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
	at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
	at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
	at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.MojoFailureException: Cannot deduce version number from:
	at com.github.maven_nar.Linker.getVersion(Linker.java:270)
	at com.github.maven_nar.NarValidateMojo.narExecute(NarValidateMojo.java:64)
	at com.github.maven_nar.AbstractNarMojo.execute(AbstractNarMojo.java:302)
	at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
	at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
	... 20 more
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoFailureException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR]   mvn <goals> -rf :pljava-so

Any help would be greatly appreciated.

Thank you,

Igal Sapir
Lucee Core Developer
Lucee.org <http://lucee.org/>

You deleted an attachment from this message. The original MIME headers for the attachment were:
Content-Type: text/plain; charset=UTF-8;
 name="pljava-mvn.log"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="pljava-mvn.log"

_______________________________________________
Pljava-dev mailing list
[email-masked]
http://lists.pgfoundry.org/mailman/listinfo/pljava-dev

---

From: John R Pierce <[email-masked]>
Date: Wed, 17 Feb 2016 12:16:22 -0800

> I'm trying to build PL/Java but am getting errors.

building pljava on MS Windows is not currently supported, as noone has 
sat down and figured out how to get it all to play.

mostly, its the C components, they need to be compiled and linked with 
MSVC as they have to be called by the MSVC built Postgres, assuming 
you're using the EnterpriseDB distribution of Postgres for Windows...  
The MS C compiler and linker command lines are quite different.

-- 
john r pierce, recycling bits in santa cruz

---

From: Chapman Flack <[email-masked]>
Date: Wed, 17 Feb 2016 15:32:04 -0500

> sat down and figured out how to get it all to play.

Hey John, there is absolutely a "Building on Microsoft Windows
with Visual Studio" page in the release 1.5.0 docs, and it is
linked from the release notes.

Where Igal's issue comes in is in building with MinGW-64 rather
than MSVC, which I mentioned in the 1.5.0-BETA1 announcement was
an untested combination (because no one had stepped up to test it).

It was my mistake earlier today that I hit reply rather than
reply-all so subsequent exchanges with Igal haven't gone to the
list ... but in the best outcome, we will end up also knowing
how to build with MinGW-64 soon.

-Chap

---

From: John R Pierce <[email-masked]>
Date: Wed, 17 Feb 2016 12:42:06 -0800

> linked from the release notes.

oops, excuse me, I totally missed that.   I thought I'd seen discussions 
here a few weeks ago suggesting that was all "TBD".

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Wed, 17 Feb 2016 20:56:00 -0800

On 2/17/2016 4:33 PM, Chapman Flack wrote:
>
> It turns out nar-maven-plugin isn't as smart as I believed it
> to be. I had thought it would do some sort of linker discovery
> to find out if you were using MSVC or g++ ... but no ... it
> simply has a configuration file that lists default linkers
> for different arch-OS combinations:
>
> https://github.com/maven-nar/nar-maven-plugin/blob/7ba6ca9f3fc4385d360a8f326d20322cea1118a8/src/main/resources/com/github/maven_nar/aol.properties#L85
>
> ... that is, if you're on amd64-windows, it just *assumes* you
> are using msvc, unless you tell it otherwise.
>
> You might try editing pljava-so/pom.xml, finding the
> <linker> section, and adding <name>g++</name> inside it.
I wasn't sure to which <linker> I should add it, so for good measure I 
added <name>g++</name> to all three occurrences of <linker> (even though 
the first one if for Mac OS X and is obviously unrelated).
> That will probably not lead directly to a successful build
> (there will be more things to fix, remember you're the first
> to try this), but I would like to know if it gets you past the
> "cannot deduce version" error, and what breaks next. :)
So we made some progress, as you anticipated, and now the error is (full 
output attached):

[ERROR] Failed to execute goal 
com.github.maven-nar:nar-maven-plugin:3.2.3:nar-compile 
(default-nar-compile) on project pljava-so: NAR: Compile failed: gcc 
failed with return code 1 -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to 
execute goal com.github.maven-nar:nar-maven-plugin:3.2.3:nar-compile 
(default-nar-compile) on project pljava-so: NAR: Compile failed
     at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:212)
     at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
     at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
     at 
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:116)
     at 
org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:80)
     at 
org.apache.maven.lifecycle.internal.builder.singlethreaded.SingleThreadedBuilder.build(SingleThreadedBuilder.java:51)
     at 
org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:128)
     at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:307)
     at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:193)
     at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:106)
     at org.apache.maven.cli.MavenCli.execute(MavenCli.java:863)
     at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:288)
     at org.apache.maven.cli.MavenCli.main(MavenCli.java:199)
     at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
     at 
sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
     at 
sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
     at java.lang.reflect.Method.invoke(Method.java:497)
     at 
org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:289)
     at 
org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:229)
     at 
org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:415)
     at 
org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:356)
Caused by: org.apache.maven.plugin.MojoExecutionException: NAR: Compile 
failed
     at 
com.github.maven_nar.NarCompileMojo.createLibrary(NarCompileMojo.java:452)
     at 
com.github.maven_nar.NarCompileMojo.narExecute(NarCompileMojo.java:122)
     at 
com.github.maven_nar.AbstractNarMojo.execute(AbstractNarMojo.java:302)
     at 
org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:134)
     at 
org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:207)
     ... 20 more
Caused by: gcc failed with return code 1
     at 
com.github.maven_nar.cpptasks.compiler.CommandLineCompiler.compile(CommandLineCompiler.java:222)
     at 
com.github.maven_nar.cpptasks.compiler.CommandLineCompilerConfiguration.compile(CommandLineCompilerConfiguration.java:148)
     at com.github.maven_nar.cpptasks.CCTask$Core.run(CCTask.java:946)
You deleted an attachment from this message. The original MIME headers for the attachment were:
Content-Type: text/plain; charset=UTF-8;
 name="pljava-mvn-03.log"
Content-Transfer-Encoding: base64
Content-Disposition: attachment;
 filename="pljava-mvn-03.log"

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Wed, 17 Feb 2016 21:16:51 -0800

UPDATE:

I updated to 1.5.0-BETA1 as Chap suggested in his first reply, and added 
the <name>g++</name> to <linker>, and I'm getting different errors (full 
output attached, if you prefer that I do not attach large files please 
let me know).

The errors seem to be about missing header files from PostgreSQL. Here 
is a directory listing of C:/Apps/PGSQL-~1.0/include/server:

total 467
drwxr-xr-x 1 User None     0 Jan 31 22:31 .
drwxr-xr-x 1 User None     0 Jan 31 22:31 ..
drwxr-xr-x 1 User None     0 Jan 31 22:31 access
drwxr-xr-x 1 User None     0 Jan 31 22:31 bootstrap
-rw-r--r-- 1 User None 33994 Jan 31 22:22 c.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 catalog
drwxr-xr-x 1 User None     0 Jan 31 22:31 commands
drwxr-xr-x 1 User None     0 Jan 31 22:31 common
drwxr-xr-x 1 User None     0 Jan 31 22:31 datatype
-rw-r--r-- 1 User None   446 Jan 31 22:22 dynloader.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 executor
-rw-r--r-- 1 User None 30839 Jan 31 22:22 fmgr.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 foreign
-rw-r--r-- 1 User None 10778 Jan 31 22:22 funcapi.h
-rw-r--r-- 1 User None  3986 Jan 31 22:22 getaddrinfo.h
-rw-r--r-- 1 User None   688 Jan 31 22:22 getopt_long.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 lib
drwxr-xr-x 1 User None     0 Jan 31 22:31 libpq
drwxr-xr-x 1 User None     0 Jan 31 22:31 mb
-rw-r--r-- 1 User None 15926 Jan 31 22:22 miscadmin.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 nodes
drwxr-xr-x 1 User None     0 Jan 31 22:31 optimizer
drwxr-xr-x 1 User None     0 Jan 31 22:31 parser
-rw-r--r-- 1 User None 28468 Jan 31 22:22 pg_config.h
-rw-r--r-- 1 User None   328 Jan 31 22:22 pg_config_ext.h
-rw-r--r-- 1 User None 10819 Jan 31 22:22 pg_config_manual.h
-rw-r--r-- 1 User None 12954 Jan 31 22:22 pg_config_os.h
-rw-r--r-- 1 User None  1084 Jan 31 22:22 pg_getopt.h
-rw-r--r-- 1 User None   316 Jan 31 22:22 pg_trace.h
-rw-r--r-- 1 User None 29611 Jan 31 22:22 pgstat.h
-rw-r--r-- 1 User None   752 Jan 31 22:22 pgtar.h
-rw-r--r-- 1 User None  2309 Jan 31 22:22 pgtime.h
-rw-r--r-- 1 User None 27946 Jan 31 22:22 plpgsql.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 port
-rw-r--r-- 1 User None 13752 Jan 31 22:22 port.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 portability
-rw-r--r-- 1 User None 22511 Jan 31 22:22 postgres.h
-rw-r--r-- 1 User None  2109 Jan 31 22:22 postgres_ext.h
-rw-r--r-- 1 User None   763 Jan 31 22:22 postgres_fe.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 postmaster
drwxr-xr-x 1 User None     0 Jan 31 22:31 regex
drwxr-xr-x 1 User None     0 Jan 31 22:31 replication
drwxr-xr-x 1 User None     0 Jan 31 22:31 rewrite
-rw-r--r-- 1 User None   843 Jan 31 22:22 rusagestub.h
drwxr-xr-x 1 User None     0 Jan 31 22:31 snowball
drwxr-xr-x 1 User None     0 Jan 31 22:31 storage
drwxr-xr-x 1 User None     0 Jan 31 22:31 tcop
drwxr-xr-x 1 User None     0 Jan 31 22:31 tsearch
drwxr-xr-x 1 User None     0 Jan 31 22:31 utils
-rw-r--r-- 1 User None  2379 Jan 31 22:22 windowapi.h

Errors from Maven:

[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\AclId.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Any.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Array.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Backend.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\BigDecimal.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Boolean.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Byte.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Coerce.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.

0 / 51 files compiled...
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Composite.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Date.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Double.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/Exception.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\ErrorData.c:10:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Exception.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\ExecutionPlan.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Float.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Function.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/HashMap_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\HashMap.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.

0 / 51 files compiled...
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\HeapTupleHeader.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\InstallHelper.c:12:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Integer.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Invocation.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/HashMap_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Iterator.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\JNICalls.c:12:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\JavaWrapper.c:10:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\LargeObject.c:13:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.

0 / 51 files compiled...
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Long.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Oid.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\PgObject.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\PgSavepoint.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Portal.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Relation.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/SPI.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\SPI.c:10:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\SQLInputFromChunk.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\SQLInputFromTuple.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.

0 / 51 files compiled...
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\SQLOutputToChunk.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\SQLOutputToTuple.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\Session.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\Short.c:11:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.
[ERROR] In file included from C:\Apps\PGSQL-~1.0\include\server/c.h:1114:0,
[ERROR]                  from C:\Apps\PGSQL-~1.0\include\server/postgres.h:47,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/pljava.h:29,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/JNICalls.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/PgObject_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/Type_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\include/pljava/type/String_priv.h:12,
[ERROR]                  from C:\Workspace\git\pljava\pljava-so\src\main\c\type\String.c:9:
[ERROR] C:\Apps\PGSQL-~1.0\include\server/port.h:17:19: fatal error: netdb.h: No such file or directory
[ERROR] compilation terminated.

Thank you,

Igal
 name="pljava-mvn-04.log"
 filename="pljava-mvn-04.log"

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 00:29:33 -0500

On 02/18/2016 12:16 AM, Igal @ Lucee.org wrote:

> the <name>g++</name> to <linker>, and I'm getting different errors

netdb.h not found was the same error you were getting earlier,
you just had to scroll farther to see it. :)

> is a directory listing of C:/Apps/PGSQL-~1.0/include/server:

Could you attach an ls -R C:/Apps/PGSQL-~1.0/include/server/port

?

Thanks,
-Chap

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Wed, 17 Feb 2016 21:35:32 -0800

On 2/17/2016 9:29 PM, Chapman Flack wrote:
> netdb.h not found was the same error you were getting earlier, you 
> just had to scroll farther to see it. :) 
ohh! :s

> Could you attach an ls -R C:/Apps/PGSQL-~1.0/include/server/port ?
C:/Apps/PGSQL-~1.0/include/server/port:
aix.h
atomics
atomics.h
cygwin.h
darwin.h
freebsd.h
hpux.h
linux.h
netbsd.h
openbsd.h
pg_crc32c.h
sco.h
solaris.h
unixware.h
win32
win32.h
win32_msvc

C:/Apps/PGSQL-~1.0/include/server/port/atomics:
arch-arm.h
arch-hppa.h
arch-ia64.h
arch-ppc.h
arch-x86.h
fallback.h
generic.h
generic-acc.h
generic-gcc.h
generic-msvc.h
generic-sunpro.h
generic-xlc.h

C:/Apps/PGSQL-~1.0/include/server/port/win32:
arpa
dlfcn.h
grp.h
netdb.h
netinet
pwd.h
sys

C:/Apps/PGSQL-~1.0/include/server/port/win32/arpa:
inet.h

C:/Apps/PGSQL-~1.0/include/server/port/win32/netinet:
in.h

C:/Apps/PGSQL-~1.0/include/server/port/win32/sys:
socket.h
wait.h

C:/Apps/PGSQL-~1.0/include/server/port/win32_msvc:
dirent.h
sys
unistd.h
utime.h

C:/Apps/PGSQL-~1.0/include/server/port/win32_msvc/sys:
file.h
param.h
time.h

Chap, what time zone are you in?  I'm in Pacific myself.  Seems like 
you're always online.

Thanks,

Igal

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Wed, 17 Feb 2016 22:18:52 -0800

> Could you attach an ls -R C:/Apps/PGSQL-~1.0/include/server/port
So I copied netdb.h and the rest of the files from 
/include/server/port/win32 to /include/server/port
and now I'm getting new errors.

See attached output.

 name="pljava-mvn-05.log"
 filename="pljava-mvn-05.log"

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 01:30:12 -0500

On 02/18/16, Igal @ Lucee.org wrote:

> So I copied netdb.h and the rest of the files from /include/server/port/win32

Nah, don't do that ... see below.

> Chap, what time zone are you in?  I'm in Pacific myself.  Seems like you're
> always online.

I'm in Eastern, and I'm about to not be online for a while. :)

You might try
git remote update ; git checkout port/REL1_5_STABLE-BASE/mingw64

(make sure it's a clean checkout, none of your earlier changes to pom.xml,
also that you uncopy whatever postgres .h files you copied around)

then see what the build does. I'm sure there will still be errors,
but a step at a time ....

-Chap

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Thu, 18 Feb 2016 07:22:27 -0800

> git remote update ; git checkout port/REL1_5_STABLE-BASE/mingw64
So the last message is BUILD SUCCESS, but I see some [ERROR]s in the 
output,
and in the target directory all I have is a single file named 
pljava.app-1.6.0-SNAPSHOT-site.xml

See Maven output attached.

Thanks,

Igal
 name="pljava-mvn-06.log"
 filename="pljava-mvn-06.log"

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 10:47:33 -0500

> See Maven output attached.

Ok ... I see three things there:

#1  I was up too late last night, and I forgot to rebase the
    branch I created onto the right place, and now I'll have to
    do the thing no respectable git hacker ever does, and rebase
    it after publication. Phooey.

    Hey you guys on pljava-dev, nobody base stuff off this
    branch, ok?

#2  The build appears to have succeeded (as far as Maven thinks,
    anyway).

#3  There are curious warnings. Most are from the printf format
    checker, which seems to think jint and int are different
    widths, likewise jlong and long. This makes me uneasy.
    The other curious warnings are about the signal handlers
    not getting defined in Backend.c. That also bears looking
    into (which I won't have time for until later).

You might, cautiously, load it into your PostgreSQL database
and see what it does.  I would not (ahem) do this on a production
instance at this stage. :)

Could you reply with whatever is in your Java installation's
include/jni.h and include/*/jni_md.h files pertaining to the
declarations of jint and jlong?

-Chap

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Thu, 18 Feb 2016 08:28:15 -0800

> #2  The build appears to have succeeded (as far as Maven thinks,
I didn't realize earlier, but I do have jar files in pljava/target. I 
was looking earlier only at the top target directory
> declarations of jint and jlong?
I renamed jni.h to jni.h.txt (as I'm sure that some email clients will 
not like the .h extension) and attached here.

The ${java}/include/win32/jni_md.h is inline below:

#ifndef _JAVASOFT_JNI_MD_H_
#define _JAVASOFT_JNI_MD_H_

#define JNIEXPORT __declspec(dllexport)
#define JNIIMPORT __declspec(dllimport)
#define JNICALL __stdcall

typedef long jint;
typedef __int64 jlong;
typedef signed char jbyte;

#endif /* !_JAVASOFT_JNI_MD_H_ */

I must say that I'm impressed with your knowledge.  I've been writing 
Java code for a very long time now, and never even knew that there are 
.h files in ${java}/include

Igal

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 11:42:36 -0500

> was looking earlier only at the top target directory

The simplest jar to install from is the one in
pljava-packaging/target.

I guess the printf format warnings are about this:
https://sourceforge.net/p/mingw-w64/mailman/message/24633511/

ugh...

-Chap

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Thu, 18 Feb 2016 09:18:35 -0800

> The simplest jar to install from is the one in
Got it!
> https://sourceforge.net/p/mingw-w64/mailman/message/24633511/
Any thoughts what the implications of that would be?
Arithmetic overflows?  Unexpected results?

Does the use of a long integer come from pljava?

Can it be fixed by using int64_t from <stdint.h> as suggested in the 
link you posted?

Thanks,

Igal

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 13:46:33 -0500

> Arithmetic overflows?  Unexpected results?

Possibly bogus values appearing in messages printed from those
format strings (which I think only appear at debug levels anyway).

The most common solution I've seen other places is to define
macros for the correct printf formats that go with each type,
and ANSI-cpp-concat them into the format strings. Which is
clever but not very compatible with message localization.
So far there hasn't ever been any localization work on PL/Java,
but that doesn't mean I'm eager to make it harder....

Maybe it's better to just always use the printf format for the
widest known type, and widen-cast every corresponding argument.
That would be annoying but not get in the way of localization.
Of course that leads to the question, will every platform that
might want PL/Java have a printf that likes %lld?

The other warnings I saw were innocuous. Apparently PL/Java
just doesn't use the statementcancel, die, or quickdie handlers
when built on Windows. There is probably some sensible Windows
reason for that and I don't know what it is, but that #ifdef was
added in 2005 so if your build from today doesn't work, I don't
think that will be the reason. ;)

It's looking like you ought to start this thing up and take it
for a spin. If I were you I would initdb a new play database
for it before trying it out in, you know, payroll, but you
can't put off trying it forever. :)

-Chap

---

From: Chapman Flack <[email-masked]>
Date: Thu, 18 Feb 2016 19:43:21 -0500

>     Hey you guys on pljava-dev, nobody base stuff off this

I have rebased that branch where it belonged. Sorry about any
disruption. If you have pulled from it before, you may find
it easiest to just

git checkout master   # go back to master branch
git branch -d port/REL1_5_STABLE-BASE/mingw64 # delete branch
git remote update
git checkout port/REL1_5_STABLE-BASE/mingw64

-Chap

---

From: "Igal @ Lucee.org" <[email-masked]>
Date: Thu, 18 Feb 2016 16:55:49 -0800

> git checkout port/REL1_5_STABLE-BASE/mingw64
Thank you for the step-by-step :)

Igal