Subject: [Pljava-dev] plJava installation problems in Windows 7

From: rath.swaroop at gmail.com (swaroop)
Date: Thu, 17 Jun 2010 16:19:22 +0100

Hi

 I installed postgresql on windows 7 usign the standard installer. The
document at "http://wiki.tada.se/index.php/Windows_Installation" says that
pljava will be automatically installed.

I doubt if it was installed. I tried running install.sql script
in C:\Project\Postgre_installer\share\pljava. The following sql fails with
the error "ERROR:  could not load library
"C:/Project/Postgre_installer/lib/pljava.dll": The specified module could
not be found."

I made sure that jvm.dll is on my path.I am using jdk1.6. "C:\"Program Files
(x86)"\Java\jdk1.6.0_11\jre" Please help me here. I have been trying a lot
of workarounds but nothing seems to work.

CREATE FUNCTION sqlj.java_call_handler()
  RETURNS language_handler AS 'pljava'
  LANGUAGE C;

Regards
Swaroop
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100617/fb5a3d94/attachment.html>

---

From: Jon.Roberts at asurion.com (Roberts, Jon)
Date: Thu, 17 Jun 2010 10:30:22 -0500

I use Windows 7 64 bit with PostgreSQL 8.3 and Java 1.6.  I have the
following settings:

Environment Variables

CLASSPATH=C:\Program Files (x86)\PostgreSQL\8.3\share\pljava.jar

JAVA_HOME=C:\Program Files (x86)\Java\jre6

LD_LIBRARY_PATH=C:\Program Files (x86)\PostgreSQL\8.3\lib;C:\Program
Files (x86)\Java\jre6\lib\i386

PATH includes: C:\Program Files (x86)\Java\jre6\bin;C:\Program Files
(x86)\Java\jre6\bin\client;C:\Program Files (x86)\Java\jdk1.6.0_20\bin;

And in my postgresql.conf file

custom_variable_classes = 'pljava'

pljava.classpath = 'C:\Program Files
(x86)\PostgreSQL\8.3\share\pljava.jar'

Jon

From: pljava-dev-bounces at pgfoundry.org
[mailto:pljava-dev-bounces at pgfoundry.org] On Behalf Of swaroop
Sent: Thursday, June 17, 2010 10:19 AM
To: pljava-dev at pgfoundry.org
Subject: [Pljava-dev] plJava installation problems in Windows 7

Hi 

 I installed postgresql on windows 7 usign the standard installer. The
document at "http://wiki.tada.se/index.php/Windows_Installation" says
that pljava will be automatically installed.

I doubt if it was installed. I tried running install.sql script in
C:\Project\Postgre_installer\share\pljava. The following sql fails with
the error "ERROR:  could not load library
"C:/Project/Postgre_installer/lib/pljava.dll": The specified module
could not be found."

I made sure that jvm.dll is on my path.I am using jdk1.6. "C:\"Program
Files (x86)"\Java\jdk1.6.0_11\jre" Please help me here. I have been
trying a lot of workarounds but nothing seems to work.

  LANGUAGE C;

Regards

Swaroop

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100617/e4b44dc1/attachment.html>

---

From: rath.swaroop at gmail.com (swaroop)
Date: Thu, 17 Jun 2010 17:04:17 +0100

Hi Jon

 Thanks for the instructions. I tried everything below but no luck. It still
says cannot find pljava.dll.

Jon/Guys - Any other suggestion ?

Regards
Swaroop

On Thu, Jun 17, 2010 at 4:30 PM, Roberts, Jon <Jon.Roberts at asurion.com>wrote:

> LD_LIBRARY_PATH=C:\Program Files (x86)\PostgreSQL\8.3\lib;C:\Program Files
> (x86)\Java\jre6\lib\i386
>
> pljava.classpath = 'C:\Program Files (x86)\PostgreSQL\8.3\share\pljava.jar'
>
>
>
>
>
> Jon
>
> *From:* pljava-dev-bounces at pgfoundry.org [mailto:
> pljava-dev-bounces at pgfoundry.org] *On Behalf Of *swaroop
> *Sent:* Thursday, June 17, 2010 10:19 AM
> *To:* pljava-dev at pgfoundry.org
> *Subject:* [Pljava-dev] plJava installation problems in Windows 7
>
>
>
> Hi
>
>
>
> Files (x86)"\Java\jdk1.6.0_11\jre" Please help me here. I have been trying a
> lot of workarounds but nothing seems to work.
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100617/077404b2/attachment.html>

---

From: Jon.Roberts at asurion.com (Roberts, Jon)
Date: Thu, 17 Jun 2010 11:09:18 -0500

Do you have pljava.dll in C:\Program Files (x86)\PostgreSQL\8.3\lib ?

Jon

From: swaroop [mailto:rath.swaroop at gmail.com] 
Sent: Thursday, June 17, 2010 11:04 AM
To: Roberts, Jon; pljava-dev at pgfoundry.org
Subject: Re: [Pljava-dev] plJava installation problems in Windows 7

Hi Jon

 Thanks for the instructions. I tried everything below but no luck. It
still says cannot find pljava.dll.

Regards
Swaroop

On Thu, Jun 17, 2010 at 4:30 PM, Roberts, Jon <Jon.Roberts at asurion.com>
wrote:

Environment Variables

 

Jon

Hi 

  LANGUAGE C;

Regards

Swaroop

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100617/3c7c6433/attachment.html>

---

From: rath.swaroop at gmail.com (swaroop)
Date: Thu, 17 Jun 2010 17:13:52 +0100

Yes, I have it in the lib folder of my Pljava installation which is at -
C:/Project/Postgre_installer/lib/pljava.dll

Regards
Swaroop

On Thu, Jun 17, 2010 at 5:09 PM, Roberts, Jon <Jon.Roberts at asurion.com>wrote:

> *From:* swaroop [mailto:rath.swaroop at gmail.com]
> *Sent:* Thursday, June 17, 2010 11:04 AM
> *To:* Roberts, Jon; pljava-dev at pgfoundry.org
> *Subject:* Re: [Pljava-dev] plJava installation problems in Windows 7
>
>
>
> Hi Jon
>
>
>
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100617/83fc66da/attachment.html>