Subject: [Pljava-dev] Help Permission Denied

From: kpesmart at hotmail.com (Parisso Escamilla)
Date: Fri, 13 Jun 2008 13:14:13 -0500

My system is CentOS 5.1
Postgres 8.1-11
Pl/Java 1.4

Hi, i've benn trying to install a jar file  into the data base with select sqlj.install_jar ('file:/home/openxp/ServidorOXP/lib/sqlj.jar','openxp',true);.

I??m getting: ERROR: java.sql.SQLException: I/O exception reading jar file: /home/openxp/ServidorOXP/lib/sql.jar (Permission denied)

I don?t know where is the problem, every folder has permission to read and write, but i think the problem isn?t in that way.

Any idea??? Help please

Parisso Escamilla
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080613/5ff3e501/attachment.html>

---

From: books at ejurka.com (Kris Jurka)
Date: Mon, 16 Jun 2008 16:01:46 -0600

Parisso Escamilla wrote:
> My system is CentOS 5.1
> Postgres 8.1-11
> Pl/Java 1.4
>  
> Hi, i've benn trying to install a jar file  into the data base with 
> select sqlj.install_jar 
> ('file:/home/openxp/ServidorOXP/lib/sqlj.jar','openxp',true);.
>  
> I??m getting: ERROR: java.sql.SQLException: I/O exception reading jar 
> file: /home/openxp/ServidorOXP/lib/sql.jar (Permission denied)
>  
> I don?t know where is the problem, every folder has permission to read 
> and write, but i think the problem isn?t in that way.

Not sure, it could be a se-linux problem?

Kris Jurka

---

From: mark81 at gmail.com (Mark Mitchell)
Date: Mon, 16 Jun 2008 18:40:05 -0400

Whatever database user you are loading the file with must also have
READ access to both the folder and file.

If you are running as user postgres, you can always copy the jar file
to /tmp to load it.

-Mark

On Mon, Jun 16, 2008 at 6:01 PM, Kris Jurka <books at ejurka.com> wrote:
> _______________________________________________
> Pljava-dev mailing list
> Pljava-dev at pgfoundry.org
> http://pgfoundry.org/mailman/listinfo/pljava-dev
>