Subject: [Pljava-dev] Is openjdk supported?

From: devrim at gunduz.org (Devrim GÜNDÜZ)
Date: Sun, 07 Sep 2008 13:54:31 +0300

Hi,

I am trying to build pljava under Fedora 9, but getting some errors,
like:

The type SyntheticResultSet must implement the inherited abstract method
ResultSet.updateNClob(int, Reader)
----------
	public class SyntheticResultSet extends ResultSetBase
	             ^^^^^^^^^^^^^^^^^^

or

The type SyntheticResultSet must implement the inherited abstract method
ResultSet.updateNClob(String, NClob)

etc.

Is openjdk supported? How can I fix this?

Regards,
-- 
Devrim G?ND?Z, RHCE
devrim~gunduz.org, devrim~PostgreSQL.org, devrim.gunduz~linux.org.tr
                   http://www.gunduz.org
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080907/706345da/attachment.bin>

---

From: devrim at gunduz.org (Devrim GÜNDÜZ)
Date: Sun, 07 Sep 2008 14:11:53 +0300

> I am trying to build pljava under Fedora 9, but getting some errors,

BTW, even though I am getting some warnings, I can build it using
USE_GCJ=1.

Regards,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080907/e992b206/attachment.bin>

---

From: jurka at ejurka.com (Kris Jurka)
Date: Sun, 7 Sep 2008 09:33:42 -0700

> ResultSet.updateNClob(int, Reader)

Currently pljava only builds under a 1.4 or 1.5 JDK.  1.6 and up are  
not supported.

Kris Jurka

---

From: devrim at gunduz.org (Devrim GÜNDÜZ)
Date: Mon, 08 Sep 2008 00:04:51 +0300

> Currently pljava only builds under a 1.4 or 1.5 JDK.  1.6 and up are  

Thanks Kris.

Cheers,
-------------- next part --------------
A non-text attachment was scrubbed...
Name: signature.asc
Type: application/pgp-signature
Size: 197 bytes
Desc: This is a digitally signed message part
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20080908/834b64fb/attachment.bin>