Subject: [Pljava-dev] org.postgresql.util.PSQLException: ERROR: could not load library "/opt/pljava/pljava.so": libjvm.so: cannot open shared object file: No such file or directory

From: carrie_green at hotmail.com (Carolyn Green)
Date: Fri, 3 Oct 2008 05:18:35 +0000

I've done a lot of installs on x86 machines - no problems.

This is my first install on X64 using http://pgfoundry.org/frs/download.php/1591/pljava-x86_64-unknown-linux-gnu-pg8.3-1.4.0.tar.gz

I'm trying to run: java -cp postgresql.jar:pljava.jar:deploy.jar org.postgresql.pljava.deploy.Deployer -database adempiere -user adempiere -password  -install

The error I'm getting is:

org.postgresql.util.PSQLException: ERROR: could not load library "/opt/pljava/pljava.so": libjvm.so: cannot open shared object file: No such file or directory

I've see comments above making sure my jvm is 64 bit and it is:

adempiere at www:~$ /usr/lib/jvm/java-6-sun/bin/java -version
java version "1.6.0_06"
Java(TM) SE Runtime Environment (build 1.6.0_06-b02)
Java HotSpot(TM) 64-Bit Server VM (build 10.0-b22, mixed mode)

Any ideas?

Many thanks in advance...

Chris

_________________________________________________________________
Get all your favourite content with the slick new MSN Toolbar - FREE
http://clk.atdmt.com/UKM/go/111354027/direct/01/

---

From: daniel at notima.se (Daniel Tamm)
Date: Fri, 03 Oct 2008 08:52:53 +0200

I would start by checking my SELinux settings (/etc/sysconfig/selinux on 
RedHat). If they are enforced (which is default on many new Linux 
distributions) you'd probably not be allowed to load a shared object 
file from /opt/pljava.

I had this problem recently and almost went crazy before I found the 
cause of the problem.

Also make sure that libjvm.so is in your linking path (run 'ldconfig -v' 
and make sure it's there).

You can also check if pljava.so can find it's dependencies by running:

ldd /opt/pljava/pljava.so

For the x86_64 version of pljava I had to build it from source to get it 
working for some reason. I didn't get the precompiled to work.

/Daniel

Carolyn Green skrev:
> _______________________________________________
> Pljava-dev mailing list
> Pljava-dev at pgfoundry.org
> http://pgfoundry.org/mailman/listinfo/pljava-dev
>   

-- 
Daniel Tamm

Notima AB
L?rjungev?gen 6
136 69 Vendels? 

Tel: 08 - 776 31 30
Mobil: 073 - 786 97 37

---

From: carrie_green at hotmail.com (Carolyn Green)
Date: Sat, 4 Oct 2008 04:27:05 +0000

Hi Daniel,

Thanks for the ld tips - it helped me find the problem.  In ld.so.conf I was pointing to i386 of the jre.  Changing this to amd64 fixed it.

was:
/lib/i386
...

now:
/lib/amd64
...

Maybe the installation docs should state this change for amd64 hardware?

Many thanks,

Chris

----------------------------------------
> Date: Fri, 3 Oct 2008 08:52:53 +0200
> From: daniel at notima.se
> To: pljava-dev at pgfoundry.org
> Subject: Re: [Pljava-dev] org.postgresql.util.PSQLException: ERROR: could not load library "/opt/pljava/pljava.so": libjvm.so: cannot open shared object file: No such file or directory
>