Subject: [Pljava-dev] how to cancel a trigger operation

From: jcllario at hotmail.com (JOSE CARLOS MARTINEZ LLARIO)
Date: Fri, 19 Mar 2010 16:02:01 +0100

Hi all, Im sending this email again to the list because I really need to get an answer for
the pljava developers or someone who can help me.
 
Im wondering how to cancel a trigger operation.

Throwing an exception works but not in the way i need because the transaction is aborted.
 
I was looking for something that I already read in this list:
 
http://pgfoundry.org/pipermail/pljava-dev/2006/001000.html
http://pgfoundry.org/pipermail/pljava-dev/2006/001001.html
 
I was expecting someone already fixed that bug (i think its a bug because we can not use triggers in a proper way) because
these posts are from 4 years ago. 
 
Has someone already worked in this bug?
 
Thanks to all,
Best,
Jose
  		 	   		  
_________________________________________________________________
Escucha a quienes ya han probado Windows 7 ?Hazlo aqu?!
http://www.sietesunpueblodeexpertos.com/index_windows7.html
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100319/94704cf9/attachment.html>

---

From: Jon.Roberts at asurion.com (Roberts, Jon)
Date: Fri, 19 Mar 2010 10:31:45 -0500

I'll bite.  Why are you using triggers?  Why are you using Java for the trigger code?

Jon

From: pljava-dev-bounces at pgfoundry.org [mailto:pljava-dev-bounces at pgfoundry.org] On Behalf Of JOSE CARLOS MARTINEZ LLARIO
Sent: Friday, March 19, 2010 10:02 AM
To: pljava-dev at pgfoundry.org
Subject: [Pljava-dev] how to cancel a trigger operation

Thanks to all,

Best,

Jose

________________________________

Actual?zate gratis al nuevo Internet Explorer 8 y navega m?s seguro <http://www.microsoft.com/spain/windows/internet-explorer/default.aspx> 

-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100319/c55b35e9/attachment.html>

---

From: jcllario at hotmail.com (JOSE CARLOS MARTINEZ LLARIO)
Date: Fri, 19 Mar 2010 16:48:02 +0100

Hi Jon, for many reasons:

-All my project is java. It is a spatial extension for postgres and h2
-plpgsql is not working because i need to know the column names so i can use NEW.something or OLD.something..so and other stuff
 i have to use C or plpython or Pljava
-pljava works perfect with triggers but it has the problem i mentioned

so my question is related just with PLJAVA and Triggers. I already know how to solve that in C or other pl languages.
Cheers,
Jose

Subject: RE: [Pljava-dev] how to cancel a trigger operation
Date: Fri, 19 Mar 2010 10:31:45 -0500
From: Jon.Roberts at asurion.com
To: jcllario at hotmail.com; pljava-dev at pgfoundry.org

I?ll bite.  Why are you using triggers?  Why are you using Java
for the trigger code?

Jon

From: pljava-dev-bounces at pgfoundry.org
[mailto:pljava-dev-bounces at pgfoundry.org] On Behalf Of JOSE CARLOS
MARTINEZ LLARIO

 

Thanks to all,

Best,

Jose

Actual?zate
gratis al nuevo Internet Explorer 8 y navega m?s seguro

_________________________________________________________________
?Te gustar?a tener Hotmail en tu m?vil Movistar? ?Es gratis!
http://serviciosmoviles.es.msn.com/hotmail/movistar-particulares.aspx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100319/7b29364b/attachment.html>