Subject: [Pljava-dev] How to cancel a trigger operation

From: jcllario at hotmail.com (JOSE CARLOS MARTINEZ LLARIO)
Date: Mon, 15 Mar 2010 21:22:56 +0100

HI all,
Some of you knows how to cancel a trigger operation (insert, delete or update) from a trigger function in PLJAVA?
In PLPGSQL I know I can get it returning a null value. I tried several things in PLJAVA but i couldnt make it.
Thanx a lot,
Best,
Jose Martinez

_________________________________________________________________
Recibe en tu m?vil un SMS con tu Hotmail recibido. ?Date de alta ya!
http://serviciosmoviles.es.msn.com/
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100315/44b16d0d/attachment.html>

---

From: jcllario at hotmail.com (JOSE CARLOS MARTINEZ LLARIO)
Date: Tue, 16 Mar 2010 10:35:03 +0100

Hi Andres,
Thanks for the answer. Throwing an exception works but not in the way i need because the transaction is aborted.

I was looking for something that I already read in this list:

http://pgfoundry.org/pipermail/pljava-dev/2006/001000.html
http://pgfoundry.org/pipermail/pljava-dev/2006/001001.html

I was expecting someone already fixed that bug (i think its a bug because we can not use triggers in a proper way) because
these posts are from 4 years ago. 

Has someone already worked in this bug?

Thanks to all,
Best,
Jose

_________________________________________________________________
?Te gustar?a tener Hotmail en tu m?vil Movistar? ?Es gratis!
http://serviciosmoviles.es.msn.com/hotmail/movistar-particulares.aspx
-------------- next part --------------
An HTML attachment was scrubbed...
URL: <http://lists.pgfoundry.org/pipermail/pljava-dev/attachments/20100316/895e5b7a/attachment.html>